# Table of Contents

## Chapter 1 Introduction
- ShoreTel Communicator for Windows .................................................. 1
- ShoreTel Communicator Access Levels .................................................... 1
- System Requirements .............................................................................. 3
  - Operating Systems ................................................................................... 3
  - Hardware Requirements ......................................................................... 4
  - Video Requirements .............................................................................. 4

## Chapter 2 Getting Started
- Introduction .............................................................................................. 5
- Installation ................................................................................................ 5
  - Normal Installation .................................................................................. 5
  - 64-bit Platform Support .......................................................................... 6
- Access to ShoreTel Communicator ............................................................. 6
  - Starting ShoreTel Communicator .............................................................. 6
  - Exiting ShoreTel Communicator .............................................................. 7
  - Closing and Opening ShoreTel Communicator ........................................ 7
  - Active Directory Integration .................................................................. 8
    - Initial Configuration ............................................................................... 8
    - Logging into ShoreTel Communicator ................................................ 8
    - User Name – Telephony Options panel ............................................. 8
- Usage Preferences ..................................................................................... 9
  - Language Selection .................................................................................. 9
  - Sound Preferences .................................................................................. 9
  - Configuring the External Number Prefix ............................................. 10

## Chapter 3 Accessing ShoreTel Communicator
- ShoreTel Communicator Windows ............................................................ 11
  - Window Types .......................................................................................... 11
    - Main Window .......................................................................................... 11
    - Satellite Window ................................................................................... 12
    - Alerts ..................................................................................................... 12
  - Window Components .............................................................................. 13
    - Application Button ............................................................................... 13
    - Main Menu ............................................................................................. 13
    - Assignment Bar .................................................................................... 14
    - Toolbars ................................................................................................ 14
    - QuickDialer ........................................................................................... 14
    - Active Call Area and Call Cells ........................................................... 16
    - Content Area .......................................................................................... 17
    - Status Bar .............................................................................................. 17
  - Manipulating ShoreTel Communicator Windows .................................... 17
    - Separating Windows .............................................................................. 17
    - Combining Two Satellite Windows ..................................................... 17
    - Moving a Satellite Window into the Main Window ............................. 21

---

**ShoreTel 12**

---
Viewing Modes ................................................................. 22
   Normal Mode .................................................................. 22
   Miniature ..................................................................... 22
   Docked ......................................................................... 22
   System Tray .................................................................. 23
Viewers ............................................................................. 24
Toolbar Customization ....................................................... 25

CHAPTER 4 VOICE CALLS ......................................................... 27

Introduction ..................................................................... 27
Extension Assignment ......................................................... 27
   Primary Device ................................................................ 27
   SoftPhone .................................................................... 28
   Extension Assignment .................................................... 28
      Description .................................................................. 28
      Activating Extension Assignment ............................... 28
      Configuring Extension Assignment ............................. 29
Configuring Device Options ............................................... 29
   Handsfree Mode ............................................................. 29
   Call Stack Size .............................................................. 30
   Specifying the Default Auto Off-Hook Device ............... 30
   Suppressing the Call Waiting Tone ................................. 30
Making a Call ..................................................................... 31
Managing Incoming Calls .................................................... 33
   Inbound Call Signals ...................................................... 33
   Answering Calls ........................................................... 33
      Answering Calls to your Extension ............................... 33
      Answering Calls to a Different Extension ................. 33
      Answering the Night Bell Extension ......................... 34
   Rerouting Inbound Calls ................................................ 35
      Sending a Call to Voice Mail .................................... 35
      Sending a Call to the Automated Attendant ............. 35
      Transferring a Call to a Directory Contact ............... 35
Automated Call Handling .................................................. 36
   Configuring the Call Handling Modes ......................... 36
   Setting the Active Call Handling Mode ...................... 36
   Call Handling Mode Warnings ...................................... 38
   Call Handling Mode Delegation .................................... 38
Personalized Call Handling ................................................ 39
   Licensing ..................................................................... 40
   Description .................................................................. 40
   Implementing Personalized Call Handling ................. 42
Find Me ............................................................................. 47
   Activating Find Me ....................................................... 48
   Configuring Find Me ..................................................... 48
   Configuring Announced Find Me ................................. 48
IM Responses to Inbound Calls .......................................... 48

During an Active Call ........................................................ 49
Adjusting the Volume ......................................................... 50
Handling Multiple Calls .................................................... 50
Call Transfer .................................................................... 50
   Types of Call Transfers ............................................... 50
   Using the Transfer Panel .............................................. 51
CHAPTER 5 INSTANT MESSAGING .............................................. 73

Description ................................................................. 73
The Instant Message Window ........................................... 73
Conducting an IM Conversation ........................................ 74
   Initiating an IM Conversation .................................... 74
   Receiving the First IM of a Conversation ......................... 75
   Creating and Sending a Message ................................. 76
   Adding a Participant to a Chat Session ......................... 76
   Terminating an Instant Message Session ....................... 76
Configuring Instant Messaging ....................................... 76
   Privacy and Control Access ...................................... 76
   Instant Messaging Options ...................................... 76
Chapter 6 Presence .................................................. 77
Description .......................................................... 77
Presence Types ....................................................... 77
  Telephony Presence .................................................. 77
  IM Presence .......................................................... 78
  Combined Presence ............................................... 80
Displaying Presence ................................................ 80
  Configuring Display Options .................................... 80
  Presence Change Alerts .......................................... 81
IM Presence Privacy .................................................. 82
  Privacy States ........................................................ 82
  Responding to Presence Access Requests .................... 82
  Managing the Privacy Access List ............................. 83
  Access Request Settings ....................................... 84

Chapter 7 SoftPhone ............................................ 85
Introduction .......................................................... 85
Using the SoftPhone ............................................... 85
  Assigning SoftPhone to Your Extension ....................... 85
  Managing SoftPhone Calls through ShoreTel Communicator 86
  Keypad .............................................................. 86
  Muting the SoftPhone ........................................... 86
Configuring SoftPhone ............................................ 86

Chapter 8 Managing Address Entries. ...................... 87
Introduction .......................................................... 87
Directory Viewer ..................................................... 87
  Directory Components ......................................... 87
  Managing the Directory ......................................... 89
    Exporting the Directory to a .csv File ...................... 89
    Importing Directory Entries from a File ................. 89
    Adding Directory Entries to the Contact List .......... 90
  Managing Personal Directory Entries ....................... 90
  Initiating Calls through the Directory Viewer ......... 92
Contact Viewer ...................................................... 93
  Contacts ........................................................... 93
  Contact Viewer Components ................................ 94
    Viewer Modes .................................................. 94
    Viewer Components .......................................... 95
  Managing Contacts ............................................. 96
    Adding Entries to the Contact List ....................... 96
    Using Contacts Quick Dialer ............................... 97
    Editing a Contact Entry .................................... 98
    Removing a Contact Entry .................................. 99
  Contact List Operations ..................................... 99
Importing Contacts from other applications ............. 99
  Implementation .................................................. 100
    Editing the Registry ......................................... 100
    Placing the File .............................................. 101
    Viewing the Contacts ....................................... 101
  File Properties ................................................ 102
1.1 ShoreTel Communicator for Windows

ShoreTel Communicator, formerly known as Call Manager, is the end-user application for all users across an organization, whether an operator, a Contact Center agent, a knowledge worker, or a road warrior. ShoreTel Communicator for Windows is the application for the Windows operating system.

1.2 ShoreTel Communicator Access Levels

While everyone on the ShoreTel system uses the same ShoreTel Communicator, different types of users will have access to different feature capabilities based on their Access Level:

- **Personal Access** comes standard with the ShoreTel UC system and offers a rich set of features designed for ease of use at the desktop.
- **Professional Access** offers advanced features such as IM, softphone, personalized call handling and high-quality video for users who depend on constant communication in their work environment.

ShoreTel includes SoftPhone and Standard Resolution Video licenses with the purchase of a Professional Access License. Users must install these licenses to access SoftPhone and VGA Video.

**Workgroup Agent Access** enables call center agents to perform automatic call distribution (ACD) functions such as viewing calls in queue, log into queue, and accessing team mailboxes.

**Workgroup Supervisor Access** helps call center supervisors to monitor all their agent and queue activity. Supervisors can also monitor, coach, and barge into call center sessions.

**Operator Access** provides features such as busy call appearance and call pick up for operators, executive administrators and receptionists. Built-in tools include IM and presence information.

**Mobile Access** offers mobile users access to familiar functions such as ShoreTel QuickDialer, corporate and address book contacts, and visual voicemail. Users can make their mobile phone the enterprise extension on the fly, and easily change their call handling settings to meet their mobile requirements.
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Remote Call Control and Presence</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Co-locators</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
</tr>
<tr>
<td>Call answer: hold, conference</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
</tr>
<tr>
<td>Call history: redial history</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
</tr>
<tr>
<td>Speed dial</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
</tr>
<tr>
<td>Advanced call management: intercom, pie, pick-up, silent monitor, back, whisper, transfer, ring, overhead, page, telephone presence change alert</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
</tr>
<tr>
<td>A-list in A-list telephone presence</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
</tr>
<tr>
<td>Call handling mode</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
</tr>
<tr>
<td>Call handling mode delegation to give permissions</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
</tr>
<tr>
<td>Call handling mode delegation to change somebody else’s</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
</tr>
<tr>
<td>Personalized call handling based on who is calling, when the call arrives or based on the user’s call handling mode</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
</tr>
<tr>
<td>Up to 6 party audio conference (pod on pod)</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
</tr>
<tr>
<td>Bridle call appearance: multiple viewing/docking options, call appearance navigation, call state control/transfer, &amp; properties, call pickup</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
</tr>
<tr>
<td>Share call appearances</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
</tr>
<tr>
<td>Call drop and drop to contact viewer</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
</tr>
<tr>
<td>Programmable buttons</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
</tr>
<tr>
<td>Visual Voicemail</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
</tr>
<tr>
<td>Standard/integrated voicemail: Caller ID name and number, date, time and duration, play, call back, delete</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
</tr>
<tr>
<td>Advanced voicemail playback: compose, forward, forward via email, move back/forth, reply, reply all, voice mail with folders</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
</tr>
<tr>
<td>Voicemail pre view</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
</tr>
<tr>
<td>Mass notification and escalation</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
</tr>
<tr>
<td>Outlook Integration</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Voicemail inbox</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
</tr>
<tr>
<td>Contact integration</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
</tr>
<tr>
<td>Calendar-based call handling mode</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
</tr>
<tr>
<td>Contact Viewer</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Telephone presence</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
</tr>
<tr>
<td>Detailed telephone presence (finding status, connect time)</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
</tr>
<tr>
<td>Instant messaging presence</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
</tr>
<tr>
<td>Instant messaging presence change alert</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
</tr>
<tr>
<td>Presence priority management</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
</tr>
<tr>
<td>Presence movement and multiparty IM</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
</tr>
<tr>
<td>Client side IM logging</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
</tr>
<tr>
<td>Mobility</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Extensions assignment: Assign to internal numbers or external telephones (e.g., home, etc.)</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
</tr>
<tr>
<td>Find Me</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
</tr>
<tr>
<td>SoftPhone: Number pad hot field saving, quick change from phone to SoftPhone, 1-2-1, 3-2-2, 3-2-2 Caller, GPS-based change of call handling mode or extension assignment</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
</tr>
<tr>
<td>Bluetooth-based change of call handling mode or extension assignment</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
</tr>
<tr>
<td>Audio and Web Conferencing</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Launch of the Converged Conference Console (required)</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
</tr>
<tr>
<td>Audioshare Web conferencing (required)</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
</tr>
<tr>
<td>Video</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>High-quality, low latency video, H.264/SVC protocol, 640 x 480 (WxH), up to 30 frames per second</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
</tr>
<tr>
<td>Workgroup and Contact Center</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Queue monitoring</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
</tr>
<tr>
<td>Queue alerts</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
</tr>
<tr>
<td>Workgroup mailbox</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
</tr>
<tr>
<td>Agent monitoring</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
</tr>
<tr>
<td>Contact Center integration</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
<td>★</td>
</tr>
</tbody>
</table>

* ShoreTel Communicator for Web is available with the Personal Access Level, with the exception of this feature.
** Requires ShoreTel Converged Conference.
*** Device dependent.
1.3 System Requirements

1.3.1 Operating Systems

ShoreTel Communicator for Windows is supported on the following operating systems:

Windows Client Operating System
- Windows XP Professional, 32-bit, SP3
- Windows Vista Business, 32-bit, SP2
- Windows Vista Enterprise, 32-bit, SP2
- Windows Vista Enterprise, 64-bit, SP2
- Windows 7 Professional, 32-bit
- Windows 7 Enterprise, 32-bit
- Windows 7 Professional, 64-bit
- Windows 7 Enterprise, 64-bit
- Unicode support (Double Byte Character)

Windows Terminal Server
- Windows 2008 Terminal Server, 32-bit, SP2
- Windows 2008 Terminal Server, 64-bit

Citrix
- XenApp 5.0 on Windows 2008-32-bit (Isolation mode is not supported)

Note: ShoreTel Communicator integration with ShoreTel Contact Center does not support XenApp 4.5 and 5.0

For current information about support for specific Citrix versions and ShoreTel Communicator features on the Citrix platform, refer to the Citrix product bulletin.
1.3.2 Hardware Requirements

Computer Hardware requirements for running ShoreTel Communicator depend on the ShoreTel Communicator type and the use of video. Table 1-1 displays the minimum recommended configuration for computers running ShoreTel Communicator.

<table>
<thead>
<tr>
<th>ShoreTel Communicator Version</th>
<th>Processor</th>
<th>RAMa</th>
<th>Disk Spaceb</th>
<th>Available RAM</th>
</tr>
</thead>
<tbody>
<tr>
<td>ShoreTel Communicator with Personal Access</td>
<td>Pentium 3 – 800 MHz</td>
<td>1 GB</td>
<td>1 GB</td>
<td>100 MB</td>
</tr>
<tr>
<td>ShoreTel Communicator with Professional Access</td>
<td>Pentium 4 – 2.0 GHz</td>
<td>1 GB</td>
<td>1 GB</td>
<td>150 MB</td>
</tr>
<tr>
<td>ShoreTel Communicator Agent, Supervisor, Operator Access (&lt;40 extension presences)</td>
<td>Pentium 4 – 2.0 GHz</td>
<td>1 GB</td>
<td>1 GB</td>
<td>150 MB</td>
</tr>
<tr>
<td>ShoreTel Communicator Agent, Supervisor, Operator Access (&lt;500 extension presences)</td>
<td>Pentium 4 – 3.0 GHz</td>
<td>1 GB</td>
<td>1 GB</td>
<td>150 MB</td>
</tr>
<tr>
<td>All Versions, VGA Video</td>
<td>Dual-Core 1.6 GHz</td>
<td>1 GB</td>
<td>1 GB</td>
<td>150 MB</td>
</tr>
<tr>
<td>All Versions, XGA Video</td>
<td>Core 2 Quad 2.4 GHz</td>
<td>1 GB</td>
<td>1 GB</td>
<td>150 MB</td>
</tr>
</tbody>
</table>

Table 1-1 Client Device Hardware Requirements

a. Lists ShoreTel Communicator memory requirements during normal operation. When running other office applications on the PC in addition to ShoreTel Communicator, memory recommendations are 512 MB (XP) or 1 GB (Vista).
b. Disk space requirement is for installation on a system without .NET Framework installed previously. Once installed, ShoreTel Communicator requires less than 100MB of disk space.

1.3.3 Video Requirements

Computers configured for video calls require the following:

- **VGA Video**: Graphic Card with 64 MB of VRAM, DirectX 9.0c-compatible
- **XGA Video**: Graphic Card with 256 MB of VRAM, DirectX 9.0c-compatible

Video calls require the following bandwidth:

- **VGA**: 600 kbps
- **XGA**: 1.2 Mbps
Chapter 2

Getting Started

2.1 Introduction

This chapter discusses installation issues and describes application preferences.

2.2 Installation

ShoreTel Communicator is a .NET Framework 2.0 or higher application. The ShoreTel Communicator installer automatically downloads the correct .NET version if it is not present during the upgrade or install. Users are then prompted to accept the End User License Agreement from Microsoft to proceed with the .NET installation. Internet connectivity is required during the installation process.

2.2.1 Normal Installation

Use the ShoreTel Communicator Install HTML page to install ShoreTel Communicator, as shown in Figure 2-1. Contact your system administrator for the URL of your ShoreTel Communicator Installation page.

Figure 2-1 ShoreTel Communicator Installation Page
2.2.2 64-bit Platform Support

ShoreTel 11 extends support for running ShoreTel Communicator on 64-bit platforms to include Microsoft Windows 7 – Professional and Enterprise editions.

ShoreTel Communicator disables SoftPhone, Video, and Outlook integration while running in Terminal server mode. These functions remain unavailable when running ShoreTel Communicator on 64-bit WTS platforms.

NOTE: All ShoreTel Communicator features available on the 32-bit Vista platform remain available when running the application on the 64-bit operating system with the following exceptions:
• XGA Video.

NOTE: ShoreTel supported XGA camera is not compatible with 64-bit Vista client.

Installing ShoreTel Communicator on 64-bit Windows running Citrix or Windows Terminal Server requires the following steps:

Step 1 Install .Net Framework for 64-bit Windows Citrix machines – Version 2.0 or higher.
.Net Framework is not supplied with the ShoreTel installation software. This software is available from Internet sources or from your software vendor.

Step 2 Install ShoreTel Communicator.

Step 3 Access Control Panel -> Phone and Modem -> Advanced (tab) and remove ShoreTel Remote TAPI Service Provider.

Step 4 Run TSPInstall.exe
TSPInstall.exe is provided with the ShoreTel installation software.

Installing ShoreTel Communicator on a 64-bit platform places files in the following folders:
• The default location is C:\Program Files (x86)
• The location of 32-bit client dll files is C:\Windows\SysWow64

2.3 Access to ShoreTel Communicator

2.3.1 Starting ShoreTel Communicator

Start ShoreTel Communicator by clicking the ShoreTel Communicator application icon that was placed on your desktop or Start menu when ShoreTel Communicator was installed. You can also configure ShoreTel Communicator to automatically start when you log into Windows.
To configure ShoreTel Communicator to start when you log into Windows:

Step 1  Open Options and Preferences by performing one of the following:
- Select Tools -> Options from the Main menu.
- Click the Application Button and select Options.
- Right click the ShoreTel icon in the System Tray and select Options.
- Press Ctrl+O.

Step 2  Select General in the panel on the left side of the window.

Step 3  Mark the Start ShoreTel Communicator when you login to Windows checkbox.

Section A.2.1 on page 175 describes the Options and Preferences: General panel.

2.3.2 Exiting ShoreTel Communicator

Exiting ShoreTel Communicator terminates program execution. ShoreTel Communicator must be running to monitor the system for inbound messages, view presence, or engage in instant message conversations.

To exit ShoreTel Communicator, right click the ShoreTel icon in the System Tray icon and select Exit.

2.3.3 Closing and Opening ShoreTel Communicator

Closing and opening ShoreTel Communicator manipulates the ShoreTel Communicator window without affecting the run status. Closing ShoreTel Communicator removes the ShoreTel Communicator window from the monitor while ShoreTel Communicator continues to run in the background. ShoreTel Communicator continues to monitor the system for inbound voice calls or instant messages. The System Tray displays the ShoreTel icon when ShoreTel Communicator is in operation, regardless if the ShoreTel Communicator window is open or closed.

Opening ShoreTel Communicator displays the ShoreTel Communicator window on your monitor.

To Close the ShoreTel Communicator window, perform one of the following:
- Click the Application Button and select Close.
- Click the Exit icon on the top right corner of the ShoreTel Communicator window.
- Press Alt+F4.

To Open the ShoreTel Communicator window, perform one of the following:
- Right click the ShoreTel icon in the System Tray and select Show ShoreTel Communicator.
- Double click the ShoreTel icon in the System Tray.
- ShoreTel Communicator opens when you receive a voice call or instant message.
2.3.4 **Active Directory Integration**

When ShoreTel Active Directory (AD) Integration is enabled, access to ShoreTel Communicator is available to all system users, including users without domain accounts or not configured as ShoreTel AD users.

2.3.4.1 **Initial Configuration**

When installing ShoreTel Communicator, users authenticated through AD are not queried for their credentials; they are immediately prompted for the server name after which wizard panels guide them through the setup process.

Users that are not authenticated through AD are required to enter their name, password and server name. After verifying the user's credentials, ShoreTel Communicator guides the user through the setup process.

2.3.4.2 **Logging into ShoreTel Communicator**

Attempts to log into ShoreTel Communicator after the initial setup are handled on the basis of the user's AD configuration. Active Directory users are authenticated by SSO through the verification of their AD credentials. Users not configured for Active Directory are authenticated against their ShoreTel username and password, as previously loaded through their ShoreTel Communicator account. In either case, users are typically not required to re-enter their username or password each time they open ShoreTel Communicator.

2.3.4.3 **User Name – Telephony Options panel**

The User Name data field at the top of the Options and Preferences: Telephony panel displays the User name of the ShoreTel Communicator account. This field is *read only* for users authenticated through AD credentials, as shown in Figure 2-2.

![Figure 2-2 Telephony Options – User Name specified through AD](image)
2.4 Usage Preferences

2.4.1 Language Selection

ShoreTel Communicator displays menus in all languages available on systems that support multiple languages. You can also specify the language through which the ShoreTel system communicates voice mail audio commands and ShorePhone display messages.

To specify the languages ShoreTel Communicator uses to display menu information:

Step 1 Open Options and Preferences by performing one of the following:
- Select Tools -> Options from the Main menu.
- Click the Application Button and select Options.
- Right click the ShoreTel icon in the System Tray and select Options.
- Press Ctrl+O.

Step 2 Select Languages in the menu on the left side of the window.

Step 3 Select the desired options from the following drop-down menus.
- The Language used in ShoreTel Communicator parameter specifies the language displayed in the panels.
  - The System Default option refers to the default language as configured on your ShoreTel system.
  - The Language used by voice mail prompts and IP phones specifies the language the system uses to display IP Phone messages and for voice mail audio prompts.

Step 4 Exit and Re-open ShoreTel Communicator.

Section A.2.18 on page 198 describes the Options and Preferences: Languages panel.

2.4.2 Sound Preferences

You can configure ShoreTel Communicator to play audio wav files when you receive a message or call. Specific events that can generate an audio alert include:

New Voice Message
Incoming Call
Incoming Instant Message
Incoming Monitored Call
Incoming Bridged Call Appearance
Incoming Agent Call
Queue Monitor Alert

To specify the wav files that ShoreTel Communicator plays to signal an audio alert:

Step 1 Open Options and Preferences by performing one of the following:
- Select Tools -> Options from the Main menu.
- Click the Application Button and select Options.
- Right click the ShoreTel icon in the System Tray and select Options.
- Press Ctrl+O.
Step 2 Select Sounds in the menu on the left side of the window.

Step 3 Select the desired event from the event table at the top of the window, located right of the menu.

Step 4 Press the Browse button to search for the desired wav file.

Section A.2.17 on page 197 describes the Options and Preferences: Sounds panel.

### 2.4.3 Configuring the External Number Prefix

The Trunk Access Code (TAC) is the prefix you must dial before entering a phone number when calling a device external to your ShoreTel system. The prefix that you dial depends on the trunk that routes your calls. Consult your system administrator for information about your system configuration.

To specify the Trunk Access Code that ShoreTel Communicator uses to route your external calls:

**Step 1** Open the Options and Preferences window by performing one of the following:

- Select Tools -> Options from the Main menu.
- Click the Application Button and select Options.
- Right click the ShoreTel icon in the System Tray and select Options.
- Press Ctrl+O.

**Step 2** Select Telephony in the menu on the left side of the window.

**Step 3** Select the desired prefix from the Prefix to dial external number drop-down menu.

Section A.2.11 on page 188 describes the Options and Preferences: Telephony panel.
Accessing ShoreTel Communicator

3.1 ShoreTel Communicator Windows
ShoreTel Communicator windows provide access to ShoreTel client services. In addition to initiating and managing communication sessions, you can view the presence of other users, adjust your presence, perform Workgroup and Contact Center functions, and access contact information, voice mail, and call history from these windows.

3.1.1 Window Types
ShoreTel Communicator windows provide access to client application features, inform the user of incoming messages, and display communication session status. ShoreTel Communicator windows include the Main Window, Satellite Windows, and Alerts.

3.1.1.1 Main Window
The Main window displays buttons, bars, and menus through which users view status, configure settings, manage voice mail, and initiate communication sessions. The title bar of the Main Window indicates the user’s extension.

Figure 3-1 displays an example of the main window where the Viewing Mode is set to normal; refer to Section 3.2 on page 22 for Viewing Mode information. The title bar in the ShoreTel Communicator window shown in Figure 3-1 indicates the user’s extension is 2569.

![Figure 3-1 Main Window in Normal View](image)

The Main window structure and the set of menus available for display depend on the selected Viewing Mode.
3.1.1.2 Satellite Window

A Satellite window is a ShoreTel Communicator component that displays ShoreTel Communicator viewers and is separated from the Main ShoreTel Communicator window.

When the Viewing option is set to Normal or Docked, ShoreTel Communicator can be configured to display viewers either through the main window or through a satellite window. You can drag satellite windows into the Main Window content area or drag viewers in the Main window to create a Satellite window. Section 3.1.3 describes ShoreTel Communicator window manipulation operations.

When the Viewing Option is set to Miniature, viewers are always displayed through a Satellite window.

Section 3.3 on page 24 describes ShoreTel Communicator Viewers and includes a list of available viewers. A Satellite window can contain more than one viewer. Alternatively, a separate satellite window can be opened for each viewer.

The Satellite window in Figure 3-2 contains the Contacts viewer.

3.1.1.3 Alerts

An Alert is a popup that ShoreTel Communicator displays in the bottom right corner of the user's monitor to inform the user of an incoming voice call or instant message. Figure 3-3 displays a Voice Call Alert.
Voice call alerts contain buttons for accepting the call or sending the call to Voice Mail. Clicking in an Instant Message alert opens the message panel from which the user can respond and continue the conversation. The function and appearance of alerts is the same for all viewing modes.

### 3.1.2 Window Components

The ShoreTel Communicator Main window is the primary window for accessing ShoreTel client services. In addition to initiating and managing communication sessions, users can adjust their call handling mode or presence; view the presence of other system users; and access directory entries, calling history, and voice mail through this window.

Figure 3-4 displays the ShoreTel Communicator Main window in normal viewing mode.

**Figure 3-4 ShoreTel Communicator Main Window Components**

#### 3.1.2.1 Application Button

The Application Button appears as the ShoreTel logo in the upper left corner of the Main window. Click the Application Button to display menus that access communication session commands, configuration options, and parameter settings.

The Application Button is visible in Normal, Docked, and Miniature viewing modes.

#### 3.1.2.2 Main Menu

The Main Menu is located below the title bar and above the Toolbars. Each word on the Main Menu accesses a drop down menu that displays commands, configuration settings, and viewing options. Main Menu options are also available through the Application Button.

To control the display of the Main Menu, select **View -> Main Menu** from the Application Button, the Main Menu, or the System Tray context menu.

The Main Menu is not available in Miniature viewing mode.
3.1.2.3 Assignment Bar

The Assignment Bar is located below the Toolbars and above QuickDialer. Each word on the left side of the Assignment bar accesses a drop down menu that lists options for assigning the user's access device, IM presence setting, and Call Handling Mode, and for displaying Viewers. Workgroup members also assign login status from the Assignment bar. All Assignment bar options are also available through the Application Button or the System Tray context menu.

The icons on the right side of the bar provides status for current ShoreTel Communicator calls:

- The Microphone icon displays the mute status of the current call when you conduct calls through SoftPhone.
- The Keypad icon accesses a keypad through which dialing tones (DTMF) can be sent during active voice calls.
- The Telephone icon indicates the current call and on-hook phone status and lists the quantity of unanswered calls.

3.1.2.4 Toolbars

Toolbars provide single button access to ShoreTel Communicator tasks. ShoreTel Communicator can display up to ten toolbars and each toolbar has a maximum capacity of 24 buttons. Toolbars are configured by the system administrator.

Toolbars are an optional component of the ShoreTel Communicator Main and Miniature windows. To control the display of the Toolbars, select View -> Show <toolbar name> from the Application Button, Main Menu, or the System Tray context menu.

3.1.2.5 QuickDialer

QuickDialer provides drop-down access to directory names and phone numbers that match the text in the data entry field. You can also enter, paste, or drag numbers into the QuickDialer field.

As shown in Figure 3-5, the right side of the QuickDialer field provides the following:

- Redial button – accesses a list of recent dialed or received calls, as configured in the Options and Preferences: QuickDialer panel.
- Go arrow – initiates a call to the selected contact in the QuickDialer field. Access to the Go arrow is configured in the Options and Preferences: QuickDialer panel.

Section A.2.2 on page 176 describes the Options and Preferences: QuickDialer panel.

Figure 3-5 QuickDialer buttons
You can specify the following information when entering the intended call recipient in the **QuickDialer** data entry field:

- The recipient’s name, as listed in your directory.
- The recipient's number as listed in your directory.
- A valid phone number, as specified by your system.
- Redial recently dialed numbers
- Company name
- Email address
- IM address
- Department name, as a name qualifier

As you fill the data entry field, ShoreTel Communicator displays a drop down menu that lists the contents of your directory filtered by the QuickDialer contents. When you select a contact in this menu your phone initiates the call as specified by your telephony settings.

QuickDialer configuration options can prevent QuickDialer from displaying contact information for fax machines and companies. QuickDialer can also display available calling actions for filtered contacts. The Options and Preferences: QuickDialer panel configures these options.

QuickDialer tokens typed into the data entry field are matched to an index of directory entries. A drop down panel displays a list of Directory entries filtered by the token matches.

**QuickDialer properties include:**

- Tokens are delimited by spaces:
  - **mark** is a single token string
  - **ma th** is a two token string
  - **m s w t** is a four token string

Directory entries match a token string when each input token maps to a distinct word within the name of the entry, without regard to case or order:

- **mark** matches *Mark Thomason* and *Tim Markison*
- **ma th** matches *Marge Thorpe* and *Thad Martin*

Each input token must match a word within the index name:

- **p p** matches *Pauline Paulus* but not *Peter Hicks*

Parentheses, apostrophes, and hyphens are not considered when matching entries:

- **one** matches *O’Neal*
- **tex** matches *John (Tex) Jones*

QuickDialer matches individual words within company names:

- **net** matches *High Country Networks*

Only single token searches (strings with no spaces) match email and IM addresses:

- **mthomason@an** matches a user’s (*mthomason@anycorp.com – Mark Thomason*) record.

The Department field can be used to refine a Name search.

In multiple token search, only the first token can match email addresses, IM addresses, or phone numbers.
3.1.2.6 Active Call Area and Call Cells

The Active Call Area displays call cells for each voice call that ShoreTel Communicator is handling. The Active Call Area in Figure 3-4 contains one call cell. The Active Call Area can be configured to display the blank call cells by selecting Tools -> Options -> Preferences from the Application Button, Main Menu, or the System Tray context menu.

Call cells display status and time information about active calls that ShoreTel Communicator is handling. Each call represents one call appearance. Operations available through main window buttons are performed on the highlighted call appearance. You can also perform operations on a call through a context menu by right clicking on the call cell.

The left side of a call cell indicates the status and duration of the connection with the other party on the call appearance, along with the name and number of that party. The right side of the call cell contains buttons for performing call management tasks on the call appearance. To determine the function of an individual button, hover the cursor above that button until ShoreTel Communicator displays a popup description.

The Active Call Area in Figure 3-6 contains two call cells:

The top cell corresponds to a call with Adam Pierce. The icon on the left side of the call cell indicates that the call is currently connected to the device that is assigned to your extension. The text indicates the name and number of the other party and that the call is connected to the extension device. The buttons on the right side indicate the operations that can be performed on the call which are, respectively, Hold, Transfer, Conference, Hang up, and View Additional Information. Because this call is highlighted, call management operations initiated from Main Window menus are performed on this call.

The call cell indicates that AES-SRTP encryption is active during a call with a small padlock icon located next to the call status icon. The padlock icon indicates the call media is secure on the ShoreTel network; ShoreTel cannot guarantee call security outside of the network, such as calls that terminate across an analog or digital trunk.

The bottom cell corresponds to a call with Hannah Poulson. As indicated by the status icon and text, this call is on hold. The set of operation buttons on the right side of the cell differ from those in the other cell because of the call state. The available buttons include Answer, Conference, Hang up, and View Additional Information. The call is not highlighted; clicking anywhere in the cell highlights the call.

Figure 3-6 Call Cells in the Active Call Area
3.1.2.7 Content Area

Content Areas display one or more viewers, such as the Contact List or the Directory List. The ShoreTel Communicator Main window may contain up to eight Content Area regions. Content regions can be dragged from the Main window into a Satellite window. Conversely, Satellite windows can be dragged into the Main window to create a Content Area.

3.1.2.8 Status Bar

The Status Bar is located at the bottom of the ShoreTel Communicator window. The left side displays error and status messages.

3.1.3 Manipulating ShoreTel Communicator Windows

Viewers can be displayed in the ShoreTel Communicator Content Area or in Satellite windows. Users can incorporate Satellite windows into the Main window. Conversely, Viewers can be moved from the ShoreTel Communicator window into Satellite windows.

The following procedure configures ShoreTel Communicator to permit window manipulation:

**Step 1** Open the Options and Preferences window by performing one of the following:
- Select **Tools -> Options** from the Main Menu.
- Click the Application Button and select **Options**.
- Right click the ShoreTel icon in the System Tray and select **Options**.
- Press Ctrl+O.

**Step 2** Select **General** in the menu on the left side of the window.

**Step 3** Mark the **Enable drag-and-drop Window arrangement** checkbox.

By default, **Enable drag-and-drop Window arrangement** is enabled for Workgroup Agent, Workgroup Supervisor, and Operator type; this parameter is disabled for Personal and Professional access levels.

3.1.3.1 Separating Windows

Drag and drop operations remove content areas from the Main window and separate viewers from a single Satellite window.

To separate panels from a tiled window, point the cursor at the Title Bar of the panel to be removed, left click and hold the left mouse button, then drag the panel outside of the window boundary.

To separate a panel from a tabbed window, point the cursor at the tab of the panel to be removed, left click and hold the mouse button, then drag the panel outside of the window boundary.

3.1.3.2 Combining Two Satellite Windows

Figure 3-7 displays a windows desktop that contains the Main window and two Satellite windows. The top Satellite window contains the Contact List; the bottom Satellite window contains the Speed Dial list. The following procedure moves the Contact List into the Satellite window containing the Speed Dial List.
To combine two satellite windows:

**Step 1** Point the mouse cursor at the Title Bar of the window to be moved, then click and hold the left mouse button. Figure 3-7 shows the cursor pointing on the Title Bar of the Contact List.

Moving the Satellite window displays Global Drop Targets in the Main window.

**Step 2** Drag the window into the body of the receiving Satellite window. Figure 3-8 shows the Contact List as it is moved into the Satellite window containing the Speed Dial List.

---

Figure 3-7 ShoreTel Communicator Main and Satellite Windows

Figure 3-8 Moving a Satellite Window into another Satellite Window
As a window receives a Satellite window, it displays a local drop target, as shown in Figure 3-8. Local drop targets contain five icons – one in each of the protruding regions and one in the center. Each icon in the protruding regions represent an edge of the Satellite window.

**Step 3** Hover the cursor over a selected drop target region until the receiving window displays a preview shadow. In Figure 3-9, the cursor is hovering over the bottom drop target icon.

Figure 3-9 Hovering over the Bottom Drop Target Icon

The shaded area represents the proposed position of the Contact List within the receiving Satellite window.

**Step 4** Release the Mouse button.

Figure 3-10 displays the Satellite window that results from releasing the mouse button while hovering on the bottom drop target, as shown in Figure 3-9. The global drop targets in the Main window disappear when the mouse button is released.
Releasing the mouse while hovering over protruding drop target icons results in the Satellite window displaying the viewers as tiled panels, as shown in Figure 3-10. Releasing the mouse while hovering over the center drop target icon results in the Satellite window displaying the viewers as tab panels, as shown in Figure 3-11.
3.1.3.3 Moving a Satellite Window into the Main Window

The procedure for moving a Satellite window into the Main window is similar to that for combining two Satellite windows. When moving panels into the Main window, two sets of drop targets appear. The outer targets are used for adding a content area to the window. The interior drop targets are used to incorporate the added panel into an existing content area.

Figure 3-12 depicts the result of hovering the Satellite window over a global drop target. The window panel is inserted into the entire ShoreTel Communicator Main window.

Figure 3-13 depicts the result of hovering the Satellite window over a local drop target. The window panel is inserted only into the Content Area of the Main window.
3.2 Viewing Modes

ShoreTel Communicator provides three viewing modes for displaying the Main ShoreTel Communicator window: Normal, Miniature, and Docked. When ShoreTel Communicator is opened, it maintains the viewing option setting that was active when it was closed.

When ShoreTel Communicator is active but not visible on the desktop, the System Tray displays a ShoreTel icon which, when pressed, opens the ShoreTel Communicator window.

3.2.1 Normal Mode

The Normal ShoreTel Communicator window, shown in Figure 3-1, can be configured to contain all ShoreTel Communicator window components. The Normal window can be moved anywhere on the desktop by dragging the title bar. To resize the width and length of the Normal window, click and drag any of the four window edges.

To display the Main Manager in Normal mode, select View -> Normal from the Menu bar, Application Button, or the System Tray context menu.

Moving viewers between the Main window and satellite windows requires that the Windows Manipulation option is enabled, as described in Section 3.1.3 on page 17.

3.2.2 Miniature

The Miniature view, shown in Figure 3-14, is a compact version of the main window. The Miniature view always displays the Application Button, QuickDialer, and Call List. The Call Toolbar is accessed in Miniature mode through a Application Button option. All viewers are accessible through a Satellite window.

To display the Main Window in Miniature view, select View -> Miniature from the Menu bar, Application Button, or the System Tray context menu.

To move the Miniature Main Window, click and hold in the dark blue region on the left or right side of the window, then drag it to the desired location.

3.2.3 Docked

ShoreTel Communicator provides four Docked window settings, one for each edge of the computer monitor. When ShoreTel Communicator is docked, it is located permanently on the edge of the window specified by the docking command. In Figure 3-15, ShoreTel Communicator is docked to the bottom of the monitor.
When ShoreTel Communicator is docked to the left or right side, the window spans the monitor from top to bottom. The width is adjustable. The viewers can appear either in the Main ShoreTel Communicator window or in Satellite windows.

When ShoreTel Communicator is docked to the top or bottom of the monitor, the height of the window is fixed and the window spans the monitor from the left to right sides. Viewers only appear in Satellite windows.

To display ShoreTel Communicator in Docked view, select View from the Menu bar, the Application Button, or the System Tray context menu, then select one of the Docked options at the bottom of the menu.

### 3.2.4 System Tray

The System Tray displays a ShoreTel icon when ShoreTel Communicator is running. Clicking the ShoreTel icon opens the ShoreTel Communicator window on the desktop and returns focus to the window. Right clicking the System Tray icon opens a context menu that displays most options available through the Application Button.

Figure 3-16 displays the ShoreTel icon in the System Tray.
3.3 Viewers

Viewers are lists that display resources available through ShoreTel Communicator including your voice mail, contacts, directory lists, speed dial contacts, and call history. You access Viewers through the Content Area of the Main window or through a Satellite window.

The following is a summary of the ShoreTel Communicator viewers. A complete description of each panel is provided in the referenced sections.

**Directory:** The Directory viewer displays all contact information for all system users. You can store personal contacts and import contact entries from Microsoft Outlook to the Directory viewer. Section 8.2 on page 91 describes the Directory Viewer.

**Contacts:** The Contact viewer displays your contact lists. Contact lists provide convenient access to selected entries from your directory of addresses. Section 8.3 on page 96 describes the Contacts Viewer.

**History:** The History viewer displays information about previous calls you made and received. It can be used to display calls you made and the phone numbers of people who called you. Section 4.9 on page 72 describes the History Viewer.

**Voice Mail:** The Voice Mail viewer manages your voice messages. In addition to viewing your messages, you can listen to, sort, and delete messages from this panel. Section 9.3 on page 115 describes the Voice Mail viewer.

**Speed Dial:** The Speed Dial viewer manages and initiates calls to your speed dial contacts. Section 8.5.1 on page 110 describes the Speed Dial viewer.

**Queue Monitor:** The Queue Monitor displays the calls that are ringing into your workgroups and waiting on your workgroup queues. Section 12.4.1 on page 149 describes the Queue Monitor.

**Agent Monitor:** The Agent Monitor displays the name, extension, and status of all agents in your workgroups. Section 12.4.2 on page 151 describes the Agent Monitor.

**Bridged Call Appearance Monitor:** The Bridged Call Appearance Monitor displays the Bridged Call Appearances for which your phone is configured to answer. Section 12.4.4 on page 156 describes the Bridged Call Appearance Monitor.
3.4 Toolbar Customization

ShoreTel Communicator allows you to customize toolbars with functionality related to that particular window. By default, the buttons on the toolbar display an image and text. ShoreTel Communicator allows the user to configure the appearance of these toolbars. The following features are available:

- Change the button style (for one button or group of buttons) between Text Only, Image Only and Image and Text.
- Show or hide a button or group of buttons on the toolbar to save screen space.
- Move a button or group of buttons on the toolbar, so that frequently used buttons appear before others.

The ShoreTel Communicator toolbars that support this feature display an additional Customize button, which will open the Toolbar Customization dialog:

![Customization Option](image1)

![Customize Toolbar Panel](image2)
The button style can be changed by clicking on the style cell will display a drop-down list, where the user can pick one of the available choices:

- Image and Text
- Image Only
- Text Only

The Customize button can be customized, but it cannot be removed from the toolbar. If the Show field is unchecked for this button, it will be ignored when the dialog is closed. All other buttons can be hidden and customized.

The modified toolbar layout will be saved and restored in future ShoreTel Communicator sessions. The buttons can be customized directly on the toolbar, without having to launch the customization dialog. In this scenario only individual buttons or all the buttons can be changed at the same time, it is not possible to select a group of buttons and apply a style, directly from the toolbar.

The following context menu opens when you right-click on a button that you can customize.

![Figure 3-19 Customize Button Context Menu](image)

Reset Toolbar resets all the buttons to the default configuration.
4.1 Introduction
ShoreTel Communicator provides a Graphical User Interface for initiating and handling your voice calls. ShoreTel Communicator operations and features that support, handle, and manage your voice calls include:

- extension assignment to a device
- configuring call device options
- initiating a voice call
- managing incoming calls
- operations during an active call
- specialty calls: conference, video, intercom, and pages
- history viewer
- call routing slips

4.2 Extension Assignment
Extension assignment specifies the device to which ShoreWare routes your calls. The following sections explain the options for receiving calls at your default home device, at your SoftPhone, or at other devices through Extension Assignment.

The Device button on the Assignment bar displays the audio device that is currently assigned to the user's extension.

4.2.1 Primary Device
Your primary device is the phone that is plugged into your home port, as configured by your administrator. The home device can only be changed by your system administrator.

To assign your Primary Device to your extension, perform one of the following:

- Click the Application Button and select Extension Assignment -> Primary Phone.
- Click the Assignment Button on the Assignment Bar and select Primary Phone.
- Right click the ShoreTel icon in the System Tray and select Extension Assignment -> Primary Phone.
- Press Ctrl+Shift+M.

The Assignment button displays the Home icon to indicate that your extension is assigned to your home device.
4.2.2 SoftPhone

SoftPhone is a ShoreTel Communicator component that performs voice calls and voice mail functions directly through the computer running ShoreTel Communicator. After users assign their extension to SoftPhone, they use the computer's audio devices to place or receive voice calls and send or receive voice messages. SoftPhone is a licensed feature that requires administrator authorization.

Chapter 4 on page 27 describes SoftPhone.

To assign SoftPhone to your extension, perform one of the following:

- Click the Application Button and select **Extension Assignment -> SoftPhone**.
- Click the Assignment Button on the Assignment Bar and select **SoftPhone**.
- Right click the ShoreTel icon in the System Tray and select **Extension Assignment -> SoftPhone**.
- Press Ctrl+Shift+S.

The Assignment button displays the SoftPhone icon to indicate that your extension is assigned to the SoftPhone.

4.2.3 Extension Assignment

4.2.3.1 Description

Extension Assignment is an extension assignment option that forwards calls to a designated system device or a remote telephone connected to the PSTN. Extension Assignment requires authorization from your administrator.

Activating Extension Assignment from a system telephone assigns your extension to that device. When activating Extension Assignment from a remote device, you maintain an on-system extension presence by mapping your ShoreWare extension to the external device.

ShoreTel Communicator displays calls that Extension Assignment forwards to your specified device. You can manage these calls in ShoreTel Communicator as if you received them through your home device.

- The device to which Extension Assignment assigns your extension rings when you receive a call. The active Call Handling Mode determines the disposition of unhandled calls.
- ShoreTel Communicator provides all call management functions except call answer. Extension Assignment calls must be answered on the assigned device.
- Voice calls made and received while Extension Assignment is active are placed in the extension's call stack. Calls cannot be parked on an extension where Extension Assignment is active.

4.2.3.2 Activating Extension Assignment

To assign your extension to a device specified by Extension Assignment, perform one of the following:

- Click the Application Button and select **Extension Assignment -> Extension Assignment**.
- Click the Assignment button on the Assignment Bar and select **Extension Assignment**.
- Right click the ShoreTel Tray icon and select **Extension Assignment -> Extension Assignment**.
Press Ctrl+Shift+O
Select *Enable Extension Assignment* from the *Options and Preferences: Extension Assignment* panel, as described in Section A.2.5 on page 179.

The Extension Assignment option is not available until a phone number is entered into the External Number field located on the *Options and Preferences: Extension Assignment* panel.

When Extension Assignment is active, the Assignment button displays the telephone number of the assigned device.

You specify the phone number of the assigned Extension Assignment device on the *Options and Preferences: Extension Assignment* panel, as described in Section A.2.5 on page 179.

### 4.2.3.3 Configuring Extension Assignment

The *Options and Preferences: Extension Assignment* panel specifies the Extension Assignment device, configures other Extension Assignment settings, and activates Extension Assignment for your extension.

Section A.2.5 on page 179 describes the *Options and Preferences: Extension Assignment* panel.

### 4.3 Configuring Device Options

#### 4.3.1 Handsfree Mode

Handsfree mode defines a telephone state where the phone is always off hook and the dial tone is suppressed. This mode clears the audio path immediately at the conclusion of a call, allowing you to initiate a call without hanging up the phone from a previous call. Although Handsfree mode is typically used with a headset, this parameter is independent of the active audio path.

To access the Handsfree mode activation parameter:

**Step 1** Open *Options and Preferences* by performing one of the following:
- Select *Tools -> Options* from the Main menu.
- Click the Application Button and select *Options*.
- Right click the ShoreTel icon in the System Tray and select *Options*.
- Press Ctrl+O.

**Step 2** Select *Telephony* in the menu on the left side of the window.

**Step 3** Select the preferred handsfree option by setting *Suppress dial-tone when off-hook (headset mode for analog phones)* as follows:
- Check *Suppress dial-tone when off-hook (headset mode for analog phones)* to enable Handsfree mode.
- Clear *Suppress dial-tone when off-hook (headset mode for analog phones)* to disable Handsfree mode.

Section A.2.11 on page 188 describes the *Options and Preferences: Telephony* panel.
4.3.2 Call Stack Size

The call stack size determines the maximum number of calls that you can handle through ShoreTel Communicator. Calls that you receive while your call stack is full are managed as busy. The call stack size configured through ShoreTel Communicator is subject to the maximum size configured for your extension by the System Administrator. Consult your System Administrator to increase maximum call stack size for your extension.

When your call stack is full, ShoreTel Communicator permits one additional outbound call for performing consultative conferences and transfers.

To configure your call stack size

Step 1  Open Options and Preferences by performing one of the following:
Select Tools -> Options from the Main menu.
Click the Application Button and select Options.
Right click the ShoreTel Communicator icon in the System Tray and select Options.
Press Ctrl+O.

Step 2  Select Telephony in the menu on the left side of the window.

Step 3  Enter the call stack size in the Maximum number of active calls to show field.

Section A.2.11 on page 188 describes the Options and Preferences: Telephony panel.

4.3.3 Specifying the Default Auto Off-Hook Device

The Default AutoOff-Hook Preference specifies the audio path that the system activates when you place or receive a voice call. SoftPhone and several ShorePhone models support Automatic Off-Hook Device selection.

To configure the Default Off-Hook audio path preference:

Step 1  Right click the ShoreTel Communicator icon in the System Tray or the ShoreTel icon in the left hand corner of the ShoreTel Communicator window.

Step 2  Select the preferred audio path by setting Default audio path for automatic off-hook:
Speaker: The speaker and external microphone on your active device is the default audio path.
Headset: The headset on your active device is the default audio path.
Wireless Headset: The wireless headset on your active device is the default audio path.
Bluetooth: The Bluetooth headset is the default audio path on phones that support Bluetooth.

Section A.2.11 on page 188 describes the Options and Preferences: Telephony panel.

4.3.4 Suppressing the Call Waiting Tone

The Call Waiting Tone is a signal inserted into the audio path during a voice call to alert you of an inbound call. Suppressing the call waiting tone prevents your receipt of this signal. Calls that you receive when the Call Waiting Tone is suppressed are handled as specified by your active call handling mode. This parameter setting does not affect Voice mail and call handling mode settings.
To access the Call Waiting mode suppression parameter:

Step 1  Open Options and Preferences by performing one of the following:

- Select Tools -> Options from the Main menu.
- Click the Application Button and select Options.
- Right click the ShoreTel Communicator icon in the System Tray and select Options.
- Press Ctrl+O.

Step 2  Select Telephony in the menu on the left side of the window.

Step 3  Select a call waiting tone option by setting *Suppress call waiting tone for subsequent calls* as follows:

- Select *Suppress call waiting tone for subsequent calls* to disable the tone.
- Clear *Suppress call waiting tone for subsequent calls* to activate the tone.

Section A.2.11 on page 188 describes the Options and Preferences: Telephony panel.

### 4.4 Making a Call

You can initiate voice calls from the Main window and from Viewers that display contact names or numbers. This section contains procedures for initiating calls from QuickDialer, the Make New Call panel, and from ShoreTel Communicator viewers.

To initiate a call by selecting a name or number from the QuickDialer drop down menu:

Step 1  Perform one of the following:

- Begin entering the contact name or number in the data entry field.
- Press the Redial icon located on the right side of the data entry field.

Refer to Figure 4-1 for the location of the QuickDialer components. Section 3.1.2.5 on page 14 describes QuickDialer.

![Figure 4-1 QuickDialer Components](image)

Step 2  Select the desired contact in the drop-down menu.

Step 3  Double click the menu entry, press the Enter key, or click the Go arrow.
To initiate a voice call through the Make New Call panel:

**Step 1** Perform one of the following:
- Right click in the Active Call Area and select *Make Call*.
- Select *Dial -> Make Call* from the Main Menu.
- Click the Application Button and select *Dial -> Make Call*.
- Right click the ShoreTel icon in the System Tray and select *Dial -> Make Call*.
- Press Ctrl+Alt+D

ShoreTel Communicator displays the *Make New Call* dialog box, as shown in Figure 4-2.

**Step 2** Begin entering the call recipient's name or number in the data entry field at the top of the panel.

The table lists entries from your directory, filtered by data entry field contents.

**Step 3** Select the desired recipient in the table.

The **Dial Digits** field, located above the buttons at the bottom of the panel, lists the number to be dialed after you select a table entry.

**Step 4** Press the **Make Call** button at the bottom of the panel.

To initiate a call from a specific ShoreTel Communicator Viewer, refer to the manual section that describes that viewer.

![Figure 4-2 Make New Call panel](image)
4.5 Managing Incoming Calls

4.5.1 Inbound Call Signals
ShoreTel Communicator provides three methods of signaling the receipt of an inbound voice call:

- Display a Call Alert in the bottom right corner of your monitor.
  You control the display of Call Alerts from the Options and Preferences: Telephony panel, as described in Section A.2.1 on page 173. Call Alerts are described in Section 3.1.1.3 on page 12.

- Play an audible tone through your computer.
  You can select the tone that your computer plays from the Options and Preferences: Sounds panel, as described in Section A.2.17 on page 199.

- Display a call cell in the Active Call Area of the Main Window.
  Section 3.1.2.6 on page 16 describes call cells.

4.5.2 Answering Calls

4.5.2.1 Answering Calls to your Extension
When you receive a call, the Active Call Area displays a call cell that lists the caller's telephone number. The call cell also lists the caller's name if the number is listed in your system's directory, personal directory, or Outlook contacts. If the inbound call number matches multiple names in your directories, the call cell displays the first match.

To answer an incoming call from ShoreTel Communicator, perform one of the following:

- Click the Answer button on the call alert.
- Click the Answer button on the call cell.
- Right click the call cell and select Answer.
- Select Call -> Answer from the main menu.
- Click the Application Button and select Call -> Answer.
- Right click the ShoreTel Communicator icon in the System Tray and select Call -> Answer.
- Press Ctrl+A
- Press F8

4.5.2.2 Answering Calls to a Different Extension
Authorized users can answer inbound calls to another user's extensions.

To pick up another user's phone call:

Step 1 Perform one of the following:

- Select Dial -> Pickup/Unpark from the Main Menu.
- Click the Application Button and select Dial -> Pickup/Unpark.
- Right click the ShoreTel icon in the System Tray and select Dial -> Pickup/Unpark.
- Press Ctrl+Alt+P

ShoreTel Communicator displays the Pickup dialog box, as shown in Figure 4-3.
Step 2  Begin entering the user's name or number in the data entry field at the top of the panel.

The table displays a list of user names, filtered by data entry field contents.

Step 3  Select the desired user in the table.

The Dial Digits field, located above the buttons at the bottom of the panel, lists the user's number after you select a table entry.

Step 4  Press the Pickup button at the bottom of the panel.

4.5.2.3  Answering the Night Bell Extension

The Night Bell is an extension that is tied to a site-wide signaling device and can be answered by authorized users.

To pick up a night bell call, perform one of the following actions:

Select Dial -> Pick up Night Bell from the Main Menu.
Click the Application Button and select Dial -> Pick up Night Bell.
Right click the ShoreTel icon in the System Tray and select Dial -> Pick up Night Bell.
Press Ctrl+Alt+L.
4.5.3  Rerouting Inbound Calls

4.5.3.1  Sending a Call to Voice Mail
ShoreTel Communicator can send your inbound calls to Voice Mail.

To send an inbound call to Voice Mail, perform one of the following:
- Click the Application Button and select Call -> To Voice Mail.
- Select Call -> To Voice Mail from the main menu.
- Click the To VM icon on the call cell.
- Right click the call cell and select Call -> To Voice Mail.
- Press Ctrl+Y.

4.5.3.2  Sending a Call to the Automated Attendant
ShoreTel Communicator can send your inbound call to the Automated Attendant.

To send an inbound call to the Automated Attendant, perform one of the following:
- Click the Application Button and select Call -> To Auto Attendant.
- Select Call -> To Auto Attendant from the main menu.
- Right click the call cell and select Call -> To Auto Attendant.

4.5.3.3  Transferring a Call to a Directory Contact
ShoreTel Communicator can send your inbound call to one of your Directory contacts. The Call Transfer function, including the transfer of active calls, is described in Section 4.6.3 on page 50.

To send an inbound call to a Directory contact:

Step 1  Perform one of the following:
- Click on the transfer button/icon in the call cells.
- Click the Application Button and select Call -> Transfer.
- Select Call -> Transfer from the main menu.
- Right click the call cell and select Call -> Transfer.

ShoreTel Communicator displays the Transfer Call dialog box.

Step 2  Enter the contact name or number in the data entry field at the top of the dialog box.

The table displays a list of directory entries filtered by data entry field contents.

Step 3  Select the desired user in the table.

The Dial Digits field, located above the buttons at the bottom of the panel, lists the user's number after you select a table entry.

Step 4  Press the button at the bottom of the panel corresponding to your desired transfer type.
4.5.4 Automated Call Handling

A Call Handling Mode defines call management conditions and tasks for your inbound calls. ShoreWare defines the following five call handling modes for each extension to customize the manner that a user's calls are handled over a variety of situations.

- Standard
- In a Meeting
- Out of Office
- Extended Absence
- Custom

One call handling mode is always active. ShoreWare automatically selects the active call handling mode on the basis of system schedules maintained by the system administrator. Users can also manually select their active call handling mode.

The following sections describe call management tasks controlled by Call Handling Modes, along with the automatic and manual methods of selecting the active call handling mode.

4.5.4.1 Configuring the Call Handling Modes

Mode Configuration panels configure call handling methods when the specified call handling mode is active. The Option and Configuration window provides access to five Call Handling Mode configuration panels, one for each call handling mode.

Section A.2.4 on page 177 describes the Call Handling Mode configuration panels.

4.5.4.2 Setting the Active Call Handling Mode

The active Call Handling Mode specifies the manner by which ShoreTel Communicator handles your inbound calls. ShoreWare automatically activates call handling modes, as specified by system schedules maintained by the administrator. You can also manually select the active call handling mode.

**Automatic Mode Selection**

A ShoreWare schedule is a software component that specifies a set of time periods. ShoreTel Communicator uses schedules to program call handling mode changes for system users.

Each schedule consists of a name and a list of day-time intervals. ShoreTel Communicator panels refer to the schedule by its name and specify an active call handling mode during the intervals.

ShoreWare defines three schedule types:

- **On-hour schedules**: On-hour schedules specify day and time intervals over a weekly period without referencing a specific date. Figure 4-4 displays three examples of On-hour schedules.

<table>
<thead>
<tr>
<th>Day Shift</th>
<th>Afternoon Shift</th>
<th>Weekend Shift</th>
</tr>
</thead>
<tbody>
<tr>
<td>Monday 8:00 am</td>
<td>Monday 1:00 pm - 6:00 pm</td>
<td>Saturday 8:00 am</td>
</tr>
<tr>
<td>Tuesday 8:00 am</td>
<td>Tuesday 1:00 pm - 6:00 pm</td>
<td>12:00 pm</td>
</tr>
<tr>
<td>Wednesday 8:00</td>
<td>Wednesday 1:00 pm - 6:00 pm</td>
<td>Sunday 8:00 am</td>
</tr>
<tr>
<td>Thursday 8:00</td>
<td>Thursday 1:00 pm - 6:00 pm</td>
<td>12:00 pm</td>
</tr>
<tr>
<td>Friday 8:00</td>
<td>Friday 1:00 pm - 6:00 pm</td>
<td></td>
</tr>
</tbody>
</table>

*Figure 4-4 On-Hour Schedule Examples*
• **Holiday schedules**: Holiday schedules specify dates. Periods that identify a year are valid once; periods that do not specify a year are valid each year on the listed dates. Holiday schedules take precedence over On-hour schedules during periods covered by each schedule. Figure 4-5 display examples of Holiday Schedules.

<table>
<thead>
<tr>
<th>Holiday 1</th>
<th>Holiday 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>1/1</td>
<td>1/1</td>
</tr>
<tr>
<td>5/06/2008</td>
<td>2/18/2008</td>
</tr>
<tr>
<td>7/4</td>
<td>3/17</td>
</tr>
<tr>
<td>11/27/2008</td>
<td>7/4</td>
</tr>
<tr>
<td>11/20/2008</td>
<td>8/1/2008</td>
</tr>
<tr>
<td>12/26</td>
<td>11/27/2008</td>
</tr>
<tr>
<td></td>
<td>11/28/2008</td>
</tr>
<tr>
<td></td>
<td>12/25</td>
</tr>
</tbody>
</table>

**Figure 4-5 Holiday Schedule Examples**

• **Custom schedules**: Custom schedules specify date and time intervals. Periods that identify a year are valid once; periods that do not identify a year are valid each year on the listed dates. Custom schedules take precedence over On-hour and Holiday schedules during periods listed by multiple schedules. Figure 4-6 display examples of Holiday Schedules.

<table>
<thead>
<tr>
<th>Custom 1</th>
<th>Custom 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>8/14/2008 9:00 am - 4:00 pm</td>
<td>2/5/2008 12:00 am - 12:00 pm</td>
</tr>
<tr>
<td>7/24 6:00 am - 9:00 pm</td>
<td>2/5/2008 12:00 am - 12:00 pm</td>
</tr>
<tr>
<td></td>
<td>2/7/2008 12:00 am - 12:00 pm</td>
</tr>
</tbody>
</table>

**Figure 4-6 Custom Schedule Examples**

Schedules are configured by the system administrator. To determine the periods specified by an individual schedule, consult your system administrator.

Default active call handling modes are managed through the Schedule parameter of the Call Handling Mode configuration panels:

• The **Standard** and **Out of Office** modes determine the active call handling mode during normal daily activities.
  
  — The available options in **Standard**'s schedule parameter are the On-hour schedules configured by the system administrator. The user's active call handling mode is **Standard** during the times listed by the selected schedule unless the user manually changes the mode.

  — The **Out of Office** schedule is the inverse of the selected schedule in the **Standard** Call Handling Mode preferences panel. The user's active call handling mode is **Out of Office** during all periods not covered by the On-hour schedule.

  Schedules are not selected in the **Out of Office Call Handling Mode** preferences panel.

  **Example**: Assume that **Day Shift** in Figure 4-4 is the selected schedule in the **Standard** Call Handling Mode panel. **Standard** is the default call handling mode between 8 am to 5 pm on Mondays through Friday. **Out of Office** is the default call handling mode all other times.

• The user's active call handling mode is **Extended Absence** during the times listed by the selected Holiday schedule unless the user manually changes the mode. The Schedule drop down menu on the Extended Absence call handling mode preferences panel lists the Holiday schedules configured by the administrator.
• The user's active call handling mode is **Custom** during the times listed by the selected Custom schedule unless the user manually changes the mode. The Schedule drop down menu on the Custom call handling mode Preferences panel lists the Custom schedules configured by the administrator.

• **In a Meeting** mode is not associated to a schedule and cannot become active through an automatic mode selection.

### Manual Mode Transitions

You can select the active call handling mode through ShoreTel Communicator. A selected call handling mode remains active until you manually select a different mode or an automatic mode transition is performed, as scheduled by the mode configuration panels.

To change the active call handling mode, perform one of the following:

• Modify the **Current call handling mode** setting on the Options and Preferences: Call Handling Mode panel, as described in Section A.2.3.

• Click the Call Handling Mode button on the Assignment bar and select the desired mode from the drop down menu.

• Press the hot key combination for the desired mode:
  — Press Ctrl+Shift+1 for Standard Mode.
  — Press Ctrl+Shift+2 for In a Meeting Mode.
  — Press Ctrl+Shift+3 for Out of Office Mode.
  — Press Ctrl+Shift+4 for Extended Absence Mode.
  — Press Ctrl+Shift+5 for Custom Mode.

### 4.5.4.3 Call Handling Mode Warnings

ShoreTel Communicator can be programmed to warn you if the following Call Handling conditions are present when you start ShoreTel Communicator:

- The **Current Call Handling Mode** is not **Standard**.
- The **Forward Calls** setting for Standard Call Handling Mode is **Forward Always**.

These parameters are set from the Options and Preferences: Call Handling Mode panel, as described in Section A.2.3.

### 4.5.4.4 Call Handling Mode Delegation

Call Handling Mode Delegation permits the change of a user's current call handling mode by other users. Call Handling Mode delegation permissions are managed from the following locations:

- Options and Preferences: Call Handling Mode panel.
- ShoreWare Director – requires system administrator access.

Users modify another user's current call handling mode through the following tools:

• **Operator ShoreTel Communicator**, by right clicking a user in the Contact Viewer.
• **Web Access Client**, by selecting Other -> CHM Delegation.

To add a user to the delegation authorization list:

**Step 1** Open the Options and Preferences: Call Handling Mode panel, as shown in Figure 4-7.
Step 2 Enter the name or address of the contact to be granted call handling mode delegation authorization in the data entry field below. Allow these users to change current call handling mode.

![Options and Preferences](image)

**Figure 4-7 Changing Call Handling Mode Delegation Users**

Step 3 Press the Add button located right of the data entry field.

To delete a highlighted user from the authorization list, press the Remove button.

### 4.5.5 Personalized Call Handling

Personalized Call Handling defines flexible handling methods for inbound calls from different callers received at various times and dates. Possible applications for Personalized Call Handling includes:

- Requiring unidentified callers to announce their name by routing them to **Announced Find Me**.
- Assigning different ringtones for selected callers, such as family, personal contacts, external contacts.
- Routing calls from non-urgent sources directly to voicemail or to other extensions.
Personalized Call Handling filters and manages inbound calls on the basis of multiple criteria including time or date calls are received, end user status, and caller identity. Personalized Call Handling is implemented through Call Routing Plans and Call Routing Rules:

- The **call routing plan** specifies a user's call handling method. The plan prioritizes a list of enabled Call Handling Rules.
- A **call handling rule** is the base unit of a Call Routing Plan that consists of a condition and action. When a call handling rule is active and the condition is satisfied, the action specifies method by which the ShoreTel system handles the user's call.

Section A.2.12 describes the User Interface panel that configures Personalized Call Handling.

### 4.5.5.1 Licensing

Personalized Call Handling is available to all System Users that are authorized for the following ShoreTel Communicator types:

- Professional
- Operator
- Workgroup Agent
- Workgroup Supervisor

Administrator authorization is not required for user assigned to these ShoreTel Communicator types.

### 4.5.5.2 Description

A Call Routing Plan manages a user's inbound voice calls. The plan consists of call handling rules, each of which specifies a method of handling a call when a condition set is valid. The plan enables and prioritizes selected rules. The user's inbound calls are evaluated against the call handling rules. The highest priority rule with conditions that are satisfied define the handling method for the call.

The call routing plan takes precedence over the active Call Handling Mode.

This section describes the structure and call handling rules, followed by a discussion of creating a call routing plan from these rules.

### Call Handling Rules

Call handling rules are the Personalized Call Handling components that define evaluation conditions and handling action. When the rule is active and the condition is satisfied, the action determines how the call is handled.

Three components comprise a call handling rule: name, condition, and action. The following sections describe call handling rule components.

- **Name:** The name is the label by which ShoreTel Communicator and Director refers to a call handling rule. Users specify the name when they create the rule.
- **Condition:** The condition is the filtering criteria that determines if a corresponding call handling action is performed. When a condition statement consists of multiple criteria, each criterion must be satisfied or the action is not performed.

Call Handling Rules defines the following six types of criteria...
— **Phone number match**: The phone number match is satisfied when the caller ID of the inbound call is a subset of the specified match type. Users can specify a maximum of ten *phone number match* entries.

Users select from the following match types:

- **Specific number** – user specifies the number that must match the caller ID; numbers can be internal extension or phone number external to the system
- **Every internal number** – matches all calls originating from a device within the ShoreTel network.
- **Any internal extension starting with** – user specifies the digits that must match the initial digits of numbers originating from internal callers
- **Every external number** – matches all calls originating from a device not located within the ShoreTel network.
- **Any external extension starting with** – user specifies the digits that must match the initial digits of numbers originating from phone numbers external to the system
- **Off system extension** – user specifies the off system extension that must match the caller ID
- **Private** – matches all calls that are identified by caller ID as private
- **Out of area / unknown** – matches all calls that caller ID identifies as out of area or unknown

— **I am on the phone**: This criterion is satisfied when the user's phone is busy.

— **Call Handling Mode**: This criterion is satisfied when the user's active Call Handling Mode matches the specified mode.

— **Time of day**: This criterion is satisfied when the call is received during the specified time ranges. *Time of day* entries are based on the timezone setting of the site to which the user is assigned.

— **Day of week**: This criterion is satisfied when the call is received on one of the specified days. *Day of week* entries are based on the timezone setting of the site to which the user is assigned.

— **DNIS Match**: This criterion is satisfied when the DNIS of the inbound call matches the specified string.

Workgroup and Hunt Group DNIS numbers are not propagated to members that answer group calls. This prevents the filtering calls on the basis of DNIS numbers not directly associated to the entity ultimately receiving the call.

• **Action**: The action specifies the resolution for calls that match the specified condition. Call Handling Rules define the following five action types:

— **Forward Call to Specific Number**: This action routes the call to the specified number. Users can select one of the following number types:
  - Specific Number
  - Off System Extension

— **Forward Call to Voice Mail**: This action routes the call to the recipient's voice mail.

— **Forward Call to Auto Find Me**: This action routes the call to voicemail, which then forwards the call to the recipient's Find Me number.
— **Forward Call to Announced Find Me**: This action routes the call to voicemail, which then forwards the call to the recipient's Find Me number where the caller's name is announced to the recipient, as described in Section 4.5.6.

— **Play Ringtone**: This action programs the phone to play the specified ShorePhone ringtone. This action is available only when receiving calls on a ShorePhone that support multiple ringtones.

### Call Routing Plan

The Call Routing Plan is the Personalized Call Handling component that determines the routing method of a user's inbound calls. The following sections describe the composition and operation of a call routing plan.

A call routing plan consists of a maximum of ten call handling rules. The plan specifies the rules that are active and lists the rules in the order that they are used to evaluate characteristics of the inbound call.

When a user receives an inbound call, the system evaluates the characteristics against the highest priority call handling rule that is enabled. If all of the criteria comprising the condition of that rule matches the call characteristics, the call is routed as specified by the rule's action and the plan execution is complete. If any of the criteria do not match the call characteristics, the system continues the plan execution by evaluating the call against the enable rule with the next highest priority.

This process is repeated for all enabled call handling rules. If the call characteristics do not match the conditions of any enabled call handling rule, the call is routed as specified by the active Call Handling Mode.

### 4.5.5.3 Implementing Personalized Call Handling

The following steps are required to implement Personalized Call Handling for a system user:

- Receive Administrator Access to Personalized Call Permission
- Create and Edit Call Handling Rules
- Manage the Call Routing Plan
- Administrative Oversight of defined plans

The following sections describes the required steps.

#### Administrative Permission

All users that have access to Professional, Workgroup Agent, Workgroup Supervisor, or Operator ShoreTel Communicator are authorized to use Personalized Call Handling.

Your system administrator can provide authorization for a ShoreTel Communicator version that supports Personalized Call Handling.

#### Creating and Editing Call Handling Rules

Personalized Call Handling Rules are created or edited from the Options and Preferences: **Personalized Call Handling panel**, as shown in Figure 4-8. Refer to Section A.2.12 on page 190 for a complete description of the Personalized Call Handling panel.
To create a Call Handling Rule:

Step 1 Press the New Rule button, located at the top of the panel.

ShoreTel Communicator displays the Personalized Call Handling Setup panel, as shown in Figure 4-9.

Step 2 Select all conditions in the Choose Condition to handle inbound calls section located in the top half of the panel.

The Condition Description section, located in the bottom half of the panel, displays the set of conditions that an inbound call must meet to be filtered by the rule. The blue hypertext regions link to dialog boxes that defined specific criteria for filtering calls.

Step 3 Click each hypertext region, enter specific filtering criteria in the dialog boxes.

Figure 4-10 displays the Phone Number match dialog box that ShoreTel Communicator displays when the Phone Number Match hypertext is clicked. Pressing the OK button closes the dialog boxes and displays the selected parameters on the Condition Selection section.
Step 4 Press the Next button located in the bottom right corner of the Personalized Call Handling Setup panel. The top section displays Choose Action for rule options; and bottom section displays Action Description, as shown in Figure 4-11.

Step 5 Select the desired call handling action for calls from the Choose Action for rule list.
The Action Description section, located in the bottom half of the panel, displays the selected action.

![Image of Personalized Call Handling Setup panel]

**Figure 4-11 Personalized Call Handling Setup panel – choosing action**

**Step 6** If the selected action in the Action Description section includes hypertext, click the link to display an action dialog box. Selected the desired option in the dialog box and press the OK button.

**Step 7** Press the Next button located in the bottom right corner of the Personalized Call Handling Setup panel.

**Step 8** Enter a name for the new rule in the *Enter Rule Name* data entry field.

**Step 9** Press the Finish button located in the bottom right corner of the Personalized Call Handling Setup panel.

The new rule appears in the Rule list of the Options and Preferences: Personalized Call Handling panel, as shown in Figure 4-12.

To edit an existing Personalized Call Handling Rule:

**Step 1** Highlight the desired rule in the rule list in the top half of the Personalized Call Handling panel.

**Step 2** Press the Modify Rule button at the top of the panel.

**Step 3** Modify rule parameters, using the same steps that create a Call Handling Rule.
Managing the Call Routing Plan

The Call Routing Plan determines the rules that are actively filtering calls and specifies the order that the rules are applied to calls. If the filtering criteria of more than one rule matches a call's characteristic, the first rule in the list that filters a call determines the handling action for that call.

To enable a Call Handling Rule, select the Enabled box located in the right column of the rule. In Figure 4-13, all of the call handling rules are selected.

To change the filtering order of a call handling rule, highlight the rule and press the Up or Down arrows located to the right of the call handling rule list.

Administrative Oversight

System administrators can view each user's call handling plan and enable or disable individual rules. Contact your system administrator for more information.
4.5.6 Find Me

Find Me call handling allows callers who are routed to your voice mailbox to contact you at alternate devices by pressing “1” while listening to your voice mail greeting. You can specify two numbers for rerouting callers through Find Me. The standard voice mail greeting does not prompt the caller on the availability of Find Me call handling.

Find Me call handling is enabled through call handling mode settings. Find Me destinations are independent of the call handling modes that activate Find Me.

After the caller presses 1, ShoreTel Communicator plays an audio prompt advising the caller that Find Me destinations are being called. If the call is not answered at either Find Me destination, the caller is sent to your voice mail.

When a call is forwarded to a Find Me destination, the phone at the Find Me destination displays your voice mail's caller ID. When you answer the call, you hear a prompt announcing the intended call recipient and the caller's ID information.

Announced Find Me provides for the recording of the caller's name for calls routed to Find Me destinations. Announced Find Me enhances the base Find Me feature such that:

- The caller's name is announced to the recipient of a Find Me call.
- Callers from external numbers or from internal extensions without a recorded name are prompted to record their name before the call is routed to the recipient.

Announced Find Me can be configured to require all users to record their names at the time of the call, except for those from internal extensions with a recorded name.
4.5.6.1 Activating Find Me
Find Me call handling is enabled during active Call Handling Mode periods that specify
Find Me. Refer to Section 4.5.4 on page 36 for information on active call handling modes
and configuring call handling mode parameters.

4.5.6.2 Configuring Find Me
The Options and Preferences: Find Me panel specifies the Find Me destinations and
specify the number of times ShoreTel Communicator rings each Find Me device. You can
also program ShoreTel Communicator to send inbound callers to your Find Me
destinations without requiring the caller to press 1.
Section A.2.5 on page 179 describes the Options and Preferences: Find Me panel.

4.5.6.3 Configuring Announced Find Me
Announced Find Me is available for users assigned to a class of service for which Find Me
is authorized. ShoreWare provides three methods of enabling Announced Find Me for a
user: from Director, from ShoreTel Communicator, and from Web Access.
Refer to Section A.2.6 on page 180 for information on configuring Announced Find Me
from the Options and Preferences: Find Me panel.

4.5.7 IM Responses to Inbound Calls
The IM Response to Inbound Calls is a feature that allows users to provide callers with an
immediate response through the Incoming Call Pop Up window of ShoreTel
Communicator. When a new call comes in the callers Caller ID is presented along with
three possible user call response options. Users can choose to Answer the call, Send the call
to Voice Mail or send an Instant Message to the caller. The Instant Messaging feature is
available for any incoming call from a recognized caller in the user's contacts list. ShoreTel
Communicator matches the Caller's ID to the user's contact profile and allows the user to
send an instant message to the caller if the callers IM address is found.
To implement the IM response to inbound calls feature the user must have Professional
level access in ShoreTel Communicator and must have IM configured in their ShoreWare
Director profile. In order for the IM address of the inbound caller to be recognized, the
caller must be added to the user's contacts or to their buddy list. An IM server such as
Microsoft Office Communications Server 2007 or the ShoreTel Conference Bridge must be
configured in the ShoreWare Director and installed and available on a separate server. All
users must have a profile created on the IM Server.

![John Smith 2345](image-url)

Figure 4-14 Incoming Call Pop Up Window
To use the instant messaging feature, follow these steps.

**Step 1** When the inbound call notification dialogue box is displayed as shown in the Figure above, click the "Send IM" button to initiate an IM chat session with the incoming caller.

The following chat window will open and the user will be able to start IM session with the caller an instant message.

![Image of IM Chat Window](Figure 4-15 IM Chat Window)

- When ShoreTel Communicator is active (it does not have to be displayed on the desktop, but does have to be an active running program), and an inbound call is presented to the user the Active Call Alert pop up window will appear in the lower right hand corner of the desktop.

- The caller has the option of answering the call by selecting the "Answer" button or sending the incoming caller to voice mail using the "To VM" button. If the incoming caller's ID is a recognized internal system caller or a recognized contact, the user will be presented with the option to respond to the caller using IM

### 4.6 During an Active Call

ShoreTel Communicator represents each voice call connection as a call cell in the Active Call Area. Section 3.1.2.6 on page 16 describes the Active Call Area and call cells.

The following sections describe call management tasks that you can perform through ShoreTel Communicator.
4.6.1 Adjusting the Volume

The audio volume is adjusted on the device that is assigned to your extension. Calls are also muted and unmuted from the assigned device.

4.6.2 Handling Multiple Calls

The number of voice calls that your extension can simultaneously handle is configured by your administrator. The number of calls that ShoreTel Communicator can display in the Active Call Area is configured in the Options and Preferences: Telephony panel, as described in Section A.2.11 on page 188.

Voice call management task for a call are performed by pressing the buttons on the right side of the call cell. The set of available buttons depend on the state of the call. Call operations listed through the Main window, Application Button, System Tray icon, and context menus are available for the call referenced by the highlighted call cell.

To change the highlighted call cell, click the cursor in the desired call cell.

To answer an inbound call while talking on another call, perform one of the call answering tasks described in Section 4.5.2.1 on page 33. ShoreTel Communicator places the current call on hold when you answer an inbound call.

To switch the active voice path to a different active call, click the call cell representing the second call. ShoreTel Communicator places the first call on hold when you switch the active voice path to the second call.

4.6.3 Call Transfer

Call transfers send your call to a selected user or device. Most calls are transferred through a transfer panel. You can also configure ShoreTel Communicator to perform guided transfers of incoming calls.

4.6.3.1 Types of Call Transfers

The following are the types of call transfers supported by ShoreTel Communicator:

• **Transfer:** A transfer immediately sends your call to the recipient. Section 4.6.3.2 and Section 4.6.3.3 describes call transfer methods.

• **Consultative Transfer:** A consultative transfers connects you to the recipient of the transfer, then sends the call upon your signal. This allows you to introduce the call to the recipient before the transfer. Section 4.6.3.2 and Section 4.6.3.3 describes consultative call transfer methods.

• **Intercom Transfer:** An intercom transfer connects the transferred party to the system intercom. Section 4.7.4 on page 63 describes intercom calls.

• **Mailbox Transfer:** A mailbox transfer sends the transferred party to the recipient's voice mailbox. Section 4.6.3.2 describes call transfer methods.

• **Voice Mail Transfer:** A transfer to voice mail sends the transferred party to your voice mailbox. Section 4.6.3.4 describes voice mail transfer methods.

• **Auto Attendant Transfer:** A transfer to the auto attendant sends the transferred party to the active auto attendant. Section 4.6.3.5 describes auto attendant transfer methods.
4.6.3.2 Using the Transfer Panel

The transfer panel, as shown in Figure 4-16, supports transfers, consultative transfers, intercom transfers, mailbox transfers, and whisper pages. Section 4.8.3 on page 65 describes whisper pages.

![Figure 4-16 Transfer panel]

To perform a transfer through the Transfer Panel:

Step 1  Select the call to be transferred by clicking its call cell.

Step 2  Open the Transfer panel by performing one of the following:

- Click the Transfer button on the call cell.
- Right click the call cell and select Transfer.
- Select Call -> Transfer from the main menu.
- Click the Application Button and select Call -> Transfer.
- Right click the ShoreTel Tray icon and select Call -> Transfer.
- Press Ctrl+T
- Press F10

Step 3  Begin entering the call recipient’s name or number in the data entry field at the top of the panel.

The table displays a list of directory entries filtered by data entry field contents.

Step 4  Select the desired recipient in the table.

The Dial Digits field, located above the buttons at the bottom of the panel, lists the number to be dialed when you have selected a valid contact.

Step 5  Press the button at the bottom of the panel that corresponds to your desired transfer type.

Press the Transfer button to immediately transfer the call to the recipient.
Press the Consult button to talk with the recipient before transferring the call.
Press the **Intercom** button to transfer the call to the intercom system.  
Press the **To Mailbox** button to transfer the call to the recipient's voice mailbox.  
Press **Whisper Page** to send a whisper page to the recipient.

### 4.6.3.3 Guided Transfer

ShoreTel Communicator provides *Guided Transfer* when initiating one call while another call is connected. When you initiate a new call while another call is in progress, the call in progress is placed on hold and becomes the *guided call*.

![Guided Transfer panel](image)

When the second call reaches the Proceeding or Connected state, the cell for the first call displays Guided Transfer Conference buttons labeled **Transfer**, **Conference**, and **No Thanks**, as shown in Figure 4-17. The **Transfer** and **No Thanks** buttons are always active; the **Conference** button is inactive while the second call is in Proceeding state and becomes active when the second call reaches Connected state.

- When you press the **Transfer** button before the call reaches the Connected button, the call is immediately transferred.
- When you press the **Transfer** button after the second call reaches the Connected state, ShoreWare performs a consultative transfer where the first call is the transferred call and the second call is to the transfer recipient.
- When you press the **Conference** button, ShoreTel Communicator either initiates or continues a conference by adding the new call to the conference. ShoreTel Communicator disables the **Transfer** button when a Conference call is active.
4.6.3.4 Transfer to Voice Mail
The Main window provides several options for transferring callers to your voice mailbox.

To send a caller to your voice mailbox from ShoreTel Communicator, perform one of the following:

- Right click the call cell and select To Voice Mail
- Select Call -> To Voice Mail from the main menu.
- Click the Application Button and select Call -> To Voice Mail.
- Right click the ShoreTel Tray icon and select Call -> To Voice Mail.
- Press Ctrl+Y

4.6.3.5 Transfer to Auto Attendant
The Main window provides several options for transferring callers to the auto attendant.

To send a caller to the auto attendant from ShoreTel Communicator, perform one of the following:

- Right click the call cell and select To Auto Attendant
- Select Call -> To Auto Attendant from the main menu.
- Click the Application Button and select Call -> To Auto Attendant.
- Right click the ShoreTel Tray icon and select Call -> Auto Attendant.

4.6.4 Call Interruptions

4.6.4.1 Hold
The Hold function maintains the state of a call while suspending the conversation. Calls that you place on hold remain associated with your extension; you can only resume your held calls from your extension.

When you place a caller on hold and hang up, the telephone rings once after 10 seconds notifying you that a call is on hold. If the first reminder is ignored, the phone rings on a 60-second interval until the call is connected or disconnected.

Call cells for calls that you place on hold remain on the Active Call Area of the main window. The call state indicates that the call is on hold and lists the hold period. Figure 4-18 displays a call cell of a call on hold.
To place a call on hold, perform one of the following on the call's cell:

- Click the Hold button on the call cell.
- Right click the call cell and select Hold.
- Select Call -> Hold from the main menu.
- Click the Application Button and select Call -> Hold.
- Press Ctrl+H

ShoreTel Communicator indicates the call is on hold in the cell that represents the call.

To pick up a call that is on hold, perform one of the following on the call's cell:

- Click the Answer button on the call cell.
- Right click the call cell and select Hold or Answer.
- Select Call -> Hold or Answer from the main menu.
- Click the Application Button and select Call -> Hold or Answer.
- Press Ctrl+H or Ctrl+A

ShoreTel Communicator indicates the call is active in the cell that represents the call.

**4.6.4.2 Park and Unpark**

Parking a call places a call on hold on another extension. This allows you to park a call on one extension and pick it up from a different extension. Unparking a call is retrieving a call that you previously parked on another extension. Calls can be unparked only by the person that parked it.

Pressing the Extension Monitoring programmable button, when it is appropriately configured by the system administrator, parks the active call on the stack of the monitored extension.

Bounced calls are unanswered parked calls that are returned to the extension from where they were parked after a period specified by the system administrator. Figure 4-19 displays a call cell of a bounced call.
To park a call, perform one of the following on the call's cell:

**Step 1** Perform one of the following:

- Right click the call cell and select *Park*
- Select *Call -> Park* from the main menu.
- Click the Application Button and select *Call -> Park.*
- Press Ctrl+K

**Step 2** Begin entering the contact name or number in the data entry field of the Park panel, as shown in Figure 4-20.
The table lists your directory entries filtered by the data entry field contents.

**Step 3** Select the desired user in the table.

The **Dial Digits** field, located above the buttons at the bottom of the panel, lists the recipient's number after you select a table entry.

**Step 4** Press one of the **Park** buttons at the bottom of the panel:

- Press the **Park** button to perform no additional action after parking the call.
- Press the **Park/Intercom** button to park the call and then initiate a new intercom call – typically to contact the recipient of the parked call.
- Press the **Park/Page** button to park the call and then initiate a new page call – typically to contact the recipient of the parked call.

The call cell that represents the parked call is removed from your Active Call Area. If the recipient's ShoreTel Communicator is active, the parked call appears on that user's Active Call Area as a call on hold.

**To unpark a call from ShoreTel Communicator:**

**Step 1** Perform one of the following:

- Select **Dial -> Pickup/Unpark** from the Main Menu.
- Click the Application Button and select **Dial -> Pickup/Unpark**.
- Right click the ShoreTel icon in the System Tray and select **Dial -> Pickup/Unpark**.
- Press Ctrl+Alt+P

**Step 2** Begin entering the contact name or number in the data entry field of the Pickup panel. Figure 4-3 displays the Pickup panel.

The table lists your directory entries filtered by the data entry field contents.

**Step 3** Either select a contact in the table or complete the number in the data entry field.

The **Dial Digits** field, located above the buttons at the bottom of the panel, lists the extension where the call was parked after you select a table entry.

**Step 4** Press the **Unpark** button at the bottom of the panel.

### 4.6.5 Call Recording

ShoreTel Communicator supports the recording of 2- or 3-way trunk calls. Converged conference calls cannot be recorded. Recording stops when a call is parked, unparked, or transferred. You can record your calls or those of other system users.

#### 4.6.5.1 Recording your calls

You can record conversations through ShoreTel Communicator if authorized by the system administrator. Call recording is performed on a call by call basis and must be initiated for each call that you want to record. A tone that informs external callers that there call is being recorded is a system option that is configured by the system administrator. ShoreWare places the recording file in your voice mail box when you end the recording or terminate the call.
To initiate a Call Recording of an active call, perform one of the following:

- Right click the call cell and select **Record**
- Select **Call -> Record** from the main menu.
- Click the Application Button and select **Call -> Record**.
- Press Ctrl+E.

You can also initiate a call recording by pressing the **Record Call** button in the ShoreTel Communicator toolbar. This button must be configured by the system administrator. Calls recorded by pressing the **Record Call** button are placed in the voice mail box designated by the system administrator.

To terminate a Call Recording from ShoreTel Communicator, perform one of the following:

- End the call, as described in Section 4.6.7.
- Right click the call cell and select **Stop Recording**
- Select **Call -> Stop Recording** from the main menu.
- Click the Application Button and select **Call -> Stop Recording**.
- Press Ctrl+E

### 4.6.5.2 Recording the Calls of Other Users

ShoreWare permits the recording of third party calls involving a system user over a trunk. The system administrator authorizes users to record other users' conversations and can designate which users' conversations can be recorded.

To initiate the recording of another user's call:

- Right click the desired user in the Contact List and select **Record**.
- Right click the desired user in the Agent Monitor and select **Record**.

You can also initiate a call recording of another user by pressing the **Record Extension** button in the ShoreTel Communicator toolbar. This button, configured by the system administrator, initiates the recording of a designated user specified by the administrator; the ability to record calls of two different users requires two distinct **Record Extension** buttons on your toolbars. Calls recorded by pressing the **Record Extension** button are placed in the voice mail box designated by the system administrator.

### 4.6.6 Sending Tones

The ShoreTel Communicator keypad has twelve keys, labeled 0 to 9, *, and #. Pressing a key sends a DTMF tone to the other party of the voice call. You cannot initiate a voice call with the keypad.

To access the keypad, press the keypad button located on the right side of the assignment bar. Figure 4-21 displays the keypad and the ShoreTel Communicator button that accesses the keypad.
4.6.7 Ending a Call

How you hang up a call depends on the mode in which you answer the call.

To disconnect a call from ShoreTel Communicator, perform one of the following:

- Press the HangUp button on the call cell.
- Right click the call cell and select Hang Up.
- Select Call -> Hang Up from the main menu.
- Click the Application Button and select Call -> Hang Up.
- Right click the ShoreTel Tray icon and select Call -> Hang Up.
- Press Ctrl+U

After disconnecting the call, place the device assigned to your extension on hook.

4.7 Specialty Calls

4.7.1 Conference Calls

Conference calls are voice calls that involve more than two parties. ShoreTel Communicator supports conference calls with a maximum of six participants. The maximum conference call size is specified by your system administrator. Conference participants may be ShoreWare users or external parties.

The Active Call Area in Figure 4-22 contains a conference call cell. The top line in the cell denotes the Conference Call type. The lines directly below the Conference Call indicator and status list the participants of the conference call.
To initiate a conference call, join two or more calls together, as described in Section 4.7.1.1.

To terminate a conference call, either hang up the entire conference or individually terminate call connections with conference participants, as described in Section 4.7.1.2.

### 4.7.1.1 Adding Calls to a Conference

Three ShoreTel Communicator operations adds participants into a conference call: specifying new participants, joining two calls, and a guided addition of a new call.

#### Specifying New Participants

Your specifying new participant through a Conference panel, shown in Figure 4-23.
To specify a new participant through the Conference panel:

**Step 1** Verify the selected voice call is in the *connected* state.

**Step 2** Open the Conference panel by performing one of the following:
- Click the Conference button on the call cell.
- Right click the call cell and select *Conference*
- Select **Call -> Conference** from the main menu.
- Click the Application Button and select **Call -> Conference**.
- Press Ctrl+J

**Step 3** Begin entering the contact name or number in the data entry field of the Conference panel.

The table displays a list of directory entries filtered by data entry field contents.

**Step 4** Either select a contact in the table or complete the number in the data entry field.

The **Dial Digits** field, located above the buttons at the bottom of the panel, lists the contact's number after you select a table entry.

**Step 5** Press the button at the bottom of the panel that corresponds to your desired Conference consultation type.

**Joining two calls**

Joining two calls merges them into a single conference call. You join the call in the connected state with the selected call. The selected call must be on hold.

To join the connected call with the call on hold into a single call:

**Step 1** Verify that the Active Call Area contains one call in the *connected* state and that the selected voice call is in the *on hold* state.

**Step 2** Perform one of the following actions:
- Click the Conference button on the call cell.
- Right click the call cell and select *Conference*
- Select **Call -> Conference** from the main menu.
- Click the Application Button and select **Call -> Conference**.
- Press Ctrl+J

The calls are joined into a single conference call.

**Guided Addition of a New Call**

When you have enabled Guided Transfers and Conferences, the call cell of a new call provides an option to transfer a call or join it with another call if you have another active call when receiving the call. Refer to Section 4.6.3.3 on page 52 for information about Guided Transfers and Conferences.
4.7.1.2 Removing Calls from a Conference
You can remove individual call from a conference or terminate the entire conference with a single command.

To **terminate the entire conference**, perform one of the following:

- Press the HangUp button on the call cell.
- Right click the call cell and select **Hang Up**
- Select **Call -> Hang Up** from the main menu.
- Click the Application Button and select **Call -> Hang Up**.
- Press Ctrl+U

After disconnecting the call, place the device assigned to your extension on hook.

To **terminate one call of the conference**, perform one of the following:

- Press the HangUp button on the call cell that corresponds to the party to be dropped.
- Right click the call cell and select the **Drop** option that corresponds to the party to be dropped.
- Open the **Call** option from the main menu and select the **Drop** option that corresponds to the party to be dropped.
- Click the Application Button, open the Call Menu and select the **Drop** option that corresponds to the party to be dropped.

After disconnecting the call, place the device assigned to your extension on hook.

4.7.2 Converged Conferencing
Converged Conferencing is a ShoreWare feature that supports calls with a maximum of 30 participants. The precise capacity depends on the topology of the network and the system configuration. Individual users must be authorized to perform converged conference calls. Consult your system administrator for capacity and authorization information.

You perform a Converged Conference call by accessing the Conference Bridge on your system. You must have an account on the Conference Bridge to initiate a converged conference call through that bridge. Refer to Converged Conference documentation for instructions on conducting a converged conference call.

ShoreTel Communicator supports the initiation of a Converged Conference call through a specified Conference bridge account. All other aspects of the call are managed through the Conference bridge user interface.

To **specify the Conference Bridge account for making Converged Conference Calls**:

**Step 1** Open the Options and Preferences window by performing one of the following:

- Select **Tools -> Options** from the Main Menu.
- Click the Application Button and select **Options**.
- Right click the ShoreTel Communicator icon in the System Tray and select **Options**.
- Press Ctrl+O.

**Step 2** Select **Conferencing** in the menu on the left side of the window.

**Step 3** Enter your Conference Bridge user name and password in the data entry fields.

Consult your system administrator for Conference Bridge logon information. Section A.2.14 on page 195 describes the Options and Preferences: Conferencing panel.
To initiate a voice call through the Make New Call panel, perform one of the following:

Select **Windows -> Conference Manager** from the Main Menu.
Click the Application Button and select **Windows -> Conference Manager**.
Right click the ShoreTel icon in the System Tray and select **Windows -> Conference Manager**.
Press Ctrl+Alt+K

ShoreTel Communicator displays the Conference Bridge dialog box, as shown in Figure 4-24.

**Figure 4-24 Conference Bridge Login panel - Video Section**

### 4.7.3 Video Calls

#### 4.7.3.1 Description

ShoreWare supports video calls between two ShoreTel Communicator users that are communicating directly. ShoreTel Communicator users communicating through a ShoreWare server cannot use video. ShoreWare does not support server-based, star-configurations or interoperability with other video solutions. ShoreWare performs video calls through an SVC codec.

ShoreWare does not support video-only calls. Video is added to a voice call as requested by a user. Video can either be added to an active voice call or established as a part of a new voice call.

#### 4.7.3.2 Supported Video Devices

Many video devices provide options to compensate for poor light conditions. Enabling these options may impact the frame rate of the camera. Using optimal light conditions is essential to ensure a good image quality and a proper frame rate when making video calls.
For a list of Video Cameras currently supported by ShoreTel Communicator, refer to “Video Camera Requirements for ShoreWare ShoreTel Communicator, Feature AN-10062”. These application notes are posted on the support site and searchable through the Knowledge base.

### 4.7.3.3 Adding Video to Existing Voice Calls

Users request a video call through the following ShoreTel Communicator components:

- **Active call cell**
  
  The video request button is active if both voice call participants are able to perform video calls.

- **ShoreTel Communicator Toolbar**
  
- **Make New Call menu or toolbar item**

Video session request recipients are notified when a ShoreTel Communicator user requests a video session. The notification panel display buttons for accepting or rejecting the request.

### 4.7.3.4 Video Window

Video is shown in an independent window that is not dockable with the ShoreTel Communicator window. The video window displays two ports to show both call participants. The resident ShoreTel Communicator user is displayed in the smaller window.

The video window provides the following components:

- **Video Status and Message Bar**: This component displays the video session status.
- **Answer Button**: This button resumes a call that is on hold. The video window displays this button when the user places the call on hold.
- **Hang-Up Button**: This button terminates the call.
- **Transfer Button**: This button transfers the call, including the video session, to another user.

Terminating a voice call also ends the video session. Ending a video session does not terminate a voice call.

### 4.7.3.5 Configuring Video Call Settings

ShoreTel Communicator users configure their Video Call settings from the Options and Preferences: Video panel.

Section A.2.16 on page 198 describes the **Options and Preferences: Video** panel.

### 4.7.4 Intercom

Intercom calls are simultaneously placed to all system users authorized to receive intercom calls. Intercom calls to idle IP phones and off-hook analog phones or off-hook SoftPhones in handsfree mode, are automatically answered and connected through the called party’s speaker phone following an announcement tone. Intercom calls to on-hook analog phones have the same ring as other calls.
Intercom calls are automatically answered if the called party's phone is:

- an IP phone with no active calls
- an analog phone that is off-hook with no active calls
- a SoftPhone that is off-hook with no active calls.

Intercom calls are treated as normal calls when the called party:

- is on-hook
- is in an active call
- does not have Intercom receive permission.

Intercom calls always override an extension's active call handling mode. For example, an intercom call to an extension that forwards all calls to voice mail will ring the extension.

The system administrator authorizes users to make or receive intercom calls.

To make an Intercom call from ShoreTel Communicator, perform one of the following:

- Click the Application Button and select **Dial -> Intercom**.
- Select **Dial -> Intercom** from the main menu.
- Right click the ShoreTel Tray icon and select **Dial -> Intercom**.
- Press Ctrl+Alt+N

To transfer an existing call to the intercom, execute a transfer from the Transfer panel as described in Section 4.6.3.2 on page 51.

### 4.7.5 Overhead Page

A paging extension accesses a site's overhead paging system. Calls to the paging extension are broadcast through the overhead paging system. ShoreWare defines one paging extension for each site. You can only call the paging extension at your site.

The system administrator authorizes users to make paging calls.

To call the paging extension, perform one of the following:

- Click the Application Button and select **Dial -> Overhead Page**.
- Select **Dial -> Overhead Page** from the main menu.
- Right click the ShoreTel icon in the System Tray and select **Dial -> Overhead Page**.
- Press Ctrl+Alt+G

The Overhead Page option on ShoreTel Communicator menus is disabled if a paging extension is not configured for your site or if you do not have authorization to call the paging extension.

### 4.8 Call Intervention

Call interventions are actions that ShoreTel Communicator users can perform on calls in which they are not involved. Barge In, Silent Monitor, and Whisper Page options are available through normal ShoreTel Communicator menus. Other actions are available through Programmable Toolbars.
### 4.8.1 Barge In

The Barge In function allows a user to join into another user's active call. The Barge In initiator can listen and speak to all other call participants. The right to initiate a Barge In operation is set by the system administrator. The system administrator also designates users whose calls can be interrupted by a Barge In.

**To Barge In another user's call:**

**Step 1** Perform one of the following
- Click the Application Button, then select `Dial -> Barge In`.
- Select `Dial -> Barge In` from the main menu.
- Right click the ShoreTel icon in the System Tray and select `Dial -> Barge In`.
- Right click the call cell and select `Call -> Barge In`.

ShoreTel Communicator displays the **Barge In** dialog box.

**Step 2** Enter an extension or select from the drop-down list.

**Step 3** Click the **Barge In** button.

### 4.8.2 Silent Monitor

Silent Monitor allows a user listen to another user's call without being heard by any of the call participants. When a call is being monitored, external callers may hear a monitor tone; system users are not signaled when their calls are monitored.

The right to initiate a Silent Monitor operation is set by the system administrator. The system administrator also designates users whose calls can be silently monitored.

**To perform a Silent Monitor:**

**Step 1** Perform one of the following
- Click the Application Button, then select `Dial -> Silent Monitor`.
- Select `Dial -> Silent Monitor` from the main menu.
- Right click the ShoreTel icon in the System Tray and select `Dial -> Silent Monitor`.
- Right click the call cell and select `Dial -> Silent Monitor`.

ShoreTel Communicator displays the **Silent Monitor** dialog box.

**Step 2** Enter an extension or select from the drop-down list.

**Step 3** Click the **Silent Monitor** button.

### 4.8.3 Whisper Page

Whisper Page allows a user to interrupt a user's call and talk with that user without being heard by the other calling party.

The right to initiate a Whisper Page is set by the system administrator. The system administrator also designates users whose calls can be interrupted with a Whisper Page.
To perform a Whisper Page:

**Step 1** Perform one of the following

- Click the Application Button, then select Dial -> Whisper Page.
- Select Dial -> Whisper Page from the main menu.
- Right click the ShoreTel icon in the System Tray and select Dial -> Whisper Page.
- Right click the call cell and select Dial -> Whisper Page.

ShoreTel Communicator displays the Whisper Page dialog box.

**Step 2** Enter an extension or select from the drop-down list.

**Step 3** Click the Whisper button.

### 4.8.4 Unparking Calls from Other Extensions

Users unpark calls from a monitored user's call stack by pressing a Monitored Extension button. To perform the unparked call function, the Extension Monitor button must be appropriately configured by the system administrator and ShoreTel Communicator cannot be servicing a connected call.

When the call stack of the monitored extension contains more than one call, the user can view a drop-down menu by pressing the arrow on the right side of the button. The drop-down menu displays contact information for each parked call on the stack. The desired call is unparked by selecting the corresponding entry in the menu.

The ShoreTel Communicator window in Figure 4-25, contains a Monitored Extension button with an accessed drop-down menu.

Pressing the button without accessing the menu unparks the first parked call.

![Figure 4-25 Unparked Call Button Drop-Down Menu](image-url)
4.9 History Viewer

The History Viewer displays information about your previous calls. Each History Viewer record includes the number of an outbound call's destination or inbound call's source along with the start time and duration of each call. History Viewer tools control the display of the calls, manage call records, and initiate calls to numbers listed in the call records.

To open the History Viewer, perform one of the following:

- Click the Application Button and select **Windows -> History**
- Select **Windows -> History** from the Main Menu
- Right click the ShoreTel icon in the System Tray and select **Windows -> History**
- Press Ctrl+Shift+H

The History viewer opens in the Main window content area or in a Satellite window.

The History Viewer record capacity is 1000 calls. Calls are added to the list when they are completed. When the list contents exceeds the capacity, records are removed in the order they are received when you exit ShoreTel Communicator.

ShoreTel Communicator operations available from History Viewer are available through a context menu by right clicking in the viewer table.

4.9.1 History Viewer Components

The History Viewer displays one record for each call that you make or receive, as shown in Figure 4-26. Each row corresponds to one call record. Each column lists one property of the call.

![History panel](image)

*Figure 4-26 History panel*
Voice Main Viewer components in Details mode include:

- **Filter bar**: The History viewer displays only entries whose sender name or number match filter bar contents. Filter bar contents are compared to columns that list name and contact information.

- **Column Headings**: Column headings indicate the data field name for the address entries.
  - **From/To**: This column displays an icon and label that indicates the call origination or disposition. Available icon labels include *To*, *From*, *Missed*, *Message*, and *Transferred*.
  - **Phone Number**: This column lists the number of the other party.
  - **Name**: This column lists the name of the party on the other side of the call. If the number matches a directory entry, this column displays the name of the entity.
  - **Start Time**: This column lists the time and date that the call was initiated.
  - **Duration**: This column lists the duration of the call in minutes and seconds.
  - **Call Note**: This column lists a note that was associated with the call. To enter a note for a History Viewer call, right click on the call and select *Properties*.
  - **Account Code**: This column lists the account code associated with a call. You attach an account code at the time of a call by right clicking the call cell.
  - **GUID**: The GUID is a number that identifies a call record.
  - **Trunk**: This column lists the system trunk through which the call was conducted.

The Routing Slip is not viewable from the Content table. However, you can view the Routing Slip for a call by right clicking on the call's record and selecting *Properties*.

Viewer operations that manipulate viewer heading bar contents include:

- **To add a column to the table**, right click in the Contents region and select *Choose Columns*. Then drag the column to be added to the desired location in the Column Heading.

- **To sort the contents**, click in the heading of the desired sort column. Clicking repetitively in the field reverses the order of the sort.

- **To move a column to a different heading location**, click and hold on the column to be moved, then drag the column to the desired location.

- **To remove a column from the table**, click and hold on the column to be removed then drag the column from the table until a large X appears on the column.

- **Contents**: The table below the column headings displays specified properties of your calls. Two viewer modes – Details mode and List mode – are available, as described in Section 4.9.3.

You can also view information about the call by right clicking on the record and selecting *Properties*.
4.9.2 Managing History Viewer Records

The following sections describe the file manipulation operations that control the contents of the History Viewer.

4.9.2.1 Deleting a Record

Messages moved to the Deleted folder remain there until 2:00 a.m. local (server) time, when ShoreWare removes messages that are at least 6 hours old. Voice mail messages less than six hours old remain in the Deleted folder until 2:00 a.m. the next day.

To move the highlighted message to the deleted folder, right click the record and select Delete Record(s).

4.9.2.2 Clearing the History

You can recover messages in the Deleted folder until ShoreWare removes them from the server during the 2:00 am voice mail maintenance cycle. To recover a message in the Delete folder, move it to the Inbox or Saved folders.

To remove all records from the History viewer, right click in the Contents region and select Clear History.

4.9.2.3 Exporting History Contents

ShoreWare supports the export of History viewer contents to csv files.

Comma-separated values (.csv) file format is a file type that stores tabular data by using commas to delimit data fields. CSV files are supported by most software applications and are convertible to conform to specific requirements.

To export History Viewer contents into a .csv file, right-click in the History Viewer Contents and select Export History from the context menu.

ShoreTel Communicator responds by converting the directory contents into a .csv file. Your computer then opens that .csv file through the program specified for .csv files through the folder options – typically notepad or MS Excel.

4.9.3 History Viewer Display Options

You control the display of History Viewer components from the context menu generated by right clicking in the content region.

History Viewer display options include:

- **Viewer Mode**: Viewer mode defines the format and contents of the content regions. The History Viewer defines two viewer modes:
  - **Details mode**: In this mode, the History Viewer displays all viewer components described below.
  - **List mode**: In this mode, the History Viewer displays only the Filter bar and Contents. The Contents region displays the Column Headings, Phone Number, Start Time, and Duration. You cannot alter the columns displayed in List mode.

To select the Viewer mode, right click in the contents region and select Details or List in the context menu.
• **Display Properties**: Select this option to display a popup that lists the call properties. This is the only method of viewing a call's routing slip from either mode.

• **Record Grouping**: Select this option to sort the call record by the call type, as specified in the From/To field.

• **Automatic Column Width Adjustment**: Selecting Fit Column Widths to Text adjusts the size of the content columns to display contents of all record fields.

### 4.9.4 Initiating Calls from the History Viewer

You can dial a previously made call or call back someone who called you from the History Viewer.

To dial the number associated to a History Viewer record, perform one of the following:

- Double click the call record
- Right click on the call record and select the desired number or address at the top of the context menu.

### 4.10 Call Routing Slips

A call routing slip lists the call's originating and destination information, the duration of the call duration, the list of other extensions that handled the call, and the final disposition of the call. You view an active call's routing slip from the Call Details panel; you view the routing slip of a previous call from the History panel, as described in Section 4.9.1.

To view the Call Details panel for the highlighted call perform one of the following:

- Right click the call cell and select **More Info** on the context menu.
- Click the **More Info** icon on the right side of the call cell.
- Click the Application Button and select **Call -> More Info**.
- Select **Call -> More Info** on the Main Menu.
- Right click the ShoreTel Tray icon and select **Call -> More Info**.

### 4.11 Call Notes

The Call Notes window is available to all clients, but will only be shown by default in an Operator ShoreTel Communicator. The window is displayed by using the corresponding menu option or the current Call Notes button on the call cell.

Once displayed, if there are no active calls, the Notes window is empty and no editing is permitted. You cannot display the call notes for multiple calls at the same time and ShoreTel Communicator will only display the notes for the currently selected call from the call cells list.

Call Detail Viewer display options include:

- **Call Notes Display**: For each selected active call the Notes window will display the Call Notes and Routing Slip for that particular call. By default the users are only allowed to add text to the Call Notes in this window as long as a call is active.

- Each line will be prefixed with the user's name and extension. The user can enter the text in the edit control and press Enter or click the "+" button on the right side of the edit control, to append the current text to the call note. The call note will not be modified until Enter or "+" keys are pressed.
Chapter 4: Voice Calls

ShoreTel 12 71

Figure 4-27  Call Detail Viewer

- Call Notes can be edited once the call has ended. The changes will only be saved locally on the machine.
- Call Notes can be manually edited in place, by checking the "Allow editing of the Call Note" option.
- The Support Info dialog displays information on: TAPI Call ID, HCALL and HLINE in hexadecimal notation.

Figure 4-28  Support Info Dialog
5.1 Description
Instant messaging is the real-time transmission of text between two or more system users. Instant messages are sent from and received through a message window. Instant messages do not use call cells. Users can participate in simultaneous multiple chat sessions.

ShoreTel Communicator provides IM presence to indicate user availability for engaging in instant messaging conversations. IM presence is described in Section 6.2.2 on page 82.

5.2 The Instant Message Window
The Instant Message window, shown in Figure 5-1, sends and receives text messages. ShoreTel Communicator displays this window under the following situations:

- the user initiates an instant message conversation
- the user receives the first message of an IM conversation

![Figure 5-1 Instant Message window components](image)

All IMs of a single conversation are displayed in the same Instant Message window. Closing an IM window erases all messages in the window unless they were previously saved. After closing an IM window, a user can start a new conversation with the same user.

ShoreTel Communicator options can configure Instant Messaging such that all chat sessions are controlled from a single window or that separate windows are opened for each chat session. Figure 5-1 displays an Instant Message window that controls two sessions; the
The display of each session is controlled by pressing the chat tabs located on the right side of the panel. The Options and Preferences: Instant Message panel configures the method of displaying multiple chat sessions, as described in Section A.2.13 on page 191.

The contents of a user's IM window is unaffected when other users close their IM windows.

The IM window contains the following components:

- **Address Bar**: displays the party with whom you are conversing.
- **Function Bar**: displays icons for initiating a voice call or for saving the current conversation.
- **Text Panel**: displays previously exchanged messages. Each message is immediately preceded by a header that lists the party that sent the message. The header may also list the time when the message was sent or received.
- **Separator**: divides the text panel and the input panel. You can move the separator bar up or down to adjust the size of the panels.
- **Input Panel**: displays text that you are preparing for the other participant.
- **Add Participant Field**: users are added to the visible chat session by entering their name, number, or address in this field.
- **Chat Tab (visible session)**: this tab denotes the chat session displayed in the text panel. The visible session is denoted by yellow background.
- **Session Participants**: this field lists the participants of the chat session displayed in the text field.
- **Chat Tab (dormant session)**: this field references a chat session that is not displayed in the text panel and is denoted by the blue background. To activate a dormant chat session, press the chat tab.
- **Send button**: transmits Input panel contents to the other participant. When you press the Send button, input panel contents are moved to the Text panel.
- **Status bar**: provides IM status messages, such as notification that the other participant is typing a message.

### 5.3 Conducting an IM Conversation

#### 5.3.1 Initiating an IM Conversation

You initiate Instant Messaging conversations from the following ShoreTel Communicator components:

- **QuickDialer**:
  - Enter the person's name in the QuickDialer field, then display that person's contact options by clicking the expand icon located left of the presence icon.
  - Figure 5-2 displays the Instant Message option for a QuickDialer contact.
  - Enter sip:<IM ID>, where <IM ID> is the other user's Instant Messaging address.

- **Directory Viewer**: Right click on the desired contact to display a menu that includes an IM option.

- **Call Toolbar**: Pressing the IM button adds an IM to an existing call. This button is inactive when there are no active calls.

- **History**: Right click on the History entry of a desired contact to display a menu that includes an IM option.
Chapter 5: Instant Messaging

5.3.2 Receiving the First IM of a Conversation

When you receive the initial message of an IM conversation, ShoreTel Communicator displays an Alert on the bottom right corner of the monitor. The Alert displays the text of the initial message. Clicking anywhere in the Alert opens an IM window. Figure 5-3 displays an Instant Message Alert.

Instant Messaging alerts are configured on the Options and Preferences: Instant Messages panel. You enable the display of alerts and specify the period that alerts appear on your monitor from this panel.

To dismiss the Alert without responding to the inbound IM, click the X symbol in the upper right corner of the Call Alert. The IM indicator in the taskbar continues flashing until you display the IM window.

Figure 5-3 Instant Message Alert
5.3.3 Creating and Sending a Message

To create a message, verify that the Message Window is active, then type the text in the input panel at the bottom of the Window.

To send the message, either click the Send button in the bottom right corner of the Message window or press the Enter key.

5.3.4 Adding a Participant to a Chat Session

Instant Message session can include two or more participants. To add a participant to an Instant Message session, enter contact information of the new participant in the Add Participant field on the right side of the Instant Message panel, as shown in Figure 5-1, then press the enter button. Subsequent messages are sent to all users listed in the Session Participant list.

5.3.5 Terminating an Instant Message Session

Closing the Instant Message window terminates all Instant Message sessions. When the Instant Message window controls more than one session, individual sessions are terminated by pressing the X icon on the right side of the chat tab.

5.4 Configuring Instant Messaging

5.4.1 Privacy and Control Access

Users control the list of people that can send them IM messages through IM Presence Privacy settings. Contacts that can view a user's IM presence can also send Instant messages to that user.

IM Privacy is described in Section 6.2.2 on page 82.

5.4.2 Instant Messaging Options

The Options and Preferences: Instant Messaging panel configures alert and IM window options along with identifying your user name on the server that conducts your instant message conversations. Section A.2.13 on page 191 describes the Options and Preferences: Instant Messaging panel.

The Options and Preferences: Sounds panel specifies the sound that the computer plays when ShoreTel Communicator receives an instant message. Section A.2.17 on page 197 describes the Options and Preferences: Sounds panel.
6.1 Description

Presence is a ShoreWare feature that identifies, uses, and distributes the availability of system users and other personal contacts. Presence information allows users to verify the availability of other users before attempting to contact them. Presence improves overall enterprise productivity by reducing calls to unavailable parties and by providing the enhanced ability to schedule immediate schedule meetings, events, and communication sessions based on the availability of desired participants. Users can also choose when to receive Instant Messages by changing their presence settings.

A user can monitor the presence of a maximum of 500 other contacts. System Administrators configure the number of contacts a user can monitor by setting the maximum contact list size.

6.2 Presence Types

ShoreTel Communicator defines three presence settings for each user.

- **Telephony presence** indicates user availability for accepting voice calls.
- **IM presence** indicates user availability for engaging in instant messaging conversations.
- **Combined presence** is a single setting that indicates user availability on the basis of Telephony and IM presence status.

Telephony presence is available to users of all ShoreTel Communicator types. IM presence is available to users of Professional, Operator, Workgroup Agent, or Workgroup Supervisor ShoreTel Communicator. Director settings control user access to both presence types.

ShoreTel Communicator implements presence through states and rules. **Presence states** indicates user status. **Presence rules** define conditions that trigger transitions between presence states. ShoreTel Communicator defines different presence states for telephony presence and IM presence.

6.2.1 Telephony Presence

Each user is assigned a presence state based on their communication availability. Users cannot manually select a telephony presence state.

ShoreWare assigns a priority level to each presence state. When a user condition triggers a potential transition into multiple presence states, ShoreWare assigns the state with the highest priority to the user.
ShoreWare defines the following Telephony Presence States, listed from highest to lowest priority:

**Ringing:** This state indicates that the user is receiving an inbound voice call. 
*Inbound phone calls* trigger a transition to **Ringing** from any lower state.

**Parked:** This state indicates a call is parked on the user's extension. 
*Having a call parked on a user's extension* triggers a transition to **Parked** from any lower state.

**Held:** This state indicates the user is on a call that is on hold. 
*Placing a call on hold* triggers a transition to **Held** from any lower state.

**On the Phone:** This state indicates the user is an active participant in a voice call. 
*Answering or initiating a voice call* triggers a transition to **On the Phone** from any lower state.

*Terminating a voice call* triggers a transition from **On the Phone** to the highest valid state.

**Do Not Disturb:** This state indicates that, within the user's active Call Handling Mode, the Call Forwarding Condition is set to **Always**.

**Busy:** This state indicates that the user's Call Handling State is not set to **Standard**. 
*Call Handling Mode changes from Standard* trigger a transition to **Busy** from **Online**.

**Online:** This state indicates that the user's Call Handling State is set to **Standard**. 
*Call Handling Mode changes to Standard* triggers a transition to **Online** from **Busy**.

**NA:** An extension is assigned to an external phone, from which ShoreWare cannot detect the telephony presence.

### 6.2.2 IM Presence

ShoreWare assigns a presence state to all users that have IM authorization. Presence rules define the conditions that trigger automatic transitions between presence states. Users can also manually change presence states.

ShoreWare defines the following IM Presence States, listed from highest to lowest priority:

**On the Phone:** This state indicates the user is an active participant in a voice call.

— *Answering or initiating a call* triggers a transition to **On the Phone** from any lower state.

— *Terminating a call* triggers a transition from **On the Phone** to the highest valid state.

Users cannot manually enter **On the Phone**.

**Manual Transition States:** ShoreWare defines four states to provide specific information as to why the user is unavailable for IM conversations. These states include:

— **Busy**
— **Away**
— **Be Right Back**
— **Out to Lunch**
Idle: This state indicates that ShoreTel Communicator has not detected any keyboard or mouse activity from the user during the period specified by the Idle Status option in the Instant Message Preferences and Options panel.

When ShoreWare detects keyboard or mouse activity while the user is in Idle mode, the presence state transitions to the state from which the Idle state was entered.

Offline: This state indicates that the user is not logged into the IM server or has manually set their presence to Appear Offline.

Online: This state indicates that all of the following conditions are true:

— The user is logged into the IM server.
— The user is not on a voice call.
— The user has not manually selected a lower priority state.
— ShoreTel Communicator has detected mouse or keyboard activity from the user during a specified period or the user has disabled the Idle Status option in the Instant Message Preferences and Options panel.

N/A: This state indicates that the user is not configured for instant messaging.

Users view and set their IM Presence from the Assignment bar. The Presence icon is located next to the Call Handling icon, as shown in Figure 6-1. Users change their IM presence state from the drop down menu shown in Figure 6-1.

Users can also view and set their IM Presence by clicking the Application Button and selecting IM Presence or by clicking the ShoreTel icon in the System Tray.

Users can attach a status note to their IM Presence State. This note appears in the IM Status column of the Contact List along with the name of the user's current state.

To specify an IM Presence Status Note, perform one of the following:

Click the Application Button and select IM Presence -> Set Status Note.

Right click the ShoreTel Communicator icon in the System Tray and select IM Presence -> Set Status Note.

Press Ctrl+Shift+I.
6.2.3 Combined Presence
ShoreTel Communicator displays the combined presence state when configured to show only one presence icon for each user. The combined presence is based upon the user's telephony presence and instant messaging presence states.

The following presence states are listed in priority order, from highest priority (1) to lowest priority (11). The text next to the combined state name specifies the condition that triggers a transition to the state.

1. In a Call: Telephony state – *On the Phone*, *Held / Park*, or *Ringing* states.
2. Do Not Disturb: Instant Messaging state – *Do Not Disturb*
3. CFA VM (*Call Forward Always*): Telephony state – *Do Not Disturb*
4. Busy: Instant Messaging state – *Busy*
5. Be Right Back: Instant Messaging state – *Be Right Back*
6. Away: Instant Messaging state – *Away*
7. Call Handling Mode: Telephony state – *Busy*
   This state is valid if the user's active call handling mode is not *Standard*.
8. Idle: Instant Messaging state – *Idle*
9. Callable: Telephony state – *Available*
10. Available: Telephony and Instant Messaging states – do not care
11. Unknown: Telephony and Instant Messaging states – unknown

Transition to a presence state requires that no higher priority states are valid.

Example: When the Telephony state is *Active* (1) and the Instant Messaging state is *Do Not Disturb* (2), then the Combined state is *In a Call* (1).

6.3 Displaying Presence
6.3.1 Configuring Display Options
Users can specify the presence information they publish through Option and Preference Presence options. Available options include displaying both presence settings, either of the settings, or a blended setting.

ShoreTel Communicator displays presence information in the following components:
- Assignment bar, as shown in Figure 6-1.
- Contact viewer displays the IM and telephony presences of the users' contacts.
  Hovering the cursor over an icon displays a popup that lists the active presence state.
- Make New Call dialog panel.
- Agent Monitor (telephony presence only).
- Redial drop down list in QuickDialer, as shown in Figure 6-2.
- Auto suggest list in QuickDialer.

ShoreTel Communicator automatically adjusts the presence status of users as they use system resources. Users can also manually adjust their status at any time.
Chapter 6: Presence

ShoreTel Communicator for Windows

6.3.2 Presence Change Alerts

Users can mark a contact to determine when that contact has terminated a phone call or an instant message session. ShoreTel Communicator then informs the user when the contact has changed their presence. Users that can access a contact’s IM presence information receive notification of IM or telephony presence changes. Users that are denied access to a contact’s presence information can only receive notification of that contact’s telephony presence change.

To mark a contact for a presence change alert, right click the desired contact in the Contact List and select Alert When Available on the context menu. If that contact is on the phone or in an Instant Message session, ShoreTel Communicator displays the popup shown in Figure 6-3 when that contact completes the call or session. If that contact is not on the phone or a session, the popup is displayed after the contact subsequently begins a call or session, then terminates it.

Pressing the snooze button closes the popup for the period listed on the button. If the contact is still available after the period elapses, the popup is displayed again. If the contact is not available, the popup is displayed immediately after the contact becomes available.

Figure 6-2 QuickDialer Presence Icons

The Options and Preferences: Instant Messaging – Presence panel specifies the presence icons that ShoreTel Communicator displays and the inactivity period that triggers the Idle state transition. Section A.2.13.2 on page 192 describes the Options and Preferences: Instant Messaging – Presence panel.

Figure 6-3 Presence Change Alert popup
6.4 IM Presence Privacy

IM Presence Privacy provides users the capacity to manage the visibility of their IM presence status. Restricting access to IM Presence information also prevents blocked users from sending instant messages to users restricting their access.

6.4.1 Privacy States

Presence privacy states define the IM interaction status between two system users. Users restrict access to their IM presence state by assigning a privacy state to other users. ShoreWare defines the following presence privacy states:

- **Allowed**: This state indicates that the requested party has received access to the user's IM presence status.
- **Blocked**: The default state, which indicates that the requested party was denied access to the user's IM presence status. A user's IM presence state appears as **Offline** to all users whose state *Don't Show Status*.
- **Pending**: This state indicates that the user has not responded to the party's request for IM presence status.

Until the requested user responds to a presence request, the presence state of that user depends on the type of presence server that the user accesses:

- **OCS 2007**: Contact's presence is displayed until access is blocked
- **Converged Conferencing 7.1**: Presence state is offline until access is allowed

6.4.2 Responding to Presence Access Requests

ShoreTel Communicator provides the following methods of requesting access to a user's presence state:

- adding the user to the Contact List
- calling the user
- sending the user an Instant Message

Administrators can configure Class of Service options to require users to approve privacy requests or to automatically accept all requests to a user. Users that are required to approve privacy requests are only able to view other users privacy from the Contact List.

Contacts that are denied access to a user's presence information appear as **Offline** in the user's contact List and QuickDialer fields. Contacts can send instant message to only users that grant them access to presence privacy information.

A popup window notifies the recipient concerning a presence access request. The recipient responds to the request by marking the checkboxes of contacts, then pressing the OK button. Contacts that are not checked when the OK button is pressed are denied access to the user's presence information. Figure 6-4 displays a privacy request notification popup.
The bottom two parameters provide options for adding checked contacts to the user's Contact List and to automatically accept all future presence privacy requests.

6.4.3 Managing the Privacy Access List

The Options and Preference: Instant Messaging Privacy panel, as shown in Figure 6-5, displays contacts that are allowed or denied access to a user's Presence Privacy information. Refer to Section A.2.13.3 on page 193 for a description of the Options and Preference: Instant Messaging Privacy.

The table on the right side of the panel displays contacts for whom the user has granted or denied presence information access. The data field immediately above the table filters contacts displayed on basis their access to presence information. Users can add contacts to the list by pressing the Add button at the bottom of the panel. The status of a contact's access can be changed by highlighting that contact in the list and pressing the Allowed or Blocked button located at the bottom of the panel. Contacts are removed from the list by pressing the Delete button.

Users do not receive instant messages from contacts whose privacy state is *Blocked.* Presence access requests are also blocked from these users.
6.4.4 Access Request Settings

Although presence privacy settings are configured by each user, ShoreWare provides tools for administering IM presence access requests on a system or user basis. Presence access requests for the entire ShoreTel system are administered through by the system administrator, which may affect ShoreTel Communicator configuration settings. Refer to your system system administrator for configuration information about your system.

Users control automated acceptance of IM presence access settings from the Options and Preferences: Instant Messaging – Privacy panel. Section A.2.13.3 on page 193 describes the Options and Preferences: Instant Messaging – Presence panel.

Figure 6-5 Instant Messaging Privacy panel
7.1 Introduction

SoftPhone is a ShoreTel Communicator software component through which you participate in voice calls and listen to messages over your computer through a headset or speakers with a microphone. SoftPhone is a licensed feature that is enabled by your system administrator.

7.2 Using the SoftPhone

7.2.1 Assigning SoftPhone to Your Extension

To assign SoftPhone to your extension, perform one of the following actions:

- Click the Application Button and select Extension Assignment -> SoftPhone.
- Click the Assignment button on the Assignment Bar and select SoftPhone on the drop down menu, as shown in Figure 7-1.
- Right click the ShoreTel icon in the System Tray and select Extension Assignment -> SoftPhone.
- Press Ctrl+Shift+S

The Assignment button displays the SoftPhone icon to indicate that your extension is assigned to the SoftPhone.

Figure 7-1 Activating SoftPhone from the Extension bar
7.2.2 Managing SoftPhone Calls through ShoreTel Communicator

You initiate, control, and terminate voice calls through SoftPhone by performing ShoreTel Communicator operations, as described in Chapter 4.

7.2.3 Keypad

The ShoreTel Communicator keypad, located on the right side of the Assignment bar, has twelve keys labeled 0 to 9, *, and #. Pressing a key sends a DTMF tone to the other party of the voice call. You cannot initiate a voice call with the keypad.

7.2.4 Muting the SoftPhone

Muting the SoftPhone disables the microphone, allowing you to continue listening to the other party without being heard. The SoftPhone Mute button is on the right side of the Assignment bar, as shown in Figure 7-2. In addition to controlling your microphone, the Mute button displays the mute status.

To mute the SoftPhone, press the Mute button.
To enable the muted SoftPhone microphone, press the Mute button.

Figure 7-2 Mute Button in the Main Window

Figure 7-3 Mute button states

7.3 Configuring SoftPhone

The Options and Preferences: SoftPhone panel specifies the computer sound devices and network adapter used by SoftPhone. Section A.2.15 on page 195 describes the Options and Preferences: SoftPhone panel and the SoftPhone configuration parameters on the panel.
Managing Address Entries

8.1 Introduction

ShoreTel Communicator provides three viewers for organizing and displaying address information of ShoreWare system users and other personal contacts. You can also initiate and manage communication sessions through these viewers.

The **Directory viewer** displays all system users and personal contacts. You can also display Outlook contacts in the ShoreTel Communicator directory.

The **Contact viewer** displays selected Directory entries to provide convenient access to frequently accessed entries.

The **Speed Dial viewer** provides a list of entries that you can initiate contact through pressing a single phone button. You can also initiate calls from this viewer.

This chapter describes the ShoreTel Communicator address viewers.

8.2 Directory Viewer

The Directory Viewer displays contact information for all entities listed in all rosters available to your user account, including the system user directory, Outlook contacts, and personal entries that you add. You can view and modify contact information, initiate communication sessions, and send messages to directory entities from the Directory Viewer.

To open the Directory Viewer, perform one of the following:

- Click the Application Button and select **Windows -> Directory**
- Select **Windows -> Directory** from the Assignment Bar
- Select **Windows -> Directory** from the Main Menu
- Right click the ShoreTel icon in the System Tray and select **Windows -> Directory**
- Press Ctrl+Shift+D

The Directory viewer opens in the Main window content area or in a Satellite window.

8.2.1 Directory Components

The Directory Viewer displays a list of contacts, as shown in Figure 8-1. Each row corresponds to one address entry. Each column lists one directory entry property. You can customize the Directory viewer to display a subset of the available columns.

Columns that the Directory viewer can display include:

- **Data Source**: This field indicates where source of the contact – system extensions; imports from your Outlook contact list or address book; or user created entries.
- **Company**
Directory viewer components include:

**Filter bar**: The Directory viewer displays only entries whose information, in specified columns, matches text in the filter bar. Filter bar contents are compared to columns that list name and contact information. Column contents are compared to filter bar contents regardless of their display status.

**Column Headings**: Column headings indicate the data field name for the address entries.

- To add a column to the table, right click in the Directory Contents region and select Choose Columns. Then drag the column to be added to the desired location in the Column Heading.
- To sort the Directory Contents, click in the heading of the desired sort column. Subsequent clicking in the heading reverses the order of the sort.
- To move a column to a different heading location, click and hold on the column to be moved, then drag the column to the desired location.
- To remove a column from the table, click and hold on the column to be removed then drag the column from the table until a large X appears on the column.
Directory Contents: The table below the column headings displays address information for the contacts that are accessible to ShoreTel Communicator. Directory contents may be provided from three sources:

- ShoreWare system users. You cannot remove or edit these entries.
- Personal contacts added by the user.
- Outlook Contacts when Outlook Contact Import is enabled.

In addition to performing column heading sorts, you can group address entries by Company or Data Source. When address entries are grouped, the field by which the contents are grouped is listed as a data entry field instead of a column heading.

- To group Directory Contents, right click in the Directory Contents table and select Group By -> Company or Group By -> Data Source.
- To turn off grouping, right click in the Directory Contents table and select Group By -> Don’t Group.

8.2.2 Managing the Directory

The Directory viewer includes a tool for exporting all directory entries to a .csv file. You can also add directory entries to your Contacts viewer from the Directory viewer.

8.2.2.1 Exporting the Directory to a .csv File

Comma-separated values (.csv) file format is a file type that stores tabular data by using commas to delimit data fields. CSV files are supported by most software applications and are convertible to conform to specific requirements.

To export Directory viewer contacts into a .csv file, right-click the Directory Contents and select Open as Text.

ShoreTel Communicator responds by converting the directory contents into a .csv file. Your computer then opens the .csv file through the program specified by your folder options – typically notepad or MS Excel.

8.2.2.2 Importing Directory Entries from a File

ShoreTel Communicator supports the import of contact entries contained in a tab-delimited file. The first row in the file must list column headings for which contact information is provided by the file. Only data that corresponds with a column headings that match a pre-defined ShoreTel Communicator column heading will be imported into the directory. To view the available column headings, refer to the Column Heading bullet item in Section 8.3.2.2 on page 95.

To import contacts from a Tab-Delimited File:

Step 1 Open the Directory Viewer

Step 2 Open the Import Directory wizard by righting click in the contact table and selecting Import.

Step 3 Click the Browse button and navigate to locate the file to be imported.

Step 4 Press the Next button.
8.2.2.3 Adding Directory Entries to the Contact List

Contact groups are subsets of your Directory that provide convenient access to selected Directory entries, as described in Section 8.3. You can add Directory entries to contact groups from the Directory viewer.

To add a Directory entry to a contact list:

Step 1 Select an entry in the Director Viewer.

Step 2 Right-click the entry and select Add as a Contact.

Step 3 Select the contact list from the menu list, as shown in Figure 8-2.

You can also add an entry to a contact group by dragging a Directory entry into the desired group in the Contact Viewer.

8.2.3 Managing Personal Directory Entries

In addition to displaying system users and your Outlook contacts, the Directory viewer lists address entries for contacts that you add to your directory. The Directory viewer indicates address entries that you added to the Directory by specifying the Data Source as Personal Directory.

You can add, edit, and remove personal address entries through the Directory Viewer. You cannot change the name or contact information for System Directory entries or addresses imported from Outlook. You cannot remove System Directory entries or addresses imported from Outlook.

To add a personal contact to the Directory Viewer:

Step 1 Right-click in the Directory Contents and select New Directory Entry.

ShoreTel Communicator displays the Directory item details panel, shown in Figure 8-3.

Step 2 Enter the address information for the new personal contact.

Step 3 Press the OK button to add the address entry to your directory.
To edit contact information for a personal contact:

Step 1 Right-click a Directory viewer entry and select View Directory Item Detail. ShoreTel Communicator displays the Directory item details panel for the contact, as shown in Figure 8-4. The text at the top of the panel indicates the edit status of the entry.

Figure 8-3 Directory items details panel – adding a new entry

Figure 8-4 Directory items details panel – editing an existing entry
Step 2  Modify the desired data fields.

Step 3  Press the OK button to modify the address entry in your directory.

To delete a Personal contact, right-click the desired Directory entry and select **Delete Directory Item(s)**.

### 8.2.4 Initiating Calls through the Directory Viewer

You can initiate communication sessions to contacts through the Directory viewer. Communication sessions that you can initiate through Directory viewer include:

- Voice calls to extensions and other phone numbers
- Instant Messages
- Voice Messages
- Email messages

To initiate communication session to a Directory viewer contact, perform one of the following:

- Double click a Directory viewer entry to initiate a voice call
- Right-click a Directory viewer entry to display the context menu.

The context menu, as shown in Figure 8-5, displays the contact methods defined for the user in the Directory viewer. The context viewer in Figure 8-5 provides a business phone number, mobile phone number, home phone number, another phone number, and an email address. Click on the desired address to initiate the specified communication session.

![Figure 8-5 Directory Context Menu – Initiating a Communication Session](image-url)
8.3 Contact Viewer

The Contact Viewer provides access to Contact Groups, which are subsets of your directory entries. Contact Groups provide convenient to directory entries that you frequently reference. The Contact Viewer is available to Professional, Workgroup Agent, Workgroup Supervisor, and Operator types of ShoreTel Communicator.

This section describes basic Contact Viewer functions. Chapter 12 describes Contact Viewer functions available only to Workgroup Agent, Workgroup Supervisor, and Operator.

To open the Contact Viewer, perform one of the following:

- Click the Application Button and select Windows -> Contacts
- Select Windows -> Contacts from the Main Menu
- Select Windows -> Contacts from the Assignment bar
- Right click the ShoreTel icon in the system tray and select Windows -> Contacts
- Press Ctrl+Shift+C

The Contact viewer opens in the Main window content area or in a Satellite window.

8.3.1 Contacts

Contacts are address entries selected from directories accessible to ShoreTel Communicator, including the system directory, your personal directory and Microsoft Outlook. Contact Groups are accessed from the Contacts Viewer and provide quick access to address entries without navigating through the comprehensive directory. Users can perform tasks on Contact Group entries such as initiating voice call or instant messages, handling active calls, and sending email or voice messages.

Contacts are divided into Contact Groups. ShoreTel Communicator requires the definition of at least one Contact Group; the initial default Contact Group is named Contacts. You can create, rename, or delete Contact Groups.

The Contact Viewer displays the complete Contact List through a collapsible tree structure that lists the defined Contact Groups. The tree can be expanded to view the contents of selected Contact Groups.

A Contact can be placed in multiple Contact Groups. Contact groups cannot contain subgroups.

Upon launching ShoreTel Communicator for the first time, the Contacts window displays and explanation on what Contacts are and how they can be added to this window.
8.3.2 Contact Viewer Components

The Contact Viewer displays Contact List contents. You can manage your contacts and communication sessions with your contacts from the Contact viewer.

8.3.2.1 Viewer Modes

ShoreTel Communicator provides the following Contact Groups views:

- **Details** – Each attribute is listed in an individual column, similar to the traditional Windows Explorer column view. Contacts can be sorted in this view by clicking the column headings at the top of the list.

- **List** – Contacts are displayed in a single column that shows the Contact name and the presence status. Contacts are listed alphabetically in this view.

  List is the default view.

- **Small Icons** – This view displays all Contacts without separating them into Contact Groups. Presence is displayed using small icons.

- **Large Icons** – This view displays all contacts without separating them into Contact Groups. Presence is displayed using large icons.

Each view includes a filter bar, similar to QuickDialer, that filters the Contact Groups to entries that match filter bar contents. Figure 8-7 displays a Contact viewer in Details mode.

To select a Contact viewer mode, right-click in the Contacts area and select the desired viewing mode.
8.3.2.2 Viewer Components

The components that are visible on the Contact viewer depends on the viewer mode. The following is a list of Contact viewer components:

Filter bar: The Contact viewer displays only entries whose information matches the text in the filter bar. Filter bar contents are compared to columns that list name and contact information for the entries, regardless of the appearance of the contact information in the current viewer mode.

All Contact viewer modes display the Filter bar.

Column Headings: Column headings indicate the data field name for the address entries.

— To add a column to the table, right click in the Contents region and select Choose Columns, then drag the column to be added to the desired location in the Column Heading.

— To sort the contents, click in the heading of the desired sort column. Subsequent clicking in the field reverses the order of the sort.

— To move a column to a different heading location, click and hold on the column to be moved, then drag the column to the desired location.

— To remove a column from the table, click and hold on the column to be removed then drag the column from the table until a large X appears on the column.

Column Headings are visible in the Details viewer mode.

Contact Group bar: In viewer modes that separate the contacts by group, the Group bar indicates the Contact Group to which the successive contacts belong. The Contact viewer in Figure 8-7 displays two contact groups: Eastern Contacts and Western Contacts. Each group comprises three contacts.

Contact Group bars are visible in the Details and List viewing modes.

Contacts: The contact table displays each of the defined contacts in your lists, along with Presence icons specified in the Preferences and Options panel. Viewing modes that display Contact Group bars can hide all contacts within a group by pressing the collapse button located left of the group name.

All viewing modes display the defined contacts. The information listed with each contact and the appearance of the icons depend upon the selected viewing mode.
8.3.3 Managing Contacts

8.3.3.1 Adding Entries to the Contact List

Contacts are added to a Contact List through each of the following actions:

Step 1  Click the Add icon on the Contact Viewer toolbar or right click on an entry in the Contact Directory viewer and select *Add as a Contact*.

Step 2  Enter the name and the group of the contact and click OK.

Step 3  Open the *Add Contact* panel, shown in Figure 8-8, by right clicking in the Contact List and selecting *Add Contact*.

The radio button options at the top of the panel specify the source of the new contact.

— Create a new contact from scratch. Select this option when information for the new contact is not in the Directory List. ShoreTel Communicator also creates a Personal Directory entry for the contact when you select this option.
— **Link this contact to an existing Directory Entry.** Select this option to add a contact that exists in the Directory viewer.

The panel displays a data entry field directly below the option text. Enter the name, extension, or address of the Directory entry to be added to the Contacts List in this field. All other data fields are filled with the Directory entry information. Data fields are editable for Personal Directory entries. Data fields are not editable for System or Outlook Directory entries.

Drag a name from the Directory viewer into the Contact viewer. If the Directory window and the Contact List are in the same Content Area, dragging entries over the Contacts tab switches the view to the Contact List.

This method is available only in Operator, Workgroup Agent, or Workgroup Supervisor ShoreTel Communicator.

### 8.3.3.2 Using Contacts Quick Dialer

When the user clicks the Add Contact option a dialog box will display where you can enter the contact's name and groups. As the user starts typing, the quick-dialer-type drop down will be displayed for the user to choose an existing Directory entry.

The listed entries will display the Phone icon if that contact has a system extension so that the telephony presence can be seen in the Contacts window or the IM icon if that contact has IM.

Once an entry is selected from the list and the OK button is clicked, that entry will be added to the specified group in the Contacts window. If a contact is already present in the group that was originally selected, the dialog will try to select the next group that does not contain the selected entry, if possible. If all existing groups already contain the contact, an error message will be shown and the entry will not be added.

![Quick Dialer Viewer](Figure 8-9)

If you do not wish to add a Directory entry, but instead wants to create a new contact from scratch, a new entry is available at the end of the match list, titled New Contact.
8.3.3.3 Editing a Contact Entry

You can edit the contact information for Personal contacts in the Directory Viewer or Contact Viewer. You cannot change the name or contact information for System Directory contacts or addresses imported from Outlook. You can change the default number from this panel for all contacts.

To edit Contact address information through the Contact viewer:

Step 1 Right-click on the selected entry in the Contact viewer and select More Info from the context menu.

ShoreTel Communicator responds by displaying the Contact Properties panel for the contact, as shown in Figure 8-10. The text at the top of the panel indicates the edit status of the entry.

Step 2 Modify the desired data fields.

Step 3 Select a default phone number by clicking left of the label of the desired number. This field is editable for all contacts.

The checkmark located left of a phone number indicates the number that ShoreTel Communicator calls when you double-click a Contact viewer entry.

Step 4 Press the OK button to change the Contact and Directory information.
8.3.3.4 Removing a Contact Entry
Deleting entries from a Contact List makes them inaccessible from the Contact Viewer. Removing an entry from the a Contact List does not affect its corresponding Directory entry. You can remove any contact from the contact list.

To delete a Contact, right-click the desired contact and select Delete Contact.

8.3.4 Contact List Operations
The list of operations that you can initiate through the Contact viewer include:

- Initiate an instant message conversation
- Send an email message
- Initiate a voice call
- Initiate a video call
- Pickup a call
- Unpark a call
- Send a voice message
- Send an Intercom message
- Barge In
- Silent Monitor
- Whisper Page
- Record a voice call
- Remove a contact from the contact list.

To initiate a voice call to a contact's default number, perform one of the following:

- Double-click on the name of the desired contact.
- Drag and drop the name of the desired contact into the Active Call Area in the Main Window.

To initiate a voice call to any of the contact's number or to initiate any other caller operation, right click on the desired contact and select the operation or phone number from the context menu.

8.4 Importing Contacts from other applications
ShoreTel Communicator supports the import of data records from CSV or XML files for display in the Directory Viewer. The CSV and XML files contain lists of contacts and are formatted specifically for integration with ShoreTel Communicator.

The CSV and XML files are not modified by the import process, nor are the contacts permanently added to the user's ShoreTel Communicator database.

ShoreTel Communicator caches CSV or XML file contents at start-up and after each file change. The data is available in the Directory Viewer, Contacts Viewer, and QuickDialer. ShoreTel Communicator reports errors during the cache process to the user and in log files. ShoreTel Communicator receives records from all properly formatted CSV and XML files in the target directory.

ShorePhones do not display records imported from other applications.
8.4.1 Implementation

The following sections describes the steps required for ShoreTel Communicator to import records from a data file. Section 8.4.2 describes the properties of CSV and XML import files.

8.4.1.1 Editing the Registry

ShoreTel Communicator reads data files located in a directory specified by the following registry key:

Location: HKEY_CURRENT_USER\Software\Shoreline Teleworks\ShoreWare Client
Key: ContactImportLocation.

The value in this registry is a string. The default value of this key is a string that points to the Contacts directory in the user profile directory:

C:\Documents and Settings\username\Application Data\ShoreWare Client\Contacts

The registry entry can point to a PC location or a server path.

ShoreTel Communicator does not automatically create this key or assign a default value to it. This registry must be created and assigned to location of the contact files before ShoreTel Communicator can import data records from the file.

WARNING Windows registry changes are effective immediately, and backups are not created automatically. Only experienced personnel should attempt registry changes.

Figure 8-11 displays the registry editor after insertion of the ContactImportLocation key. This registry is set up such that ShoreTel Communicator will import records from CSV and XML files located in Bonnie Hopkin's CM_Import folder.
8.4.1.2 Placing the File

Properly configured CSV and XML Files placed in the folder specified by the ContactImportLocation key are immediately cached to ShoreTel Communicator. Changes to these files are visible when the edited file is saved.

When a file is removed from the folder, the contacts listed in that file remain in the Directory Viewer until ShoreTel Communicator is exited. Contacts removed from a file also remain in the Directory Viewer. When ShoreTel Communicator is started again, all records removed by contact deletion or file removal do not appear in the Directory Viewer.

8.4.1.3 Viewing the Contacts

Directory View

Contacts imported from CSV or XML files appear in the Directory Viewer, as shown in Figure 8-12. When contacts are grouped by data source, they appear under a heading that lists the Data Source. When the contacts are grouped by company or not grouped, the Data Source column indicates either the name of the originating file or the contents of the Name field in the originating file.

![Figure 8-12 Directory Viewer containing Imported Records](image-url)
Directory Item Details

Details of contacts imported from the CSV or XML files are visible from the Directory Item Details panel, access by right clicking a contact and selecting View Directory Item Detail. The Directory Item Details panel, as shown in Figure 8-13, indicates the source of the file in the first data field and states that the record contents are not editable.

Figure 8-13 Directory Item Details

Quick Dialer

The imported CSV/XML file contacts will be available in all QuickDialer controls. They will appear in the list just like any other contact.

8.4.2 File Properties

8.4.2.1 CSV Files

CSV files contains records, each of which consists of data fields. The following sections describe the composition of CSV file fields and records.

Field Composition

Each field denotes one property for the file or for one contact. The field entries must conform to the following syntax rules:

- Data is of type *strings* and supports UTF-16 encoding.
- Fields that contain a double quote must be surrounded by double quotes. Double quotes are indicated by two double quotes.

Example 1: A “tiny” space -> “A ““tiny”” space”
Example 2: “Joe” -> ““Joe””
Example 3: “Red” Wagon -> ““Red”” Wagon
• Fields that contain commas must be surrounded by double quotes.
  
  Example 1: “ShoreTel, Inc.”

• Fields that do not contain double quotes or commas with double quotes may be surrounded with double quotes.

• Data fields with no information translate into blank entries in ShoreTel Communicator

Record Types

Each line in a CSV file corresponds to one data record. The end of a record is denoted by a Carriage Return and Line Feed.

ShoreTel Communicator CSV integration files define three types of records

• **File Information Record**: The File Information Record denotes the Source of the data and the Version of the file. Inclusion of this record in the CSV file is optional. When it is included, the File Information Record must be the first record in the file.

  — **Source**: This field is associated with all file records in ShoreTel Communicator and corresponds to the **Data Source** column in the Directory Viewer. Typically, this value is set to the original source of the file contents.

  When this field is not included, ShoreTel Communicator uses the CSV or XML file name as the **Data Source** contacts imported into the Directory Viewer.

  — **Version**: This field displays the version of the contact information. When included, this field must be set to 1.0.

  Source and Version variable declarations must conform to the following:

  — Syntax for the Source variable is `Source=sourcetext`.

  — Syntax for the Version variable is `Version=versionname`.

  — The Source and Version variables are optional.

  Example 1: “Source=Lotus”, ”Version=1.0”

  Example 2: `Source=Lotus, Version=1.0`

• **Contact Header Record**: The Contact Header Record is mandatory and lists the names of the heading files in the Viewer Directory. The Contact Header Record is located immediately after the File Information Record. If the file does not contain a File Information Record, the Contact Header Record is the first record in the file.

  Although field names correspond to Directory Viewer heading names, the field names are not always identical to the heading.

  The following is a list of valid field names for CSV import files:

  — **Contact ID**: This field uniquely identifies the contact record within the file. The Contact ID is a string with a maximum of 126 characters. ShoreTel Communicator does not display this field. All contact records require a Contact ID. If multiple contact record contain identical Contact IDs, the last such contact is the list is imported into ShoreTel Communicator and all other contacts with the same ID are ignored.

    ShoreTel Communicator does not display the contents of this field.

  — **First name**: Directory Viewer displays contents under the First Name column.

  — **Middle name**: Directory Viewer displays contents under the Middle Name column.

  — **Last name**: Directory Viewer displays contents under the Last Name column.

  — **Company**: Directory Viewer displays contents under the Company column.
— **Department**: Directory Viewer displays contents under the Department column.
— **Business Phone**: Directory Viewer displays contents under the Business column.
— **Business Phone 2**: Directory Viewer displays contents under the Business 2 column.
— **Home Phone**: Directory Viewer displays contents under the Home column.
— **Home Phone 2**: Directory Viewer displays contents under the Home 2 column.
— **Mobile Phone**: Directory Viewer displays contents under the Mobile column.
— **Pager**: Directory Viewer displays contents under the Pager column.
— **Business Fax**: Directory Viewer displays contents under the Fax column.
— **Email Address**: Directory Viewer displays contents under the Email column.
— **Email2 Address**: Directory Viewer displays contents under the Email2 column.
— **Email3 Address**: Directory Viewer displays contents under the Email3 column.
— **IM Address**: Directory Viewer displays contents under the IM column.
— **Categories**: Directory Viewer displays contents under the Categories column.

**Example 1**: “Contact ID”, “First Name”, “Last Name”, “Business Phone”

**Contact Record**: The file contains one record for each contact that is integrated into the Directory viewer. The order of data fields in each contact record must be identical to the fields in the Contact Header Record.

**Example 1**: “ID_100”, “Johnny”, “Fracas”, “398-212-0012”
**Example 2**: ID_100, Johnny, Fracas, 398-212-0012

**CSV Examples**

The following is an example of a CSV file where all fields are surrounded by double quotes:

```
"Source=Lotus","Version=1.0"
"Contact ID","First Name","Middle Name","Last Name","Company","Department","Business Fax","Business Phone","Home Phone","Mobile Phone","Pager","Categories","Email Address"
"1234","Maude","June","Bigsby","Anycorp, Inc.",","","(398) 777-8888"
```

The following is an example of a CSV file where only fields with commas and double quotes are surrounded by double quotes:

```
Source=Lotus,Version=1.0
Contact ID,First Name,Middle Name,Last Name,Company,Department,Business Fax,Business Phone,Home Phone,Mobile Phone,Pager,Categories,Email Address,IM Address
1234,Maude,June,Bigsby,"Anycorp, Inc.",",",",,(398) 777-8888,,
```
8.4.2.2 XML Files

XML files contain a structured set of elements. The following sections describe required file components and XML elements recognized by ShoreTel Communicator.

**XML File Name**

The file name must have the extension .xml.

**Elements**

The following elements are recognized by ShoreTel Communicator Contact XML files.

**Level 1 Elements:** Each file contains one **Contacts** element.

- **contacts**: The Contacts element specifies the source name and version number and contains one Contact element for each contact in the file. Defines valid attributes
  - **valid attributes**: source, version
  
  **Example:** `<contacts source = “File 1” version = “1.0”> </contacts>`

**Level 2 Elements:** The **Contacts** element contains one **Contact** element for each user defined by the XML file. Each contact element contains Level 3 elements that define the field contents for the user. Each Contact element must contain one ContactID element and one other Level 3 element.

**Level 3 Elements:** Level 3 elements are contained with the Contact element and specify field contents for contacts imported to ShoreTel Communicator. The following is a list of Level 3 elements.

- **contactID**: This field uniquely identifies the contact record within the file. The Contact ID is a string with a maximum of 126 characters. ShoreTel Communicator does not display this field. All contact records require a Contact ID. If multiple contact record contain identical Contact IDs, the last such contact is the list is imported into ShoreTel Communicator and all other contacts with the same ID are ignored.

  **Example:** `<contactID>1234</contactID>`

- **name**: This element specifies the contact's name. Each contact element may contain only one name element.
  - **valid attributes**: first, middle, last

  **Example:** `<name first="Sarah" middle="Jane" last="Clauser"/>`

- **company**: Each contact element may contain only one company element.
  - **valid attributes**: value

  **Example:** `<company name="Anycorp, Inc."/>`

- **department**: Each contact element may contain only one department element.
  - **valid attributes**: value

  **Example:** `<department value="Sales"/>`

- **categories**: Each contact element may contain only one categories element.
  - **valid attributes**: value

  **Example:** `<categories value="Austin"/>`

- **phone**: This element specifies the contact's phone numbers. A contact element may contain multiple phone elements, subject to the following:
— valid attributes: type, name, value

Type: The type attribute must be equal to one of the following: Business, Home, Mobile, Pager, and Fax.

- An element may contain 2 phone elements with name is equal to Business
- An element may contain 2 phone elements with name is equal to Home
- An element may contain 1 phone elements with name is equal to Mobile
- An element may contain 1 phone elements with name is equal to Pager
- An element may contain 1 phone elements with name is equal to Fax

Name: The name attribute specifies the label of the ShoreTel Communicator Directory Viewer column heading. If a name value does correspond to a standard column heading label, ShoreTel Communicator creates a new heading.

Value: The value attribute specifies the phone number that appears in the Directory Viewer data field. If a name value does correspond to a standard column heading label, ShoreTel Communicator creates a new heading.

Example 1: <phone type="Business" name="Business 2" value="+1 (398) 244-2489"/>
Example 2: <phone type="Pager" name="Pager" value="+1 (398) 298-231"/>

If multiple Phone Type elements have the same name attribute, ShoreTel Communicator uses the first string and ignores all duplicate entries.

- email: This element specifies the contact's email addresses. An contact element may contain a maximum of three email elements, subject to the following:

  — valid attributes: name, value

Name: The name attribute specifies the label of the ShoreTel Communicator Directory Viewer column heading. If a name value does correspond to a standard column heading label, ShoreTel Communicator creates a new heading.

Value: The value attribute specifies the email address that appears in the Directory Viewer data field. If a name value does correspond to a standard column heading label, ShoreTel Communicator creates a new heading.

Example 1: <email name="email 2" value="apierce@anycorp.net"/>
Example 2: <email name="email" value="adam.pierce521@yahoo.net"/>

- IM: This element specifies the contact's email addresses. An contact element may contain only one IM element.

  — valid attributes: name, value

Name: The name attribute specifies the label of the ShoreTel Communicator Directory Viewer column heading. If a name value does correspond to a standard column heading label, ShoreTel Communicator creates a new heading.

Value: The value attribute specifies the IM address that appears in the Directory Viewer data field. If a name value does correspond to a standard column heading label, ShoreTel Communicator creates a new heading.
**Example**

The following is an example of an ShoreTel Communicator Contact Integration XML file:

```xml
<?xml version="1.0" encoding="utf-8"?>
<contacts source="Lotus" version="1.0">
  <contact>
    <name first="Sarah" middle="" last="Clauser"/>
    <company value="Anycorp, Inc."/>
    <department value="Finance"/>
    <contactID>1234</contactID>
    <phone type="Business" name="Business" value="+1 (398) 122-2558"/>
    <email name="Email" value="Sclauser1021@anycorp.org"/>
    <email name="Email Address 2" value="sclauser@yahoo.com"/>
    <IM name="IM" value="sclauser1021@aol.com"/>
  </contact>
  <contact>
    <name first="Tammy" middle="" last="Masoon"/>
    <company value="Anycorp, Inc."/>
    <department value="Sales"/>
    <contactID>2234</contactID>
    <phone type="Home" name="Home" value="+1 (398) 962-2552"/>
    <phone type="Pager" name="Pager" value="+1 (398) 529-8670"/>
  </contact>
  <contact>
    <name first="Greg" middle="" last="Thilmonda"/>
    <company value="ShoreTel, Inc."/>
    <department value="Sales"/>
    <contactID>3234</contactID>
    <email name="Email" value="gthilmonda@anycorp.com"/>
  </contact>
  <contact>
    <name first="Patrick" last="Farrington"/>
    <contactID>4234</contactID>
    <phone type="Business" name="Business" value="+1 (398) 331-3642"/>
    <phone type="Mobile" name="Mobile" value="+1 (398) 666-5113"/>
    <phone type="Fax" name="Fax" value="+1 (398) 331-3642"/>
    <email name="Email" value="PFarrington@anycorp.com"/>
    <IM name="IM" value="PFarrington@aol.com"/>
  </contact>
</contacts>
```

### 8.5 Speed Dial

Speed Dial is a ShoreWare feature that dials a selected contact by pressing a single button on your ShorePhone. The Speed Dial viewer displays the your speed dial contacts and the number that initiates calls to those contacts. You can also initiate calls from the Speed Dial viewer.

#### 8.5.1 Speed Dial Viewer

The Speed Dial viewer manages contacts that are associated with a speed dial digit. In addition to initiating voice calls, you can add, remove, and edit speed dial contacts from this panel.

Figure 8-14 displays the Speed Dial viewer in a Satellite window. You can also view the Speed Dial viewer in the Content Area of the Main Window.
To open the Speed Dial Viewer, perform one of the following:

- Click the Application Button and select **Windows -> Speed Dial**
- Select **Windows -> Speed Dial** from the Main Menu
- Select **Windows -> Speed Dial** from the Assignment bar
- Right click the ShoreTel icon in the system tray and select **Windows -> Speed Dial**
- Press Ctrl+Shift+P

The Speed Dial viewer opens in the Main window content area or in a Satellite window.

The Speed Dial viewer consists of a Contact Table that lists your speed dial contacts. The first ten contacts are associated with a numeric key. To initiate a call to the contact,

- Pressing the specified ShorePhone key.
- Double click the entry on the Speed Dial viewer
- Right click an entry and select Dial.

### 8.5.2 Managing Speed Dial Entries

The menu bar provides buttons for adding and deleting Speed Dial entries. You can also edit labels of your Speed Dial entries.

To add a Speed Dial Number:

**Step 1**  Right click the entry and select **Add Entry**.
ShoreTel Communicator responds by displaying the **Add Speed Label** panel.

**Step 2**  Enter the name, IM, email address, or phone number of the desired contact in the Number data entry field.
As you fill the data entry field, a drop down menu displays the list of directory entries filtered by the text in the field.

**Step 3**  Select the desired contact in the drop down list.

**Step 4**  Enter an identifier for the contact in the Label field.

**Step 5**  Press the OK button to save the contact into the Speed Dial list and assign the next available Speed Dial digit to the contact.
To edit a Speed Dial label:

Step 1  Right click the entry and select *Edit Label*.
ShoreTel Communicator responds by displaying the *Edit Speed Label* panel.

Step 2  Enter the new Label contents into the data entry field.

Step 3  Press the OK button to save the label changes.

To delete a Speed Dial entry, right click the entry and select Delete.

To rearrange Speed Dial contacts:

Step 1  Click and hold the entry to be moved in the *Speed Dial* list.

Step 2  Drag the entry to the desired position within the list.

Step 3  Release the mouse button.
CHAPTER 9

Managing Voice Mail

9.1 Introduction

ShoreTel Communicator provides access to voice messages received by your user and workgroup extensions. Voice message actions that you can perform through ShoreTel Communicator includes:

- View a list of your messages
- Listen to your messages
- Compose and send new messages
- Reply to a message
- Specify the device for listening and composing messages
- Manage your voice message files
- Export messages for use by other applications
- Call back the message sender
- Forward a message
- Delete a message during downloading
- Create personal distribution lists
- Save and delete messages
- Export messages

ShoreWare provides two methods for handling voice mail.

- Voice Mail Viewer is a ShoreTel Communicator component that is accessed from the Main Window.
- Outlook integration provides an alternative method for managing voice messages from Outlook.

This chapter describes the ShoreTel Communicator Voice Mail Viewer and references this viewer for all process and component descriptions. Refer to Section 14.3 on page 170 for information on using Microsoft Outlook for managing voice mail.

9.2 Mailboxes and Messages

ShoreWare stores voice messages in mailboxes that are accessible to system users. This section describes the properties of ShoreWare Mailboxes and Voice Messages

9.2.1 Mailboxes

ShoreWare defines one mailbox for each user extension and each workgroup extension. User extension mailboxes are accessible only to the user assigned to the extension. Workgroup mailboxes are available through Workgroup Agent, Workgroup Supervisor, and Operator ShoreTel Communicator to all users assigned to the workgroup.
Each mailbox contains three folders: an **Inbox** folder, a **Saved** folder, and a **Deleted** folder. When you access Voice Mail through Outlook, the Saved folder is named Archive Folders.

**Inbox Folder:** The Inbox folder receives an extension’s inbound voice messages. Messages remain in this folder until moved to the Saved or Delete folder.

**Saved Folder:** The Saved folder is a repository for messages that were previously received but are not yet ready for deletion. Placing messages in the Saved folder.

**Deleted Folder:** Messages moved to the Deleted folder remain there until 2:00 a.m (server) time, when ShoreWare removes messages that are at least 6 hours old. Voice mail messages less than six hours old remain in the Deleted folder until 2:00 a.m. the next day. Messages moved to the Deleted Folder and then subsequently deleted are removed from the system and cannot be recovered.

You can restore messages in the Deleted Folder by moving them to the Inbox or Saved folders, after which they are safe from daily maintenance deletion.

### 9.2.2 Voice Messages

This section describes the properties and content of ShoreWare voice messages.

#### 9.2.2.1 Properties

ShoreWare defines two properties that categorize voice messages. Message status indicates if a message has been heard. The Urgency Mark assigns an importance signal to a message.

**Message Status:** ShoreWare defines two message status levels – heard and unheard. The message status is adjusted as follows:

- The system changes the status of a message to **Heard** when you listen to the message.
- You can manually change the message status by right clicking the message and selecting **Mark as Heard** or **Mark as Unheard**.
- A voice mail icon is displayed to notify the user if any unheard workgroup voice mails exist. The notification area icon tool-tip display the number of voice mails, as shown in the figure below.

![Voice Mail Icon - Unheard Messages](image)

**Figure 9-1  Voice Mail Icon - Unheard Messages**

ShoreWare uses Message status to select messages for deletion through the auto-deletion operation, as described in Section 9.2.2.3.

**Urgency Mark:** The Urgency Mark is assigned to a message by the sender and indicates high importance or time relevance of the message. The Urgency Mark setting is not editable.
9.2.2.2 Content
Message content consists of the message recording as composed by the sender. The content is not editable. You can export the message content to a wav file, as described in Section 9.3.2.4.

Message timestamps displayed by ShoreTel Communicator are based on the computer’s time zone setting.

9.2.2.3 Message Deletion
Messages are removed from the system either through user selection or through auto-deletion operations defined by the system administrator.

User deletion: Users specify messages to be deleted by moving them to the Deleted folder. The system then deletes messages that are older than six hours during the Voice Mail Maintenance operations performed by ShoreWare at 2:00 am each day.

Auto deletion: ShoreWare provides voice message auto-deletion for administrators to conserve system storage resources. Messages are stored for a period specified by an administrator, then permanently removed from the system. Users receive a message informing them of the imminent auto deletion of their message. The range of valid retention periods is between 30 and 2000 days.

ShoreWare defines retention periods for two classes of messages:

— Class 1: Messages in the Saved folder OR Messages marked as Unheard.
— Class 2: Messages in the Inbox folder AND Messages marked as Heard.

Retention periods for the message classes are defined independently of each other. Administrators can also disable auto deletion. Refer to your administrator for more information and to determine the retention period for your messages.

9.3 Voice Mail Viewer
The Voice Mail viewer is a graphical user interface for accessing your voice messages. You use Voice Mail viewer tools to manage message files, listen and respond to messages, compose new outbound messages, and broadcast messages to groups through Distribution Lists.

To open the Voice Mail viewer, perform one of the following:

Click the Application Button and select Windows -> Voice Mail
Select Windows -> Voice Mail from the Main Menu
ShoreTel icon in the System tray and select Windows -> Voice Mail
Press Ctrl+Shift+V

The Voice Mail viewer opens in the Main window content area or in a Satellite window.

9.3.1 Viewer Components
The Voice Mail viewer displays the messages in your mail box, as shown in Figure 9-2. Each row corresponds to one message. Each column lists one message property.
ShoreTel Communicator for Windows

Chapter 9: Managing Voice Mail

Voice Main Viewer components include:

**Action bar:** The action bar contains buttons that trigger message actions, initiate viewer functions, or display message properties. Action bar buttons include:

- **New Message:** Press this button to record and send a voice message.
- **Reply:** Press this button to record and send a response to the highlighted message.
- **Forward:** Press this button to send the highlighted message to other recipients.
- **Contact Sender:** Select this button to initiate a call, IM, or email to the sender of the highlighted message.
- **Delete:** Press this button to move the highlighted message to the Deleted folder.
- **Save:** Press this button to move the highlighted message to the Saved folder.

**Filter bar:** The Voice Mail viewer displays only entries whose sender name or number is filtered by the contents of this data entry field.

**Column Headings:** Column headings indicate the data field name for the address entries. Available column headings include:

- **Urgent Mark:** This column is denoted by an exclamation point (!) and indicates the message's urgency status. You cannot remove this column from the table.
- **Message:** This column is denoted by a cassette icon and indicates the message type. You cannot remove this column from the table.
- **From:** This column lists the sender of the message.
- **Subject:** This column lists the message subject. The subject is initially specified by the sender and can be edited from the context menu.
- **Received:** This column lists the day and time that you received the message.
- **Duration:** This column lists the length of the message, in seconds.
- **GUID:** This column lists the internal message identifier.

ShoreTel Communicator timestamps are based on the timezone setting of the user's computer.

**Voice Mail Subject Title:** You can edit the subject of any voice mail message in displayed in the Voice Mail Viewer.
Viewer operations that manipulate Voice Mail viewer heading bar contents include:

— *To add a column to the table*, right click in the Message Contents region and select **Choose Columns**. Then drag the column to be added to the desired location in the Column Heading.
— *To sort the contents*, click in the heading of the desired sort column. Clicking repetitively in the field reverses the order of the sort.
— *To move a column to a different heading location*, click and hold on the column to be moved, then drag the column to the desired location.
— *To remove a column from the table*, click and hold on the column to be removed then drag the column from the table until a large X appears on the column.

**Mailbox Contents**: The table below the column headings displays your voice messages.

The Voice Mail viewer displays components in a hierarchical file structure

— The first hierarchical layer specifies the **mailboxes**, which are identified by the extension receiving the messages.
— The second hierarchical layer specifies the **mailbox folders**, including the Inbox, Saved, and Deleted folders.
— The third hierarchical layer lists the **messages** that each mailbox folder contains.

**Playback bar**: The playback bar is located at the bottom of the Voice Mail viewer and controls the audio playback of the highlighted message. Playback bar buttons, listed from left to right, include:

— **Playback device**: This icon controls the device through which you listen to messages. You can select your PC speaker or assigned phone through this button.

  When playing a voice mail using the speakers, a download indicator is displayed to inform the user that the message is being downloaded for playback. This indication will not be displayed when using the phone for voice mail play-back. During the message download, the voice mail icon will be replaced with an animated icon. When the user hovers over the animated download icon a tooltip will be displayed - "Downloading message..." The complete file must be downloaded locally before playback.
— **Play/Pause button**: Press this button to control the playback of the highlighted message.

  When this button displays a green arrow icon, pressing the button initiates or continues audio playback of the message.

  When this button displays a pause symbol (two parallel bars), pressing the button pauses the audio playback. Pressing this button again resumes the playback from the point it was paused.
— **Stop button**: Press this button to discontinue playback of the highlighted message and reset the playback cursor to the start of the message.
— **Cursor**: This indicator specifies the current message point. During message playback, this point indicates the part of the message that is being played. During message pause or stop, this point indicates the part of the message that ShoreTel Communicator plays when you press the play button. Click, hold, and move the cursor to adjust the current message point.
— **Duration**: The time indicators indicate the current message point, relative to the beginning of the message, and the length of the message.
9.3.2 Managing Viewer Contents

The following sections describe the file manipulation operations that control the contents of the Voice Mail Viewer.

9.3.2.1 Saving a Voice Message

Saving a Voice Mail Messages moves a message from the Inbox or Deleted folder to the Saved folder.

To save the highlighted message, perform one of the following:
- Press the Save button in the Action bar.
- Right click the message and select Move to Saved folder.

The message is moved to the Saved folder.

9.3.2.2 Deleting a Voice Message

Messages moved to the Deleted folder remain there until 2:00 a.m (server) time, when ShoreWare removes messages that are at least 6 hours old. Voice mail messages less than six hours old remain in the Deleted folder until 2:00 a.m. the next day.

To move the highlighted message to the deleted folder, perform one of the following:
- Press the Delete button in the Action bar.
- Right click the message and select Move to Deleted Icons folder.

The message is moved to the Deleted folder.

NOTE: You can also delete a voice message while the message is being downloaded.

9.3.2.3 Recovering a Voice Mail Message

You can recover messages in the Deleted folder until ShoreWare removes them from the server during the 2:00 am voice mail maintenance cycle. To recover a message in the Deleted folder, move it to the Inbox or Saved folders.

To recover the highlighted message from the Deleted folder, perform one of the following:
- Press the Save button in the Action bar.
- Right click the message and select Move to Inbox folder or Move to Saved folder.

The message is moved to the selected folder.

Download Indicator

When playing a voice mail a download indicator is displayed, to inform the user that the message is being downloaded for playback. When the message is downloading, a download tooltip is displayed.
9.3.2.4 Exporting a Voice Mail Message

You can export a voice mail message to a .wav file for use by other applications.

To export the highlighted message to a wav file:

Step 1  Right click the message and select Export to .wav File.
ShoreTel Communicator opens a Save As windows folder.

Step 2  Select the desired file location for the .wav file and, if desired, modify the name listed in the file name field.

Step 3  Click the Save button.

9.4 Managing Voice Messages

9.4.1 Listening to a Message

You can listen to your messages using either your computer's speakers or your telephone. When listening to messages through your speakers, playback begins when you press the Play button. When listening to messages through your telephone, pressing the Play button triggers your phone to ring; message playback begins after you lift the receiver.

To listen to the highlighted message, perform one of the following:

   Double click the message.
   Click the play button in the Playback bar at the bottom of the Voice Mail viewer.
9.4.2 Replying to a Voice Message

You can reply to voice messages sent by other ShoreWare users through the Voice Mail viewer. You can only send Voice Messages to other users on your ShoreWare system.

To reply to the highlighted voice message:

Step 1  Perform one of the following:

- Click the Reply button on the Action bar.
- Right click the message and select Reply or Reply to All on the context menu.

ShoreTel Communicator opens the Voice Message Recorder panel, as shown in Figure 9-4.

Step 2  Click the To button to select the Message Recipients.

ShoreTel Communicator opens the Add/Remove Members panel for selecting recipients.

Step 3  Enter the Message subject in the Subject data entry field.

Step 4  Press the Device button in the bottom left corner to specify the recording device.

Step 5  Press the Record button, then speak into the recording device. Press the Stop button to end the recording.

Step 6  Click the Send button to send the message to the Recipients.

9.4.3 Forwarding a Voice Message

Forwarding a Voice Message sends that message to another system user. You can only forward messages to other users on your ShoreWare system.

To forward the highlighted voice message:

Step 1  Perform one of the following:

- Click the Forward button on the Action bar.
- Right click the message and select Forward on the context menu.

ShoreTel Communicator opens the Voice Message Recorder panel, as shown in Figure 9-4.
Step 2  Click the To button to select the Message Recipients.

ShoreTel Communicator opens the Add/Remove Members panel, as shown in Figure 9-5.

Step 3  Select the recipients of the message on the left table by highlighting the desired contacts, then pressing the Add button between the tables.

Step 4  Press the OK button after selecting all desired recipients.

The Add/Remove Members panel closes and control returns to the Voice Message Recorder panel. You can add an introductory statement before sending the message.

Step 5  Click the Send button on the Voice Message Recorder panel to send the message to the Recipients.

9.4.4 Calling the Sender

If Caller ID is available for a voice mail message, you can call the sender.

To call the sender of the highlighted message, perform one of the following:

Press the Contact Sender button on the Action bar.
Right click on the contact and select the desired contact method at the top of the context menu.
9.4.5 Editing the Subject Header

You can edit the subject header of your voice messages through each of the following actions.

- Right click on the message subject header.
- Edit message subject header in place.

To edit the subject header of the highlighted message using the Edit Subject option:

**Step 1** Right click the message and select *Edit Subject* from the context menu.

**Step 2** Enter the desired text in the Edit Subject panel.

**Step 3** Click OK.

To edit the subject header of the highlighted message In-place:

**Step 1** Click the cell of the voice mail subject. The cell is now editable.

**Step 2** Enter the desired text of the voice mail subject.

**Step 3** Click OK.

9.4.6 Recording and Sending a New Voice Message

You can record voice messages using your telephone or a microphone. You can only send voice messages to other users on your ShoreWare system.

To record and send a new voice message:

**Step 1** Click the *New Message* button on the Action bar.

ShoreTel Communicator opens the Voice Message Recorder panel.

**Step 2** Click the *To* button to select the Message Recipients.

ShoreTel Communicator opens the Add/Remove Members panel

**Step 3** Type the subject in the *Subject* box.

**Step 4** Press the *Device* button in the bottom left corner to specify the recording device.

**Step 5** Press the *Record* button, then speak into the recording device. Press the *Stop* button to end the recording.

**Step 6** Click the *Send* button to send the messages to the Recipients.
9.4.7 Viewing Voice Message Information

The voice mail properties dialog box displays properties of a voice message, including the sender, subject, folder location, date of receipt, duration, urgency status, and forwarding history.

To view information about a voice message, perform one of the following:

- Right click the message and select More Info
- Select a message and select More Info on the Action bar

9.5 Voice Mail Notification

9.5.1 Introduction

Voice Mail Notification is a ShoreWare feature that sends email or initiates voice calls to designated contact points when you receive a voice message. The purpose of Voice Mail Notification is to inform you of inbound voice messages when ShoreTel Communicator or other ShoreWare utilities are not immediately accessible.

ShoreTel Communicator provides two Notification levels:

- **Personal Notification**: Personal Notification sends a single email message to a specified address.
- **Notification Escalation**: Notification Escalation initiates a series of contact attempts to various email addresses or phone numbers. Notification Escalation is typically enabled during periods when you may receive messages that require an immediate response.

Voice Mail Notification is configured on the Voice Mail and Escalation panels of the Options and Preferences window.

9.5.2 Personal Notification

When Personal Notification is enabled, ShoreTel Communicator sends a message to a specified email address when your user account receives a voice message. You can program ShoreTel Communicator to send only the notification message or to attach the inbound voice message to the notification message.

To setup personal notification for your extension:

**Step 1** Open the Options and Preferences window by performing one of the following:

- Select **Tools -> Options** from the Main menu.
- Click the Application Button and select **Options**.
- Right click the ShoreTel Communicator icon in the System Tray and select **Options**.
- Press Ctrl+O.

**Step 2** Select **Voice Mail** from the menu on the left side of the panel.
Step 3  Enable Notification and specify the content of notification messages from the Escalation Delivery Options drop down menu.

Select Disabled to prevent ShoreTel Communicator from sending you notification messages.
Select one of the other options to enable personal notification.
   — Select Email Wave Mail to attach the voice message to your notification messages.
   — Select Email Notification to send notification messages without attaching the voice message.

Step 4  Specify the messages that trigger a personal notification from the Escalation Notification Options radio buttons:

Select Escalate for each New Message to send a notification message immediately when you receive a voice message.
Select Escalate for First Unheard Message to delay the notification message for an inbound voice message until after all of your previously received voice messages are marked Heard.

Step 5  Specify the email address to where ShoreTel Communicator sends your messages in the Deliver to Email Address data entry field.

The Mark delivered voice mail as Heard option disables Notification Escalation, as described in Section 9.5.3.

9.5.3 Notification Escalation

Notification Escalation initiates a series of contact attempts to various email addresses or phone numbers when you do not respond to an inbound voice message. Notification Escalation is typically enabled when you may receive messages requiring an immediate response.

The following sections describe the ShoreTel Communicator Escalation process and the tasks required to configure and enable Escalation.

9.5.3.1 Escalation Components

The Escalation process defines the following software components:

Step: A step consists of at least one contact address and a timeout. Contact addresses can be phone numbers or email addresses. When the step is active, ShoreWare delivers a notification message to each listed contact address. The timeout specifies the period ShoreTel Communicator waits before the next contact attempt. Section A.2.8.1 on page 184 describes the Escalation Profile panel that defines all step for an escalation profile.

Profile: A profile consists of a list of steps that define a notification program and a counter that specifies the maximum number of notification attempts. Each profile may have a maximum of ten steps. A user may define a up to nine profiles to specify multiple custom notification procedures for handling various situations. Section A.2.8 on page 183 describes the Options and Preferences: Escalation panel that lists all profiles defined for your extension.
9.5.3.2 Escalation Structure

Escalation components interact with other ShoreTel Communicator components as follows:

**Invoking Profiles:** Each Call Handling Mode provides a Voice Mail Escalation Profile option that specifies one of your configured Notification profiles. When that Call Handling Mode is active and Escalation is triggered, the profile specified by this option defines the notification process until ShoreTel Communicator receives a response. Section A.2.4 on page 178 describes the Call Handling Mode Configuration panels that reference escalation profiles.

**Activating Escalation:** Escalation is activated by disabling *Mark delivered voice mail as Heard* on Options and Preferences: Voice Mail panel. Section A.2.7 on page 182 describes the Options and Preferences: Voice Mail panel.

9.5.3.3 Escalation Process

The Escalation process consists of a trigger condition, a Notification Cycle, and a Terminating Condition.

**Trigger Condition:** The trigger conditions specify the event required to initiate an Escalation process. The following are the conditions required to initiate an escalation:

1. The active Call Handling Mode specifies a valid Escalation profile.
2. The Deliver Voice Mail as Heard on the Options and Preferences: Voice Mail panel is not selected.
3. The user receives a call that generates a voice mail message.

**Notification Cycle:** After detecting the Trigger Condition, ShoreWare performs the following steps until the Terminating Condition is satisfied:

1. ShoreTel Communicator sends a voice mail or a phone call to the address listed in the first configured step in the profile.
2. ShoreTel Communicator waits for the period specified by the Timeout field.
3. ShoreTel Communicator repeats 1 and 2 for each configured step in the profile. Executing 1 and 2 for all configured steps is defined as a notification cycle.

**Terminating Condition:** ShoreTel Communicator continues the Notification cycle until one of the terminating conditions is satisfied:

The message that triggered the escalation is marked as *Heard*.

ShoreTel Communicator has performed the Notification Cycle the maximum number of times. The maximum is defined as *Repeat Count + 1*, where *Repeat Count* is specified in the Escalation Profile panel that configures the Escalation profile.
9.5.3.4 Configuring Escalation

The following steps are required to configure and enable Escalation Notification:

Step 1 Define Escalation profiles.

The Escalation panel lists the Escalation Profiles configured for your extension. Section A.2.8 describes the Escalation panel.

Step 2 Assign Escalation profiles to Call Handling Modes.

Call Handling Modes are configured by opening the desired mode in the Options and Preferences panel. The Voice mail escalation profile drop down menu assigns a profile to the Call Handling Mode.

If you set Escalation Profile to None for a call handling mode, Escalation is disabled for that mode.

Step 3 Enable Escalation from the Options and Preferences: Voice Mail panel by clearing the Mark delivered voice mail as Heard parameter. Section A.2.7 on page 182 describes the Options and Preferences: Voice Mail panel.

9.6 Distribution Lists

ShoreWare defines Distribution lists for sending voice messages to a group of system users. The following sections describe ShoreWare distribution lists that you can access through ShoreTel Communicator.

9.6.1 Distribution List Types

ShoreWare defines three types of distribution lists:

Broadcast List: ShoreWare defines one Broadcast List, which includes all systems defined on the system. ShoreWare assigns an extension number to the Broadcast List.

You must have authorization, as configured by the System Administrator, to send messages through the Broadcast Distribution List. Only the system administrator can create, edit, or delete the Broadcast List.

System Lists: System Lists are defined for the entire ShoreWare system. The system administrator creates and modifies system lists, which are then accessed by users through an extension number assigned to the list.

You must have authorization, as configured by the System Administrator, to send messages through System Distribution Lists. You cannot create, edit, or delete System Distribution Lists through ShoreTel Communicator.

User Lists: User Lists are created by individual ShoreWare users for use by that user. User Lists can be modified and accessed only by the creator of the list. Index numbers, instead of extensions, are associated with each list.
9.6.2 Distribution Lists panel

The Distribution Lists panel, as shown in Figure 9-6, displays the accessible distribution lists and provides tools for managing your lists. To access the Distribution Lists panel, perform one of the following:

- Click the Lists button on the Action bar.
- Right click in the contents area and select Distribution Lists on the context menu.

![Distribution Lists panel](Figure 9-6 Distribution Lists panel)

Distribution Lists panel components include:

- **List roster:** The List Roster is located on the left side of the panel and displays all available distribution lists.
  - User Lists are denoted with a leading # sign in the number field. In Figure 9-6, List_1 is a user list.
  - The Broadcast List is denoted by the name Broadcast.
  - System Lists are associated with an extension in the number field.
- **New button:** Pressing the New button opens the Distribution List Details panel. You create new lists and modify existing lists from this panel.
- **Edit/View button:** Pressing the Edit/View button opens the Distribution List Details panel for the highlighted list. The available components depend on the List for which the panel was opened.
  - The panel opens a viewing panel for System and Broadcast list, as shown in Figure 9-7.
  - The panel opens an edit panel for user lists. Section 9.6.3 describes the use of this panel for modifying and creating Distribution Lists.
- **Prompt button:** Pressing the Prompt button opens a recorder bar for the highlighted list in the List roster. The prompt announces the name of the distribution list when other users send a message to list members.
  - The Prompt button is disabled for System lists and the Broadcast list.
Delete button: Pressing the Delete button removes the highlighted list from the List roster. The Delete button is disabled for System lists and the Broadcast list.

9.6.3 Managing User Distribution Lists

9.6.3.1 Creating Distribution Lists

The title assigned to a distribution list becomes the contact name for that list. You type or select that name when sending a voice message to the list members using the ShoreTel Voice Mail Viewer or Microsoft Outlook. The assigned number becomes the telephone number used when using the distribution list to deliver voice messages.

To create a distribution list:

Step 1  Open the Distribution Lists panel by performing one of the following:

- Click the Lists button on the Action bar.
- Right click in the contents area and select Distribution Lists.

Step 2  Click the New button.

ShoreTel Communicator displays the Distribution Lists Details panel, in edit mode, as shown in Figure 9-8.

Step 3  Type the title of the new distribution list in the List Name field.

Step 4  Select an identification number through the Number box drop down list.

Step 5  Select a contact in the left list and press the Add button to include the member in the user list. Repeat until all desired members are included in the list.

Step 6  Click the OK button to save the list and return to the Distribution Lists panel.
9.6.3.2 Recording a Distribution List Prompt

The Distribution List prompt announces the name of the distribution list when other users send a message to the list members.

To record a prompt for a distribution list:

Step 1  Open the Distribution Lists panel by performing one of the following:

Click the Lists button on the Action bar.
Right click in the contents area and select Distribution Lists.

Step 2  Select a List on the panel.

Step 3  Click the Prompt button.

ShoreTel Communicator displays the Prompt Recorder. The controls on the Prompt Recorder are similar to those on the Playback bar located on the bottom of the Voice Mail Viewer, as described in Section 9.3.1 on page 113.

The Prompt button is unavailable for the Broadcast List and all System Lists.

Step 4  Press the Device button on the left side to select the recording device.

Step 5  Press the Record button, then speak into the recording device. Press the Stop button to end the recording.

Step 6  Press the OK button to save the prompt and return to the Distribution Lists panel.
9.6.3.3 Editing Distribution Lists

You can change the members on existing user lists.

To add or remove names from a distribution list:

Step 1  Open the Distribution Lists panel by performing one of the following:
       Click the Lists button on the Action bar.
       Right click in the contents area and select Distribution Lists.

Step 2  Select a distribution list from the List roster on the left side of the panel.

Step 3  Click the Edit/View button.
        If the highlighted item is a User List, ShoreTel Communicator displays the
        Distribution Lists Details panel, in edit mode, as shown in Figure 9-8. If the
        highlighted item is the Directory List or a system list, ShoreTel Communicator
        displays the Distribution Lists Details panel in view mode, as shown in Figure
        9-7.

Step 4  Edit the list by adding or removing users.
        To add users, type a name or select a name from the available list, and click
        the Add button
        To remove users, select a name from the Distribution Lists Members area,
        and click the Remove button.

Step 5  Repeat this process until the list contains the desired users and contacts.

Step 6  Click the OK button to save the list and return to the Distribution Lists panel.

9.6.3.4 Deleting Distribution Lists

You can only delete User Distribution Lists. You cannot delete System distribution lists or
the Broadcast list.

To delete a distribution list

Step 1  Open the Distribution List panel by performing one of the following:
       Click the Lists button on the Action bar.
       Right click in the contents area and select Distribution Lists.

Step 2  Select the list to be removed from the roster on the left side of the panel.

Step 3  Click the Delete button.
        The Delete button is not available if the selected list is a System list or the
        Broadcast list.

Step 4  Click the Close button to close the Distribution Lists panel.
9.6.4 Using a Distribution List

Distribution lists are available as contacts when selecting the recipients of a voice message from the Add/Remove Members panel. In Figure 9-9, the icon to the left of the Broadcast and Executive entities indicate that they are distribution lists.

To select a distribution list, perform one of the following:

- Enter the extension of a System List or the Broadcast list in the data entry field in the top left corner of the panel
- Enter the name of the Distribution List in the data entry field in the top left corner of the panel
- Scroll in the table on the left side of the panel and click on the name of the desired Distribution list.

After selecting a list, pressing the Add button in the center of the panel adds the list to the roster of message recipients.

Section 9.4.6 on page 120 describes the methods of sending voice messages.

9.7 Configuring Voice Mail

9.7.1 Options and Preferences

The Options and Preference: Voice Mail panel specifies the default interface for listening and recording voice messages, records your spoken name that the system plays to callers routed to your mailbox, and configures your voice mail password. Section A.2.7 on page 182 describes the Options and Preferences: Voice Mail panel.
9.7.2 Using System IDs to Address AMIS Voice Mail

Your system administrator can configure your voice mail system to send messages to remote systems either using the same extension numbers you use to dial the remote users, or by assigning a unique system identification to each system in the network. Your administrator should provide information on the way your voice mail system is configured.

To send voice mail using system IDs to recipients on AMIS systems, enter the system ID followed by the mailbox number (extension) of the recipient on the AMIS system.

Example: If the system ID is 8331 and the mailbox number is 1234, enter 83311234 to address the voice mail. Your System Administrator can tell you the system IDs you need to address AMIS voice mail for each remote site.

If your system administrator configured your voice mail system to use the extension numbers of remote users, voice mail messages are referenced by their remote extension number.

If ShoreTel cannot deliver a voice message after three attempts, it stops trying and returns the message to you. If your voice mailbox is full, you will not receive notification about the messages that were not delivered.
10.1 Introduction

Shared Call Appearance is a ShoreTel client feature that establishes common Bridged Call Appearance between a user (executive) and at least one other user (assistant). A Shared Call Appearance is typically established to allow one or more assistants to manage inbound calls and initiate outbound calls for an executive.

Shared Call Appearances are supported on all ShoreGear switches and all ShorePhones that have programmable buttons.

10.1.1 Shared Call Appearance Components

10.1.1.1 Executive Extension

The executive extension is a ShoreTel extension that is configured for Shared Call Appearance. All call appearances of the executive extension are converted into associated Bridged Call Appearances (aBCA); calls to the executive extension are routed to the extension of the corresponding aBCA.

When a executive extension is routed to a phone that does not have programmable buttons, the executive extension is handled as a normal extension. The extension behavior reverts back to that of an Executive Extension when extension calls are routed to a phone with programmable buttons.

To convert an extension to a executive extension

Step 1  Open the Edit User panel of the desired user by selecting Administration -> Users -> Individual Users from the Director Main Menu, then click the name of the desired user.

Step 2  Select Shared Call Appearances, as shown in Figure 10-1.

Director autofills the Associated BCA field. This field specifies the extension of the aBCA associated with the executive extension.
Step 3 Enter the desired number for the aBCA in the Associated BCA field.
This step can be skipped if the autofill entry is acceptable. This field cannot be edited after the initial configuration.

Step 4 Press the Save button at the top of the Edit User panel.

When a new call is placed from executive's PCM the existing active calls will be locally held and not parked back on aBCA. However if the new call is placed from the phone, then the existing active call will be parked back on aBCA.

Clearing the Shared Call Appearances checkbox reverts the executive extension to a normal extension and deletes the aBCAs associated with the extension.

10.1.1.2 Associated Bridge Call Appearance
An Associated Bridged Call Appearance (aBCA) is a bridged call appearance that is associated to a Executive Extension. Associated Bridged Call Appearances differ from other BCAs as follows:

- aBCAs are not editable from the Bridged Call Appearance Director panel. aBCA settings and parameters are configured from the user's Edit User panel.
- aBCAs are created when a ShoreTel extension is converted to a executive extension.
To create a executive extension, open the Edit User panel for the desired user and select the Share Call Appearances option. The number listed in the Associated BCA field specifies the extension of the aBCA.

aBCAs are deleted if the associated executive extension is reverted to a normal extension.

To revert a executive extension to a normal extension, clear the Shared Call Appearance option on the Edit User panel.

Placing a executive extension call on hold parks the call on the aBCA. Held calls on a executive extension can be viewed from the PCM Bridged Call Appearance Monitor or from IP Phone display.

NOTE: If there are any secretaries that are monitoring Executive' aBCA the dependencies shall be removed before you can clear Share Call Appearances check box.

Associated BCA settings are viewed from a Bridged Call Appearance edit panel, as shown in Figure 10-2. This panel is read only for aBCA. Parameters can be modified from the edit panel of the associated user. The No Answer Number of Rings and Call Forward Destination parameters reflect the initial state of these values and, depending on the activity of the user, may not indicate the current state of these parameters.

aBCA is only hidden in the phone directory list so that users don't accidently call aBCA instead of executive. However, like any normal BCA, administrators can configure aBCA as the destination of a trunk group or target extension of a programmable button function. Its up to administrator's discretion how to use aBCA.

![Figure 10-2 Edit Panel – Executive Bridged Call Appearances](image_url)
The following procedure opens the aBCA edit panel:

**Step 1** In Director, open the Bridged Call Appearance List panel of the desired user.

**Step a:** Select *Administration -> Call Control -> Bridged Call Appearances* from the Director Main Menu.

**Step b:** Click the aBCA associated with the desired user. aBCA names have the form `<first name>_last name_extension>`, where
- *first name* is the first name of the user
- *last name* is the last name of the user
- *extension* is the user's extension number

**Step 2** Open the edit panel for the aBCA, as shown in Figure 10-2, by clicking the name of the desired aBCA on the Bridged Call Appearance List panel.

When the Edit panel of an aBCA opens, Director displays a warning that the BCA is a Shared Bridged Call Appearance and cannot be modified.

### 10.1.1.3 Assistant Users

Assistant users require no additional configuration, other than the assignment of ShoreTel Communicator or IP Phone programmable buttons to monitor the Executive Extension aBCAs.

### 10.1.1.4 Hotline

A hotline is a bi-directional ringdown circuit accessed through IP Phone or ShoreTel Communicator buttons. A hotline call is initiated by pressing the assigned button. Hotline calls can be configured as speed dial or intercom calls.

A Hotline circuit can be implemented between an executive and assistant to communicate call status on the executive's aBCA. To land a call on hotline button as intercom or speed dial, it's required that both the parties have a hotline program button. If not the call will be offered as normal call.

Hotline calls and Extension Monitor calls to an Executive extension that are picked up are not bridged. Refer to the Hotline section for configuration information.

NOTE: Hotline intercom calls will use a user's intercom permissions. Hence same rules that apply to regular intercom calls apply to hotline-intercom calls.

### 10.1.1.5 Programmable Buttons

Executives and Assistant users access aBCAs and the hotline circuit from ShoreTel Communicator or ShorePhones through programmable buttons configured for Bridged Call Appearances. Buttons for Executive Extensions are not configurable as Call Appearances.

Refer to the ShoreTel Administrator Guide for information about programmable buttons.

### 10.1.1.6 Bridged Call Appearance Monitor

The Bridged Call Appearance Monitor is a ShoreTel Communicator window that displays all Bridged Call Appearances accessible to the user's extension through all devices assigned to the user. The BCA Monitor consolidates all of a user's aBCA activity into a single panel.

The Bridged Call Appearance Monitor is only available through Operator ShoreTel Communicator.
10.1.2 Using Shared Call Appearance

A typical Shared Call Appearance application includes a Hotline circuit between an executive and an assistant. The hotline circuit is used by the assistant to relay the status of calls requiring the executive's attention.

The following sections describe the set up and performance of Shared Call Appearance and Hotline circuits for this typical scenario.

10.1.2.1 Configuring Shared Call Appearance

Setting up a Shared Call Appearance – Hotline connection between a executive extension (executive) and an assistant user requires the following steps:

Step 1 Convert the executive's extension to a Executive Extension, as described in Section Executive Extension on page 131. This step configures the executive's Call Appearances as aBCAs.

Step 2 Configure the executive's ShorePhone or ShoreTel Communicator to access the hotline circuit. Refer to the Hotline section for configuration details.

Step 3 Configure the Assistant user to access the aBCA associated with the executive extension.

Step 4 Configure the Assistant user's ShorePhone or ShoreTel Communicator to access the hotline circuit. Refer to the Hotline section for configuration details.

10.1.3 Shared Call Appearance Inbound and Outbound Calls

10.1.3.1 Inbound Calls

The following scenario describes a typical process of receiving calls for an executive by an assistant through Shared Call Appearances.

Step 1 The inbound call flashes an aBCA indicator on the assistant's and executive's calling devices – ShorePhone or ShoreTel Communicator. The executive can answer the call at this time and eliminate the assistant's role.

Step 2 The assistant user answers the call that is flashing on the aBCA button and determines the caller's name and purpose.

Step 3 The assistant user places the call on hold.

   NOTE: Executive call timer gets reset if Executive puts call on hold.

Step 4 The assistant user presses the hotline button to call the executive.

Step 5 The assistant user advises the executive of the call in progress and provides instructions on picking up the call.

Step 6 The executive picks up the held call by pressing the aBCA button, as instructed by the assistant.

   NOTE: Internal users calling executive will see aBCA's number called party ID while the call is ringing and actual executive number after the call is connected.
10.1.3.2 Outbound Calls

The following scenario describes a typical process of setting up a call for an executive by an assistant through Shared Call Appearance.

Step 1  The assistant user accesses an aBCA associated with the executive extension by pressing an appropriate IP Phone or ShoreTel Communicator button.

   NOTE: The called party will see the executive's bBCA or the assistant's aBCA's caller ID based on the BCA Caller ID registry setting.

Step 2  The assistant user calls the recipient and prepares the recipient for the executive's call.

Step 3  The assistant user places the call on hold.

Step 4  The assistant user presses the hotline button to call the executive.

Step 5  The assistant user advises the executive of the call in progress and provides instructions on picking up the call.

Step 6  The executive picks up the held call by pressing the aBCA button, as instructed by the assistant.

   NOTE: An executive extension's redial list shows only outbound calls.

10.1.4 Using Blind Conference with Shared Call Appearance

Scenario 1

In this scenario the executive is currently on a call with party one. The assistant receives a call from a second party. The assistant determines that the executive is on a call and wants to have the second party join the Executive's call. Using the assistant blind transfer, the Assistant calls Executive on hotline to tell the Executive that the second party is on the line and ready to join the call. The hotline call ends and the Executive is connected back to Party and the Assistant is connected back to Party two. The Assistant then initiates a conference and selects executive's call into which Party two needs to join. Once the conference connection is completed, Parties one and two will be in the same call.

   NOTE: 6-way conference is currently possible from the Executive phone, but only 3-way conferencing is possible from the Assistant's phone.

Scenario 2

In this scenario executive hotlines the assistant and asks him or her to bring party two into the call and then the executive gets back on the line with party1. Then the assistant calls party two, hotlines the executive to tell him that party two is ready to join and then joins party two by initiating a blind conference and then selecting the executive's line.

   NOTE: The assistant joins the second party into the executive call by initiating a blind conference then specify the number or extension and then select options for for blind or consultative conference. The executive's line LED will be RED as designed.

   NOTE: Assistant cannot join a party into a executive's line if the executive is already on a 3-party call on that line.
11.1 Introduction
Silent Coach is a ShoreTel client feature that allows a user to intervene in another user's active call and communicate with that user. The initiator can speak to the specified user and listen to all other call participants. The specified user is the only call participant that can hear the initiator. A Telephony Class of Service assigns Silent Coach rights. Silent Coach can be initiated through various ShorePhone models or through ShoreTel Communicator.

This feature also provides the capability for the initiator to switch between Silent Monitor, Barge In, and Silent Coach functions for the same call.

The right to perform Silent Coach is set by the system administrator. The system administrator also designates users whose calls can be monitored.

11.1.1 Initiating a Silent Coach Session
Silent Coach sessions can be initiated through ShorePhone or ShoreTel Communicator programmable buttons, ShoreTel Communicator menu options, and star code calls from other calling devices.

11.1.2 Session Transitions
Users initiating a Silent Coach session can change the session to a Silent Monitor or Barge In session. Silent Monitor sessions can be changed into a Silent Coach session.

11.1.3 Coach Consult and Resumption
The user that receives a Silent Coach session can place the original call on hold to engage in a two-way conversation with the Silent Coach initiator. At the end of this conversation, the user can resume or terminate the original call.

NOTE: The following devices do not support session transitions, coach consulting, and coach resumption.
- all analog phones
- IP110
- IP210

Silent Coach cannot be initiated with users that are on conference calls.
Calls upon which Silent Coach is active and cannot be transferred or converted to a conference call.

Silent Coach is not available on SIP extensions or over SIP phones trunks.
The recipient cannot record calls while Silent Coach is active.
11.2 Silent Coach Configuration

11.2.1 Configuring Silent Coach Permissions

Silent Coach access is controlled through Telephony CoS settings. Permissions for monitoring calls and for having calls monitored are configured through the Silent Monitor / Silent Coach option on the Telephony Class of Service Edit panel, as shown in Figure 11-1.

To configure Silent Coach for a Telephony Class of Service:

Step 1 Open a Telephony Class of Service panel for the desired service class:

Step a: Select Administrator -> Users -> Class of Service on the Main Menu.

Step b: Click the name of the desired Telephony Features Permissions CoS.

Step 2 Select the following Silent Monitor options for users assigned to the Class of Service:

• Enable users assigned to the CoS to monitor calls by marking the Allow Initiation checkbox in the Silent Monitor / Silent Coach Other’s Calls row.

• Determine the users that can monitor users assigned to the CoS by selecting a radio button right of the Accept: text.

Valid options include None, All, and From Only. Selecting From Only activates the data entry field that specifies the user that can silently monitor calls of users assigned to the CoS.

Step 3 Click the Save button to save your changes.
11.2.2 Enabling the Silent Coach Warning Tone

ShoreWare provides an option for playing a Silent Coach Warning Tone to all call participants when a Silent Coach session is initiated and if the Silent Coach Warning Tone option is enabled. The Warning Tone setting applies to all Silent Coach sessions on the system. When a user transitions between Silent Coach and Silent monitor, the warning tones start/stop are based on the silent coach or silent monitor warning tone setting.

To enable the Silent Coach Warning Tone option:

Step 1 Open the Call Control Options Edit panel, as shown in Figure 11-2, by selecting Administration -> Call Control -> Options on the Director Main Menu.

Step 2 Mark the Enable Silent Coach Warning Tone option.

![Call Control Options Edit panel](image)

Figure 11-2 Enabling the Silent Coach Warning Tone

11.2.3 Configuring Silent Coach buttons

ShorePhone and ShoreTel Communicator programmable buttons can be configured to initiate a Silent Coach session with a specific user or to query the caller for a Silent Coach destination. The configuration processes for ShorePhone and ShoreTel Communicator programmable buttons are almost identical.

To configure an IP Phone button to initiate Silent Coach:

Step 1 Open a user's IP Programmable Button panel for the desired user:

Step a: Select Administrator -> Users -> Individual Users on the Main Menu.

Step b: Open the Edit User panel by clicking the name of the desired user.

Step c: Select Personal Options at the top of the panel.

Step d: Click IP Phone Buttons.

Figure 11-3 displays the IP Phone Buttons configuration panel.

Step 2 Select Silent Coach from the Function drop-down menu of a selected button.
### Chapter 11: Silent Coach

#### 11.3 Performing a Silent Coach Operation

Silent Coach is initiated from the following:

- ShoreTel Communicator programmable button
- ShoreTel Communicator menu option
- ShorePhone programmable button

Any phone by pressing the code *22, then entering the target extension.

#### 11.3.1 ShoreTel Communicator

ShoreTel Communicator supports two methods of initiating Silent Coach operations – from menu options and by pressing a toolbar button.

To perform a Silent Coach from a ShoreTel Communicator Menu:

**Step 1** Perform one of the following:

- Click the Application Button, then select **Dial -> Silent Coach**.
- Select **Dial -> Silent Coach** from the main menu.
- Right click the System Tray ShoreTel icon select **Dial -> Silent Coach**.

ShoreTel Communicator displays the **Silent Coach** dialog box, as shown in Figure 11-4.

![Program IP Phone Buttons](image)

Figure 11-3 Programming IP Phone Button – Silent Coach

**Step 3** Enter the button label in the **Label** field.

**Step 4** To program the button to monitor the calls of a specific user, enter the user's extension in the **Extension** field.

If this field is left blank, pressing the IP Phone button queries the initiator to enter a number in the Telephone User Interface before the session begins.

**Step 5** Click **Save** to store panel changes.
To perform a Silent Coach from a ShoreTel Communicator toolbar button:

**Step 1** Press the programmable *Silent Coach* button, as shown in Figure 11-5.

  - If the button specifies a Silent Coach recipient, the system immediately initiates a Silent Coach session with that user. Skip the remaining steps.
  - If the button does not specify a Silent Coach recipient, ShoreTel Communicator displays the *Silent Coach* dialog box. In this case, continue to the next step.

**Step 2** Enter an extension or select from the drop-down list.

**Step 3** Click the *Silent Coach* button.

To transition a Silent Coach session into a Silent Monitor or Barge In session, perform one of the following:

- Right click the call cell and select the desired session type on the context menu.
- If available, press the Monitor or Barge In programmable button.

The same process transitions a Silent Monitor session into a Silent Coach session.
11.3.2 IP Phone

To perform a Silent Coach from a ShorePhone programmable button, press the Silent Coach button.

- *If the button specifies a Silent Coach recipient,* the system immediately initiates a Silent Coach session with that user. Disregard the remaining steps.

- *If the button does not specify a Silent Coach recipient,* enter the recipient's name or number in the Telephone User Interface.

ShoreTel Communicator displays the Silent Coach dialog box. In this case, continue to the next step.

To perform a Silent Coach from any system phone,

- Enter the *22 code, followed by the number of the target extension.

ShoreTel phones display softphone options while a Silent Monitor option is active. Figure 11-6 displays the ShorePhone 560 Telephone User Interface for a user that initiated a Silent Coach session.
Figure 11-6 IP Phone User Interface – Silent Coach initiator
Softkey options available to the Silent Coach initiator:

- **SilMon**: Transitions the session into a Silent Monitor session
- **Barge**: Transitions the session into a Barge In call.
- **Show**: Displays all call participants in the Telephone User Interface
- **Hangup**: Terminates the Silent Monitor session.

Softkey options available to the Silent Coach recipient:

- **Consul**: Places the active call on hold and establishes a two-way voice path between with the Silent Coach initiator.
  
  While the recipient consults with the initiator, soft key options include:
  
  - **Resume**: Restarts the recipient's original call.
  - **Show**: Displays all call participants.
  - **HangUp**: Terminates the call.
  
- **Show**: Displays all call participants in the Telephone User Interface.
- **Hangup**: Terminates the Silent Monitor session.
Chapter 12

Workgroups and Operators

12.1 Introduction

Workgroups is an entry level contact center application for small, informal Automatic Call Distribution (ACD) groups that is integrated into ShoreWare. Workgroups support basic call routing, agent management, reporting, and agent activity functions.

Classic phone operators provide assistance to callers and manage PBX switchboards. Although many operator functions can be automated, many systems or situations require a live person to handle specific issues.

ShoreTel Communicator supports Workgroups and Operators through three ShoreTel Communicator types. This chapter describes functions and components provided by these client types.

12.2 Client Types

ShoreTel Communicator provides three client types that provide capabilities required by users that do have workgroup or operator responsibilities: Workgroup Agent, Workgroup Supervisor, and Operator.

12.2.1 Workgroup Agent

Workgroup Agent ShoreTel Communicator is assigned to workgroup members that have basic call handling responsibilities. Workgroup Agent ShoreTel Communicator supports the following features:

- All functions available through Professional ShoreTel Communicator
- Enhanced Contacts Viewer capabilities, including drag-and-drop call transfer
- Workgroup access utilities
- Workgroup Queue Monitor
- Workgroup voice mailbox

12.2.2 Workgroup Supervisor

Workgroup Supervisor ShoreTel Communicator is assigned to users that are members of a workgroup and have management responsibilities over the members and function of the group. Workgroup Supervisor ShoreTel Communicator supports the following features:

- All functions available through Workgroup Agent ShoreTel Communicator.
- Workgroup Agent Monitor
- Enhanced Agent Monitor capabilities
- Supervisory specific functions, including editing agent access settings and establishing Workgroup activity thresholds.
12.2.3 Operator

Operator ShoreTel Communicator is assigned to users that are required to provide assistance to system callers or have call routing responsibilities. Operator Access is assigned the following features:

- All functions available through Workgroup Supervisor ShoreTel Communicator.
- Enhanced Contact viewer capabilities, including call and agent management functions
- Bridged Call Appearance Monitor.

12.3 Workgroup Status

12.3.1 Logging into and out of a Workgroup

Workgroup members receive calls to the workgroup extension when they are available and are logged into the workgroup call. ShoreTel Communicator displays workgroup status in the status bar. Users that belong to multiple workgroups can receive calls from all the workgroups to which they are members when their status is available. Each user has one workgroup status that applies to all their workgroups.

To log in to your workgroups, perform one of the following:

- Click the Application Button and select **Workgroup -> Logged In**.
- Select **Workgroup -> Logged In** from the main menu.
- Click the Workgroup button on the Assignment Bar and select **Logged In**.
- Right click the ShoreTel icon in the System Tray and select **Workgroup -> Logged In**.
- Press Ctrl+Alt+I.

To log out of your workgroups, perform one of the following:

- Click the Application Button and select **Workgroup -> Logged Out**.
- Select **Workgroup -> Logged Out** from the main menu.
- Click the Workgroup button on the Assignment Bar and select **Logged Out**.
- Right click the ShoreTel icon in the System Tray and select **Workgroup -> Logged Out**.
- Press Ctrl+Alt+O.

Your call control status appears in the Agent Monitor, which advise workgroup supervisors of your availability to accept workgroup calls. The workgroup supervisor can also log members in or out of the workgroup.

Depending on the workgroup's configuration, you may also be logged out automatically if you do not answer a workgroup call while logged in.
12.3.2 Call Wrap-Up

The Call Wrap-Up feature gives you time between calls to complete notes or finish updates to customer records. You are not available to accept calls from the queue when you are in Wrap-Up mode. After the Wrap-Up interval ends, you are automatically logged into the workgroup. The wrap up interval is defined for each workgroup and configured by the system administrator.

You can change your Call Wrap-Up status before the interval ends by logging in or out of the workgroup.

To manually enter wrap up mode, perform one of the following:

- Click the Application Button and select Workgroup -> Wrap-Up.
- Select Workgroup -> Wrap-Up from the main menu.
- Click the Workgroup button on the Assignment Bar and select Wrap-Up.
- Right click the ShoreTel icon in the System Tray and select Workgroup -> Wrap-Up.
- Press Ctrl+Alt+W.

To manually exit wrap up mode, log into or out of your workgroups.

12.4 Viewer Descriptions

Workgroup Agent, Workgroup Supervisor, and Operator ShoreTel Communicators provide viewers that are not available for Personal and Professional ShoreTel Communicators. Additionally, viewers that are accessible to Personal and Professional ShoreTel Communicators may offer enhanced functionality to support Operators and Workgroup Members.

The following sections describe ShoreTel Communicator Viewers available to Workgroup and Operator ShoreTel Communicator.

12.4.1 Queue Monitor

The Queue Monitor, shown in Figure 12-1, displays the calls that are ringing into your workgroups. The Queue Monitor is available in Workgroup Agent, Workgroup Supervisor, and Operator ShoreTel Communicator.

To open the Queue Monitor, perform one of the following:

- Click the Application Button, then select Workgroup -> Queue Monitor.
- Select Workgroup -> Queue Monitor from the Main Menu.
- Select Windows -> Queue Monitor from the Main Menu.
- Select Windows -> Queue Monitor from the Assignment bar.
- Right click the ShoreTel icon in the system tray and select Workgroup -> Queue Monitor.
- Press Ctrl+Shift+Q.

The Queue Monitor opens in the Main window content area or in a Satellite window.
12.4.1.1 Viewer Components

The Queue Monitor comprises an action bar, a workgroup table, and a call table:

**Action bar:** The action bar contains buttons that trigger workgroup configuration options and panels. Action bar buttons include:

- **Alert Sound:** Press this button to toggle the sound alert status. When this button is highlighted and a threshold is exceeded, ShoreTel Communicator plays the audio alert designated by the Options and Preferences: Sounds panel.
- **Options:** Press this button to access the Options and Preferences: Workgroups panel.

**Workgroup table:** The top table in the Queue Monitor lists selected Workgroups to which you belong. You specify the workgroups displayed in the table from the Options and Preferences: Workgroups panel.

Each row corresponds to one workgroup. Each column corresponds to a workgroup property. Columns that the Workgroup table can display include:

- **Unlabeled Checkbox:** Select this check box to display Workgroup calls in the Call Table.
- **Workgroup:** This field lists the workgroup's name and extension.
- **CHM:** This column lists the active Call Handling Mode for the Group. Clicking in this cell accesses a drop-down menu that changes the call handling mode.
- **Queued Calls:** This field lists the number of calls in the workgroup's queue.
- **Longest Queued Time:** This field indicates the longest queue time of all calls in the queue.
- **Longest Call Time:** This field indicates the longest call time of all calls in the queue. This time differs from the longest queue time when calls are returned to the queue after an agent answers it.

![Queue Monitor](image)
**Chapter 12: Workgroups and Operators**

**ShoreTel Communicator for Windows**

**Call table:** The bottom table lists the calls that are in the queues of the workgroups to which you belong. Each row corresponds to one call that is waiting in a workgroup's queue. Columns that the Call table can display include:

- **Workgroup:** This field lists the call's intended recipient workgroup.
- **Caller Name / Number:** This field lists the Call ID information for the call.
- **Queued Time:** This field indicates the period that the call has waited in the queue.
- **Call Time:** This field indicates the period the call has been active including, for calls re-entering the queue after being by an agent, all periods the call was active and on hold.
- **DNIS:** This field displays the DNIS identification number sent by the originating call.
- **More Info:** This field displays miscellaneous call information including the routing slip and the call note.

**12.4.1.2 Setting Thresholds**

Workgroup Supervisors can specify queue size and queue time thresholds for a workgroup. Queue Monitor displays any values that exceed these thresholds in bold red text. Supervisors can also configure audible alerts to when queued calls result in exceeded thresholds.

The supervisor sets a Workgroup's warning thresholds that define the maximum number of queued calls and the maximum wait time allowed before the Queue Monitor displays a warning to all agents.

To set workgroup warning thresholds:

**Step 1** Open the Options and Preferences window by performing one of the following:

- Press the *Options* button in the Queue Monitor menu bar.
- Select *Tools -> Options* from the Main menu.
- Click the Application Button and select *Options*.
- Right click the ShoreTel Communicator icon in the System Tray and select *Options*.
- Press Ctrl+O.

**Step 2** Select *Workgroups* in the menu on the left side of the window.

**Step 3** Specify the Calls Size threshold by clicking the *Calls in Q* cell for the desired workgroup.

**Step 4** Specify the Call Wait Time threshold by clicking the *Queued Time* cell for the desired workgroup.

**12.4.1.3 Setting Workgroup Call Handling Modes**

The supervisor sets the Call Handling Mode for the workgroup in the Queue Monitor. There are four Call Handling Modes: On-Hours, Off-Hours, Holiday, and Custom. The workgroup Call Handling Mode changes the way calls are handled based on the current setting.

To change the workgroup Call Handling Mode, access the drop down menu by clicking the CHM button on the Queue Monitor menu.
12.4.2 Agent Monitor

The Agent Monitor, shown in Figure 12-2, displays the status of agents in your workgroups as specified in the Options and Preferences: Workgroups panel. Agent Monitor is available in Workgroup Supervisor and Operator ShoreTel Communicator.

To open the Agent Monitor, perform one of the following:

- Click the Application Button, then select Workgroup -> Agent Monitor.
- Select Workgroup -> Agent Monitor from the Main Menu.
- Select Windows -> Agent Monitor from the Main Menu.
- Select Windows -> Agent Monitor from the Assignment bar.
- Right click the ShoreTel icon in the system tray and select Workgroup -> Agent Monitor.
- Press Ctrl+Shift+A.

The Agent Monitor opens in the Main window content area or in a Satellite window.

12.4.2.1 Viewer Modes

ShoreTel Communicator provides the following Agent Monitor view options:

- **Details** – Each agent is listed in an individual row, similar to the traditional Windows Explorer column view, and grouped by Workgroup. Agents can be sorted within their workgroups by clicking the column headings at the top of the list.
- **List** – Agents are displayed in a single column that shows their name and log status. Agents are listed alphabetically within their workgroups.
**Small Icons** – This view displays all Agents without separating them into their workgroups. Phone status is displayed using small icons.

**Large Icons** – This view displays all Agents without separating them into Workgroups. Phone status is displayed using large icons.

To select a viewer mode, right click in the Monitor table and select the desired mode.

### 12.4.2.2 Viewer Components

The Agent Monitor comprises an action bar, a workgroup table, and a call table:

**Action bar:** The action bar contains buttons that trigger agent options and panels. Action bar buttons include:

- **Pickup:** Press this button to pickup the call from the selected agent. This option only available to Operator ShoreTel Communicator.
- **Unpark:** Press this button to unpark a call from the selected agent. This option only available to Operator ShoreTel Communicator.
- **Dial:** Press this button to initiate a call to the selected agent.
- **Dial Mailbox:** Press this call to call the selected agent's voice mailbox.
- **IM:** Press this button to initiate an instant message to the selected agent.
- **Intercom:** Press this button to perform an intercom call to the selected agent.
- **Whisper Page:** Press this button to initiate a whisper page to the selected agent.
- **Barge In:** Press this button to barge into the selected agent's call.
- **Silent Monitor:** Press this button to listen to the selected agent's call.
- **Logged In:** Press this button to log the selected agent into the workgroup.
- **Logged Out:** Press this button to log the selected agent out of the workgroup.
- **Wrap-Up:** Press this button to change the selected agent's log status.
- **More Info:** Press this button to display status and call handling information for the selected agent.

**Filter bar:** The Agent list displays only entries whose name or number matches the the filter bar text. Filter bar contents are compared to columns that list name and contact information for the entries.

**Agent List:** The Agent table lists the Agents in the Workgroups to which you belong. Each row corresponds to one agent. When viewing the table in Details mode, each column corresponds to an agent property or status indicator. Columns that the Agent table can display in Details mode include:

- **Name:** This field lists the agent's name
- **Agent State:** This field lists the agent's log state.
- **Number:** This field lists the agent's extension.
- **Extn Status:** This field lists the agent's phone status.
- **Call Handling Mode:** This field indicates the agent's current call handling mode.
- **Call Handling Note:** This field lists the agent's current call handling note.
- **Call Handling Details:** This field indicates the call forwarding method specified by the agent's active call handling mode.
- **Call State:** This field indicates the status of the call that the agent is handling.
- **# Calls:** This field indicates the number of calls on the agent's call stack.
- **Duration:** This field indicate duration of the call that the agent is currently handling.

Agent Monitor also plays an audio alert while a new call rings any agent.
12.4.2.3 Context Menu Operations

You can perform most operations available on the Action bar through a context menu accessed by right clicking on an Agent.

Functions accessible through the Agent Monitor include:

- **Workgroup functions**: viewing and changing agent status
- **Call Monitor functions**: barge in, silent monitor, whisper page
- **Call Resumption functions**: Park and Pickup
- **Agent Contact options**: Dial, Dial Mailbox, Intercom

The Agent Monitor displays workgroup agents' call status and activities. The telephone icon next to an agent's name indicates call status and the number of calls the agent is handling. The connection icon displays the agent's logged on and wrap-up status.

To initiate a voice call to an agent's extension, perform one of the following:

- Double-click on the name of the desired contact
- Drag and drop the name of the desired contact into the Active Call Area in the Main Window.

To initiate any other call operation, right click on the desired contact and select the operation or phone number from the context menu.

12.4.3 Instant Messaging in the Workgroup Agent Monitor Window

Support for Instant Messaging in the Agent Monitor window allows the workgroup Supervisor to monitor an agent's IM presence as well as initiate an IM chat with any of the workgroup agents. This functionality is deployed with any workgroup that has implemented the Supervisor or Operator ShoreTel Communicator. All participants of the workgroup including the Supervisor must be configured with Instant Messaging.

To implement an IM response during an inbound call, the user must have IM configured in their ShoreWare Director profile. In order for the IM address of the inbound caller to be recognized, they must be added to the user's contacts or to their buddy's list. An IM server such as Microsoft Office Communications Server 2007 or the ShoreTel Conference Bridge must be configured in the ShoreWare Director and installed and available on a separate server. All users must have a profile created on the IM Server.

![Instant Messaging Status](image-url)
When viewing the Agent's IM status the supervisor quickly can determine the Agent's availability, as shown in the above figure, for an incoming chat or they can initiate a chat while the agent is available. They may also choose to use the chat option when the agent is on a call and may possibly require assistance with any inbound calls.

To initiate a chat session, perform the following:

**Step 1** Launch the Agent Monitor by right clicking on the ShoreTel icon in the system tray and select Workgroup -> Agent Monitor. The Agent Monitor window is displayed, as shown below.

![Agent Monitor Window](image)

**Step 2** Select the user you wish to chat with using by and clicking on the Agent's name.

**Step 3** Click the IM button located in the menu bar to start an IM Chat session.

### 12.4.3.1 Configuring Instant Messaging

System administrators can configure ShoreTel's Instant Message functionality through ShoreWare Director. Each user who has access to instant messaging must have the General tab of their Users Profile configured with the instant messaging profile information that must also be present on the IM server.
Each Supervisor or Operator must be set to the appropriate Client Type in their user profile.
12.4.4 Bridged Call Appearance Monitor

The Bridged Call Appearance Monitor, as shown in Figure 12-8, displays the Bridged Call Appearances for which your extension has devices configure to answer. Operator ShoreTel Communicator is required to access the Bridged Call Appearance Monitor.

To display the BCA Monitor, as shown in Figure 12-8, perform one of the following:
- Click the Application Button and select Windows -> Bridged Call Appearance Monitor.
- Select Windows -> Bridged Call Appearance Monitor from the Main Menu.
- Select Windows -> Bridged Call Appearance Monitor from the Assignment bar.
- Right click the ShoreTel icon in the system tray and select Windows -> Bridged Call Appearance Monitor.
- Press Ctrl+Shift+X.

12.4.4.1 Bridged Call Appearance Description

A BCA is an extension that is shared among multiple users. A BCA is characterized by an extension number and its call stack depth. The extension number defines the method of contacting BCA users. The call stack depth specifies the number of call that can simultaneously reside on the BCA. The maximum BCA stack size is 24. Bridged Call Appearances are configured by the system administrator.

Calls into a BCA occupy distinct call appearances and are identified by their position in the call stack. ShorePhone buttons that answer calls are configured to handle calls to a specific call stack position of a BCA.
Example: The system administrator configures a BCA with an extension of 118 and a call stack depth of 3. The ShorePhones of three users are configured to handle calls to the BCA as follows:

User One has one button that answers calls from Stack Position #1.
User Two has one button that answers calls from Stack Position #2.
User Three has three buttons configured to answer BCA calls – the first button answers calls to Stack Position #1, the second button answers calls to Stack Position #2, and the third button answers calls to Stack Position #3.

The first incoming call to the BCA arrives on Stack Position #1. User Two cannot answer this call. A second call to the BCA will arrive on Stack Position #2 if the first call is still active. User One cannot answer that call. User Three is the only user that can answer calls that arrive on Stack Position #3.

12.4.4.2 Bridged Call Appearance Monitor Components

The Bridged Call Appearance Monitor displays all call stack positions for each BCA extension for which your extension can receive calls. Each row in the table corresponds to one BCA call stack position. Each column lists an identifying property of the call stack position or of the call to the BCA that occupies the call stack position.

Bridged Call Appearance in Details mode include:

- **Filter bar**: The BCA Monitor displays only entries whose sender name or number matches filter bar contents. Filter bar contents are compared to columns that list name and contact information.
- **Action bar**: The action bar contains buttons that trigger actions or display status relative to the selected BCA stack position. Action bar buttons include:
  - **Retrieve**: Press this button to access a ringing or parked call.
  - **More Info**: Press this button to display call information, including the phone number and call duration.
- **Column Headings**: Column headings indicate the data field name for the BCA call stack position.
  - **Name**: This field lists the name of the BCA call stack position, as specified by the system administrator.
  - **Ext.**: This field displays the BCA extension number.
  - **Position**: This field displays the call stack position.
  - **Call State**: The field lists the state of the call occupying the call stack position.
  - **Duration**: This field displays the period that the call on the call stack position has been active.

12.4.4.3 Viewer Modes

You can specify the BCA Monitor viewer mode by right clicking in the table and selecting the desired mode. Each view includes a control field, similar to QuickDialer, that filters the agents displayed by the monitor.

ShoreTel Communicator provides the following BCA Monitor views:

- **Details** – Each BCA stack position is listed in an individual row, similar to the traditional Windows Explorer column view. The table displays the columns in Details mode.
List – BCA stack positions are displayed in a single column that shows their extension and stack position.

Small Icons – This view displays BCA stack positions as small icons that indicate call status.

Large Icons – This view displays BCA stack positions as large icons that indicate call status.

12.4.4.4 Caller ID and Bridged Call Appearances

The following rules determine which caller ID is displayed when an outgoing call is made using BCA:

Outbound to an internal extension – the name and number of the user that initiated the BCA call is displayed; if that user is a “private” user, then the caller ID is blank.

Outbound to an external number – the following caller ID options are displayed in the following priority, based on availability:

— Outbound caller ID configured for that BCA
— DID number configured for that BCA
— External identification or caller ID number of the BCA call initiator

Outbound to an external emergency number (such as 911) – the emergency identification or a CESID number of that user will be sent.

12.5 Viewer Enhancements

The Voice Mail and Contacts Viewers provide enhanced capabilities to users of Workgroup Agent, Workgroup Supervisor, and Operator ShoreTel Communicator. The following sections describe the enhanced capabilities of these viewers.

12.5.1 Voice Mail Viewer

Each workgroup has its own workgroup mailbox in the ShoreTel Voice Mail Viewer, and each member of the workgroup can access this mailbox.

The workgroup mailbox has its own Inbox, Saved, and Deleted folders that appear separate from the user’s personal mailbox folder in the ShoreTel Voice Mail Viewer. Incoming workgroup messages appear in the workgroup Inbox. When you save or delete workgroup messages, they are sent to the workgroup’s Saved or Deleted folders.

The Voice Mail Viewer displays messages to your workgroups in addition to messages to your extension. The Viewer displays messages to each entities in blocks. In Figure 12-9, the personal messages to Ted Coates are grouped in the first block and messages to Tier One workgroup are grouped in the second block.

Section 9.3 on page 115 describes Voice Mail Viewer features and functions.

12.5.2 Contacts Viewer

The Contact viewer provides access to Contact Lists, which are subsets of your directory entries. In addition to the basic functionality described in Section 8.3 on page 93, Workgroup Agents, Workgroup Supervisors, and Operators can transfer calls to contacts through drag and drop operations of a call cell to a contact.
The Contact viewer for operators provide an Action bar, through which Park, Pickup, and other call operations are available.
13.1 Introduction

The ShoreTel Contact Center is a software application that controls, manages, and monitors call center activities. Contact Center controls interactions with customers through a system of four interlocking components:

- **Call routing** implements business rules that define customer service and resource allocation.

- **Monitoring of call center operations** to provide supervisors with information required to manage daily operations.

- **Performance measurement** through historical reports gives supervisors an “aerial view” of operations from the perspective of business objectives, and captures information that management can use to make policy decisions.

- **Agent tools** extend the ability of your knowledge workers to provide effective service.

Contact Center connects to ShoreWare through a software interface over an IP Network. All Contact Center functionality is access through a separate suite of application tools, including an Agent Toolbar, Supervisor Monitoring Tools, Historical Reports, and a software wall board.

**Contact Center** features are available through all Access Levels to users authorized by the system administrator. The Main Menu bar provides a Contact Center menu for users with Contact Center access rights.

**ShoreWare Workgroups** is distinct from **Contact Center** features and functionality. Workgroup features cannot be used to perform Contact Center functions and Contact Center features cannot be used to perform Workgroup functions.

For a detailed description of all Contact Center features, refer to the following ShoreTel manuals:

- Contact Center Administration Guide
- Contact Center Agent Toolbar
- Contact Center CRM Installation Guide
- Contact Center Installation Guide
- Contact Center Supervisor Applications Guide
13.2 Requirements

Contact Center agents can access Contact Center through ShoreTel Communicator only on PCs upon which Contact Center Agent Bar and ShoreTel Communicator are installed.

Contact Center Supervisors can access Contact Center through ShoreTel Communicator only on PCs upon which Contact Center Agent Bar, Contact Center Supervisor Applications, and ShoreTel Communicator are installed.

To use ShoreTel Communicator for performing Contact Center operations, a Contact Center Supervisor must also be configured as a Contact Center Agent.

For complete information on configuring Contact Center components, refer to Contact Center documentation.

13.3 Configuring Contact Center Options

To configure the Contact Center options, perform the following:

Step 1 Open ShoreTel Communicator. The panel in Figure 13-1 appears the first time ShoreTel Communicator is opened after integrated ShoreTel Communicator is enabled for the user.

![Agent Toolbar (Instance 1243088)](image)

Figure 13-1 Configuring the IP addresses for the agent toolbar

The Setup window is configured once. If it has not been configured, the Agent Toolbar opens this dialog the first time it is executed. This dialog box offers a manual way to enter IP addresses or mail account information.

Server IP – The address of the Contact Center Server

Local IP Address – The address of the agent's client machine

Mail Account – The Personal Email Username for Contact Center – not an email address. Refer to the ShoreTel Contact Center Administration Guide.

Mail Password – this is the agent's password that is associated with the Personal Email Username
Mail Accounts allows agents to receive email from callers through standard email programs, such as Outlook or Outlook Express. Email accounts are configured for each inquire type and email received in these accounts are placed in a queue where an agent can download a predetermined number of emails. Mailboxes can be assigned to a specific computer or agent.

**Step 2** Verify the information in the setup window, then select **Contact Center -> Configure Call Center** from the ShoreTel Communicator main menu.

ShoreTel Communicator displays the Contact Center Options panel shown in Figure 13-2.

![Figure 13-2 The Contact Center Options window](image)

**Step 3** Click on the Configure Groups button from the Contact Center Options window to display the Group manager window shown in Figure 13-3.

![Figure 13-3 Logging into and out of workgroups](image)
Step 4 The Group manager window allows you to log into or out of select contact center groups. To log into a group, click a group name from the “Available Groups” pane (on the right) to highlight it. Then, click the Login button to move that group to the “Logged Groups” pane on the left.

Step 5 Next, click the Configure Call Status button from the Contact Center Options window to display a window similar to the one shown in Figure 13-4.

![Configure Call Status](image)

**Figure 13-4 Selecting parameters for display**

Step 6 This window allows you to determine which blocks of information will appear in the agent Call Status window (shown on the next page). Click any of the parameters from the “Available Fields” pane on the right, and then click the << button to move the selected parameter to the “Selected Fields” pane on the left.

The agent Call Status window displays information about a current call that has been answered by this agent. Information is displayed with the selected fields listed across the top, as shown in Figure 13-5.

![Agent Toolbar](image)

**Figure 13-5 Call status fields in the agent toolbar**

The Call Status window can display information for multiple calls. The window displays information about how long the caller has been waiting, the priority of the call. And if the agent belongs to multiple groups, the window will provide information about which group the call originated from.
**Step 7** Next, click the Configure Queue Monitor button from the Contact Center Options window. The dialog box used to configure the Queue Calls window is similar to that shown in Figure 13-5 for configuring the Call Status window. You should select click the desired parameters from the “Available Fields” pane and move them to the “Selected Fields” pane on the left.

After the configuration is selected, the Queue Calls window appears, as shown in Figure 13-6.

![Figure 13-6 Queue monitor](image)

The Queue Monitor is similar to the Agent Call Status window in that it provides information about incoming calls, but it is different in that it displays information for calls that have not been answered. An additional difference is that the Queue Calls window allows users with the proper permissions, as defined in the Class of Service, to double-click a particular call to answer it.

**Step 8** Select the Show Agent Toolbar check box from the Contact Center Options window to display the Contact Center Agent Toolbar, similar to the one in Figure 13-7.

![Figure 13-7 Agent Toolbar functions](image)

The Agent Toolbar offers an optional method of accessing the Contact Center features and application windows. Because the Agent Toolbar offers access to many of the same functions and features as the integrated ShoreTel Communicator window, having both open at the same time may be redundant and unnecessary, but it can ease the transition from Contact Center to the new unified interface.
13.3.1 Accessing Contact Center Features from ShoreTel Communicator

- Depending on how the programmable buttons were configured, many of the functions shown in the Agent Toolbar in Figure 13-7 will be the same as those that now appear in the integrated ShoreTel Communicator and Contact Center user interface.
- Supervisors can access certain capabilities by clicking on the highlighted buttons shown in Figure 13-7.
- The following functions can be performed from the Agent Toolbar:
  - Telephony Operations
  - ACD Operations
  - Application Windows
  - Chat Operations
  - Other Operations

13.3.2 Contact Center Feature Limitations in ShoreTel Communicator

The Contact Center Agent Toolbar includes a status bar, shown in Figure 13-8, that displays caller and call status information. Status bar information is not available through ShoreTel Communicator. Information displayed by the status bar that is not available through ShoreTel Communicator includes:

- Type of call the agent is servicing: voice call, email interaction, or chat interaction.
- Call Profile information collected from the IVR or configured in Contact Center. The Call Status window in ShoreTel Communicator displays the Call profile fields.
- Indicators that an agent is scheduled for an outbound call programmed by Contact Center Dial Lists, abandoned callbacks, and scheduled callbacks.

When Agent Notification Preview is enabled in Contact Center, ShoreTel Communicator receives notification of programmed call before they are placed.

ShoreTel Communicator does not have ring tone options to distinctly identify the inbound call type on the agent desktop. ShoreTel Communicator signals an incoming Contact Center call in the same manner as all other calls.

Contact Center upgrades for the agents and supervisors are distinct from ShoreTel Communicator upgrades for new software releases. Version updates for new Contact Center releases that require an update for agents and supervisors must be performed as described by Contact Center installation documentation and are not affected by ShoreTel Communicator upgrades.
13.4 Using Contact Center through ShoreTel Communicator

You can use the Contact Center menu in ShoreTel Communicator to access the Contact Center login feature and other functions.

Step 1 Select Contact Center -> Login Primary Groups to login into the primary groups.

If you are already logged in, you can select Logout Primary Groups to exit from the primary groups of which you are a member.

This operation can be assigned to a programmable buttons in ShoreTel Communicator.

Step 2 Verify that you successfully logged into a contact center group by viewing the Logged In icon in the Assignment bar, as shown in Figure 13-9.

If you are not logged into at least one contact center group, the login icon states Logged Out.

If a problem occurs while logging into the contact center, the status bar displays System Unavailable.

Figure 13-10 displays ShoreTel Communicator and the Contact Center toolbar when receiving a Contact Center call.
Figure 13-10 Receiving Contact Center Call Through ShoreTel Communicator
14.1 Introduction

For Microsoft Outlook users, ShoreTel Communicator supports integration with Outlook inbox, voice mail and calendar features. This Chapter describes Outlook integration features and procedures.

14.2 Importing Outlook Contacts

You can configure ShoreTel Communicator to include Microsoft Outlook contacts in the Directory viewer every time you log into ShoreTel Communicator. Outlook contact import options include:

- Open the Outlook Contacts panel when you receive a call.
- Cache Outlook Contacts: Outlook contacts remain available to ShoreTel Communicator until you logout. They are not added to the permanent ShoreWare database, where ShoreTel Communicator settings resides. This limitation requires the import of Outlook contacts each time ShoreTel Communicator is started.
- You cannot access Outlook contacts while they are being imported into ShoreTel Communicator. Caching Outlook Contacts provides immediate access to your Outlook Contacts upon logging into ShoreTel Communicator.

To import Outlook contacts to the ShoreTel Communicator

Step 1  Open Options and Preferences by performing one of the following:

Select Tools -> Options from the Main menu.
Click the Application Button and select Options.
Right click the ShoreTel icon in the System Tray and select Options.
Press Ctrl+O.

Step 2  Select Outlook in the menu on the left side of the window.

Step 3  Select Import contacts from Outlook.

Outlook contacts are accessible from the Directory Viewer. The Data Source column indicates the directory entries that were imported from Outlook.
To program ShoreTel Communicator to activate the Outlook Contacts panel when you receive a call:

**Step 1** Open Options and Preferences by performing one of the following:
- Select **Tools -> Options** from the Main menu.
- Click the Application Button and select **Options**.
- Right click the ShoreTel icon in the System Tray and select **Options**.
- Press Ctrl+O.

**Step 2** Select **Outlook** in the menu on the left side of the window.

**Step 3** Select **Open Outlook Contacts when Calls Arrive**

To program ShoreTel Communicator to cache Outlook Contacts:

**Step 1** Open Options and Preferences by performing one of the following:
- Select **Tools -> Options** from the Main menu.
- Click the Application Button and select **Options**.
- Right click the ShoreTel icon in the System Tray and select **Options**.
- Press Ctrl+O.

**Step 2** Select **Outlook** in the menu on the left side of the window.

**Step 3** Press the **Import Options** button on the top right corner of the panel.

**Step 4** Select **Enable disk caching** on the Disk Cache Options panel.

**Step 5** Configure other Caching parameters on the panel.

### 14.3 Configuring Outlook for Voice Mail

You can configure ShoreTel Communicator to integrate voice mail with Microsoft Outlook. When you integrate voice mail with Outlook, voice messages appear in your Outlook Inbox.

To install or uninstall Outlook voice mail integration, perform the following:

**Step 1** Open Options and Preferences by performing one of the following:
- Select **Tools -> Options** from the Main menu.
- Click the Application Button and select **Options**.
- Right click the ShoreTel icon in the System Tray and select **Options**.
- Press Ctrl+O.

**Step 2** Select **Outlook** in the menu on the left side of the window.

If Voice Mail Integration is installed, the Voice Mail section displays an **Uninstall** button and the following text: **Outlook Voice Mail Integration is installed**.

If Voice Mail Integration is not installed, the Voice Mail section displays an **Install** button and the following: **Voice Mail integration with Outlook is not currently installed**.
Step 3 To install Voice Mail Integration, press the **Install** button located right of the voice mail integration status text.

To remove Voice Mail Integration, press the **Uninstall** button located right of the voice mail integration status text.

The Voice Mail integration section also provides options for handling voice mail files:

- **Attach Voice Mail from Message when Moved:** When this parameter is selected, moving an email from the Outlook Inbox to another folder results in the copying of the attached Voice Message .wav file to the Outlook message file.

- **Delete Voice Mail from Message when Moved:** When this parameter is selected, moving an email from the Outlook Inbox to another folder results in the removal of the attached Voice Message from the ShoreWare server.

### 14.4 Outlook Calendar Integration

Calendar Integration provides Outlook to use your ShoreWare call handling mode settings to manage your appointments.

#### 14.4.1 Installing Calendar Integration

To install or uninstall Outlook Calendar integration, perform the following:

**Step 1** Open **Options and Preferences** by performing one of the following:

Select **Tools -> Options** from the Main menu.

Click the Application Button and select **Options**.

Right click the ShoreTel icon in the System Tray and select **Options**.

Press Ctrl+O.

**Step 2** Select **Outlook** in the menu on the left side of the window.

If Calendar Integration is installed, the Voice Mail section displays an **Uninstall** button and the following text: **Outlook Calendar Integration is installed**.

If Calendar Integration is not installed, the Voice Mail section displays an **Install** button the following: **Calendar integration with Outlook is not currently installed**.

**Step 3** To install Voice Mail Integration, press the **Install** button located right of the voice mail integration status text.

To remove Voice Mail Integration, press the **Uninstall** button located right of the voice mail integration status text.

The Calendar integration section also provides options for handling voice mail files:

- **Use Outlook appointments to change Call Handling Mode:** When this parameter is selected, you can program Outlook to change your ShoreWare Call Handling mode on the basis of appointments listed in your Outlook Calendar.
14.4.2 Configuring Outlook for Automatic Call Handling

You can set ShoreTel Communicator to use your Outlook Calendar to determine your active Call Handling Mode.

To configure Outlook for automatic call handling

Step 1  On the Outlook toolbar, click the Configure Call Handling icon.
         The Outlook Call Handling Configuration dialog box appears.

Step 2  Select the Use Outlook Calendar to handle Call Handling check box.

Step 3  Select the desired Call Handling Mode for on-hours and off-hours in the Work Week Call Handling Mode section and the desired holiday Call Handling Mode in the Holiday Call Handling Mode section.

Step 4  Click OK to close the dialog box.

To set your work week on/off hours in Outlook:

Step 1  Open the Tools menu in Outlook Calendar and select Options.

Step 2  Click the Preferences tab and click Calendar Options.
         For call handling to be changed based on your on/off hours, this feature must be enabled in both the Outlook tab of the ShoreTel System dialog box and in Outlook.

14.4.3 Configuring Call Handling for an Appointment

When you make an appointment on your Outlook calendar, you can trigger the transition to a Call Handling Mode at the time of the appointment.

To configure your Outlook calendar appointment for call handling

Step 1  In Outlook, click New.
         A menu list appears.

Step 2  Click the Appointment tab.
         The Appointment dialog box appears.

Step 3  Click the Call Handling Mode tab.

Step 4  Select the desired Call Handling Mode options. The default setting is "Do Not Change My Call Handling Mode," which means that call handling will remain in the mode established automatically for this time period (on-hours, off hours, or holiday).

Step 5  Click Remind Me if you want a reminder to be displayed on your desktop when your Call Handling Mode is changed.

Step 6  Click Save and Close to confirm the changes and close the dialog box.
         For call handling to be changed based on appointments, Use Outlook appointments to change Call Handling Mode must be enabled in the ShoreTel Communicator Options and Preferences: Outlook panel and this feature must be enabled in Outlook.
14.4.4 Changing and Cancelling Automatic Call Handling

When Outlook is configured for automatic call handling, the call handling mode that you select for an appointment is active during the appointment. You can modify the scheduled call handling before the appointment.

To change or cancel automatic call handling for an appointment

Step 1 In Outlook, open the appointment for which you want to modify the automatic call handling selection. Cancelling the call handling selection causes the mode to change back to the default call handling mode.

Step 2 Click the Call Handling Mode tab.

Step 3 Change the call handling mode to one of the radio buttons on the left side. Choose Do Not Change to maintain the default call handling mode.

Step 4 Click Save and Close.

When the appointment occurs, the selected call handling mode is activated. If you choose Do Not Change, the call handling mode is set to the default mode chosen during the configuration of Outlook for automatic call handling during the appointment hours (on-hours and off-hours).

If you select Remind Me when setting the call handling mode, a reminder dialog box confirming the active call handling mode changed. Select one of the following:

- Dismiss to change the call handling mode.
- Cancel to maintain the call handling mode that was active before the start of the meeting.

If you open the Call Handling Mode tab again after clicking Cancel when the reminder dialog box appears, you will see that the radio button for the call handling mode option you originally chose for the appointment is still selected on the left side of the dialog box. On the right side of the dialog box, the option Change to call handling mode has been cancelled is also selected.
Options and Preferences Window

A.1 Introduction

The Options and Preferences window contains panels that configure many ShoreTel Communicator options, components, and functions including Instant Messaging, Call Handling Modes, Video Calls, and Presence. The list of available panels depend upon the features for which the user is authorized.

To display the Options and Preferences window, perform one of the following:

- Select Tools -> Options from the Main menu.
- Click the Application Button and select Options.
- Right click the ShoreTel Communicator icon in the System Tray and select Options.
- Press Ctrl+O.

A.2 Panel Descriptions

Panels in the Options and Preferences window are accessed by clicking panel names in the menu on the left side of the window. The following sections describe Options and Preferences panels in the order that they appear in the menu.

A.2.1 General panel

The General panel, shown in Figure A-1, determines ShoreTel Communicator startup behavior and appearance settings.

To access the General panel, open the Options and Preferences window and select General in the menu on the left side of the window.

General panel parameters include:

- **Start ShoreTel Communicator when you login to Windows**: Select this option to automatically open ShoreTel Communicator every time you login to windows.
- **Enable drag-and-drop Window arrangement**: When this option is selected, ShoreTel Communicator allows the movement of viewers between the Main Window Content Area and Satellite windows. Section 3.1.3 on page 24 describes the movement of viewers between the windows.
- **Color Scheme**: This option specifies the background color of ShoreTel Communicator windows and panels.
- **Hide ShoreTel Communicator when idle for more than**: This option specifies the amount of time before the ShoreTel Communicator is hidden when it's been idle. When enabled, you can specify the time. The default time is 30 seconds. ShoreTel Communicator will not be hidden if one or more calls are active.
• Move keyboard focus to Quick Dialer when activating ShoreTel Communicator: When this option is selected, the keyboard focus will be moved to the Quick Dialer control. The ShoreTel Communicator window can be activated using one of the following options:
  — a mouse click,
  — clicking the application on the task bar
  — selecting the Alt + TAB.

NOTE: If you click on a specific element on the ShoreTel Communicator window such as a contact, a voice message, another Call Manager window, or a toolbar button, the focus will NOT move to the QuickDialer.

### A.2.2 QuickDialer

The QuickDialer panel, shown in Figure A-2, configures QuickDialer field characteristics. Refer to Section 3.1.2.5 on page 22 for a complete description of QuickDialer.

To access the QuickDialer panel, open the Options and Preferences window and select QuickDialer in the menu on the left side of the window.
Appendix A: ShoreTel Communicator for Windows

• **Show company names**: Select this option to include company entries in your QuickDialer lists.

• **Show fax numbers**: Select this option to include fax number entries in your QuickDialer lists. Selecting this option also displays fax numbers in Directory Viewer context menus that you access when right clicking an entry.

• **Show extension calling actions**: Selecting this option configures QuickDialer to display available methods of contacting filtered extensions.

• **Show Go arrow**: Selecting this option displays a Go arrow on the right side of the QuickDialer field. Pressing the Go arrow initiates a call to the contact that QuickDialer displays.

• **Calls to show in redial**: The Redial icon, located on the right side of the QuickDialer field, displays calls recently made and received, as specified by this parameter setting.
  — **Outbound Calls**: Select this option to display only previously called numbers.
  — **Missed Calls and outbound calls**: Select this option to display only numbers of missed inbound calls and previously made outbound calls.
  — **All calls**: Select this option to display numbers of all of your inbound and outbound calls.

Figure A-2 Options and Preferences: QuickDialer panel
A.2.3 Call Handling Mode

The active Call Handling Mode determines the settings that ShoreTel Communicator uses to handle your inbound calls. The Call Handling Mode panel, shown in Figure A-3, specifies the active Call Handling Mode. Refer to Section 4.5.4.2 on page 36 for more information about the active Call Handling Mode.

To access the Call Handling Mode panel, open the Options and Preferences window and select Call Handling Mode in the menu on the left side of the window.

Call Handling Mode panel parameters include:

- **Current call handling mode** determines the active method of handling inbound calls. One mode is always current.
- **When ShoreTel Communicator is started** options enable call handling mode warnings:
  - **Warn when not using Standard Call Handling Mode** – Select this option to receive a warning if the active Call Handling Mode is not Standard when you start ShoreTel Communicator

![Figure A-3 Options and Preferences: Call Handling Mode panel](image-url)
— Warn when Standard Call Handling is set to Forward Always – Select this option to receive a warning if the active Call Handling Mode is Standard and the Forward Calls parameter is set to Always when you start ShoreTel Communicator.

• Allow these users to change current call handling mode: This option supports Call Handling Mode Delegation, as described in Section 4.5.4.4 on page 38. The edit box is a Quick Dial type window. Entering a name or number in the data entry field results in a drop down menu that lists all matching user name or number. The drop down only displays user extensions. Workgroups and system extensions are not displayed.

The table below the edit box contains the list of users allowed to change the current call handling mode of the subject.

— Add button: Click this button to add the user listed in the edit box to the table.

— Remove button: Select this button to remove the highlighted user/users from the List of users.

### A.2.4 Mode Configuration Panels

Mode Configuration panels configure call handling methods when the specified call handling mode is active. The Option and Configuration window provides access to five Call Handling Mode Configuration panels, one for each of ShoreWare call handling mode.

Figure A-4 displays the Standard Mode Call Handling configuring panel. The other panels are identical in appearance and differ in the available settings for some of the parameters.

![Figure A-4 Options and Preferences: Standard Call Handling Mode panel](image-url)
Refer to Section 4.5.4 on page 36 for Automated Call Handling information.

To access a Call Handling Mode configuration panel, open the Options and Preferences window and select one of the following panels from the menu on the left side of the window: Standard, In a Meeting, Out of Office, Extended Absence, or Custom.

Mode Configuration panel parameters include:

- **Recorded Greeting:** Press this button to record the greeting that callers receive when they reach your voice mailbox.
- **Forward Calls:** This parameter specifies conditions for forwarding inbound calls.
  - **Always:** When selected, all inbound calls are sent to the number listed in the Forwarding Destination box.
  - **When no answer or busy:** When selected, inbound calls are directed to one of two numbers listed in the Forwarding Destination box.
    - One number lists the destination when the call was not answered after a specified number of rings. The other number lists the destination when the call was not answered because the line was busy.
  - **Never:** Selecting this option disables call forwarding.
- **Forwarding Destination:** This parameter displays the destination of your calls that are forwarded and the number of times your phone rings before the call is forwarded. To change the Call Forwarding Destination, press the Edit Destination button.
  - When Call Handling Condition is Always, the field displays one number that receives all of your inbound calls.
  - When Call Handling Condition is When No Answer or Busy, the field displays two numbers:
    - One number specifies a destination for unanswered calls after a specified number of rings.
    - One number specifies a destination for unanswered calls when the line is busy.
  - When Call Handling Condition is Never, the field displays no forwarding numbers.
- **Enable Find Me:** This box enables Find Me call handling when the specified Call Handling Mode is active. Refer to Section 4.5.6 on page 47.
- **When caller presses ‘0’, transfer to:** This field designates the recipient of your call when the caller presses 0 (zero) while listening to the voice mail greeting.
- **Scheduled mode change:** This field specifies the ShoreWare schedule that determines the default period for the specified Call Handling Mode. Section 4.5.4.2 on page 36 describes the correlation between schedules and call handling modes.
- **Voice mail escalation profile:** Escalation profiles specify a list of contacts that are notified when ShoreTel Communicator forwards your calls. Escalation profiles are used for periods when you may receive calls that require immediate attention. Refer to Section 9.5.3 on page 124 for information about Notification Escalation.
- **Call Handling Note:** A Call Handling Note is a text stream provided to the operator who monitors your extension. Notes provide additional information, such as when you plan to return. The Contacts panel displays Call Handling notes. Workgroup Supervisors can also view notes on the Agent Monitor.
A.2.5 Extension Assignment

Extension Assignment is a ShoreWare feature that allows users to reassign their extensions to any phone connected to the ShoreTel System or remote devices accessible to the network, including home phones and mobile devices. Access to Extension Assignment requires system administrator authorization. Refer to Section 4.2.3 on page 28 for more information about Extension Assignment.

The Extension Assignment panel, shown in Figure A-5, specifies the Extension Assignment device, configures other Extension Assignment settings, and activates Extension Assignment for your extension.

To access the Extension Assignment panel, open the Options and Preferences window, then select Extension Assignment in the menu on the left side of the window.

Extension Assignment panel parameters include:

- **Enable Extension Assignment**: Select this option to activate Extension Assignment for your extension.
- **External Number**: This field specifies the number of the phone that receives calls to your extension when Enable Extension Assignment is selected.
Pressing the arrow on the right side of the field displays phone numbers that you previously specified as your external number.

- **Activation**: This option specifies the time when a Extension Assignment call is connected. Select the desired Activation Settings radio button.
  
  — *Accept Call by pressing ‘1’*: The user is prompted to press the numeric key ‘1’ upon receiving an Extension Assignment call. The system connects the call when the user presses the key.
  
  — *Accept Call by answering*: The call to the Extension Assignment device is connected when the user takes the device off hook.

- **Clear Previous Numbers**: Press this button to remove the numbers listed on the External Number and Assignment bar drop-down menus.

### A.2.6 Find Me

Find Me call handling allows callers who reach your voice mail box try to reach you at alternate numbers. You can specify up to two alternate numbers for routing inbound callers trying to contact you. Refer to Section 4.5.6 on page 47 for more information about Find Me.

The **Find Me** panel, shown in Figure A-6, specifies Find Me destinations and configures other Find Me parameters.

![Figure A-6 Options and Preferences: Find Me panel](image)
Appendix A: ShoreTel Communicator for Windows

To access the Find Me configuration panel, open the Options and Preferences window and select Find Me in the menu on the left side of the window.

Find Me panel parameters include:

- **First Number**: This parameter specifies the number of the first device to which callers are routed.
  - **Number of Rings** specifies the times that Find Me rings this number before sending the caller to the second number or voice mail.

- **Second Number**: This parameter specifies the number of the second device to which callers are routed.
  - **Number of Rings** specifies the times that Find Me rings this number before sending the caller to voice mail.

- **Send Incoming Caller ID**: This option programs ShoreTel Communicator to send the Caller ID of the inbound call to the Find Me number.

- **Enable Find Me for incoming calls before playing greeting**: Selecting this option routes calls to the Find Me device without requiring the caller to press ‘1’.

- **Enable record caller’s name for Find Me**: This option enables Announced Find Me, which provides for the recording of the caller’s name for calls routed to Find Me destinations. Callers routed to the user’s Find Me destination are prompted to record their name, which is then played to the call recipient before answering the call.
  - **Record name even if caller ID is present**: Selecting this option requires all callers forwarded to the Find Me destination to record their name for playback to the recipient, regardless of the availability of their Caller ID. This excludes internal users whose name was previously recorded.

A.2.7 Voice Mail

The Options and Preferences Voice Mail panel, shown in Figure A-7, specifies the default interface for listening and recording voice messages, records your spoken name that the system plays to callers routed to your mailbox, and configures your voice mail password.

To access the Voice Mail panel, open the Options and Preferences window, then select Voice Mail in the menu on the left side of the window.

Voice Mail panel parameters include:

- **Play Messages via PC Speakers**: Select this option to program ShoreTel Communicator to play your voice messages through your computer speakers instead of your phone.

- **Record messages using PC microphone**: Select this option to record voice messages through a microphone that accesses your computer’s sound card.

- **Play Envelope Information When Listening to Messages**: Select this option to play sender and receipt time information prior to listening to a voice message.

- **Change Password**: Press this button to change the password that protects access to your voice mail.

- **Record Name**: Press this button to initiate the recording of your name. This recording is played for callers when they are routed to your voice mail.

- **Notification Delivery options**: This parameter specifies the media the system uses to inform the user of the receipt of a voice message. Delivery options available through the drop down menu include:
— **Disabled** – Selecting this option disables Escalation Notification.

— **Email Wave file** – Selecting this option initiates an escalation by sending a copy of the voice message to the specified email address.

— **Email notification** – Selecting this option initiates an escalation by sending an email message that announces the receipt of an voice message to the specified email address.

- **Marked delivered voice mail as Heard**: Select this option to mark the voice message as Heard when a notification message is sent to the specified address. This option is available only if Notification Delivery options is not set to Disabled.

  The system does not initiate Escalation when this option is selected.

- **Deliver to Email Address**: This parameter specifies the address to which the system sends the initial notification message specified by the Notification Delivery Options setting.
A.2.8 Escalation

Escalation Notification is a Voice Mail delivery method that defines a list of addresses that the system can contact when you receive messages that require immediate attention. Section 9.5 on page 122 describes Escalation Notification.

The Escalation panel, shown in Figure A-8, displays a list of your Escalation Profiles. You access an Escalation profile by double clicking its name in the table.

To access the Escalation panel, open the Options and Preferences window, then select Escalation in the menu on the left side of the window.

![Options and Preferences: Escalation panel](image)

Figure A-8 Options and Preferences: Escalation panel

Escalation panel parameters include:

- **Notification Options**: This option specifies the messages that initiate Escalation instances, based on unresolved previous escalation messages.
  
  — **Notify for First Unheard Message** – Select this option to begin an Escalation only if the system is not currently escalating a voice message. The system quits Escalation when a voice message is marked Heard.
  
  — **Notify for Each New Message** – Select this option to begin an Escalation for each voice message, which allows concurrent Escalations.
• **Escalation Notification Profiles**: Escalation profiles designate a roster of contacts that can be notified when you have voice mail that remains marked **Unheard**. The active Call Handling Modes specifies the Escalation Notification Profile that is invoked.

Each row in the table corresponds to an Escalation Profile. Each column lists a profile characteristic that is defined in the Escalation Profile panel.

— **Number**: This parameter is the index number that identifies the profile.
— **Name**: This parameter is the label by which other panels refer to the profile.
— **# Steps**: This parameter lists the number of escalation steps in the profile.

Escalation Notification profiles are configured in the Escalation Notification Profile panel. To open the Escalation Notification panel, double-click the desired profile in the Escalation Notification Profiles table.

### A.2.8.1 Escalation Profile panels

The Escalation Notification Profile panel configures a specified Escalation Profile. To access the Escalation Profile panel, shown in Figure A-9, double-click the desired Escalation Profile listed on the Escalation panel in the Options and Preferences window.

![Escalation Notification Profile panel](image)

**Figure A-9  Escalation Notification Profile panel**

Escalation Notification Profile contains two types of parameters:

- Profile parameters apply to the entire profile and are independent of the step highlighted in the step table.
- Step parameters apply only to the step highlighted in the step table.
Profile Parameters
Profile parameters are located at the top of the panel and include the Profile Name and Repeat Count settings.

- **Profile Name**: This parameter configures the name by which the Notification Profile is referred in other ShoreTel Communicator windows. ShoreTel Communicator panels that refer to Notification Profiles by this label include the Escalation Notification panel in the Options and Preferences Window and each of the Call Handling Mode configuration panels.

- **Repeat Count**: This parameter specifies the number of times the escalation cycle is repeated after completion of the initial cycle. The cycle is discontinued when the original is marked as **Heard**.

Step Parameters
Step parameters are configured individually for each profile step. The following data fields specify the parameter settings for the step number denoted by the table.

- **Timeout**: This parameter specifies the period after the message is sent to the step contact before the system sends a notification message to the contact defined in the next step.

- **Notify me of urgent messages only**: Select this option to initiate Escalation only for messages marked as Urgent. ShoreWare allows callers to mark voice message after recording the message.

- **Email Notification Options**: These parameters specify the media and the address the system uses to inform the step contact of the voice message. Email notification options have not effect on Telephone Notification actions.

  - **Email Notification**: This drop down menu specifies email delivery options:
    - **Disabled**: Selecting this option disables email notification.
    - **Email wave file**: Selecting this option initiates an Escalation by sending a copy of the voice message to the specified email address.
    - **Email notification**: Selecting this option initiates an escalation by sending an email message that announces the receipt of a voice message to the specified email address.

  User Email Address specifies the address to which the system sends voice mail notification messages. This parameter is not available when the Delivery option is set to Disabled.

- **Telephone Notification Options**: These parameters specify the phone or pager number by which the step contact is informed about the voice message. Entering contact information in the phone number field activates all other fields in this panel section.

A.2.9 Outlook

The Outlook panel, shown in Figure A-10, configures interaction parameters between ShoreTel Communicator and Outlook. Chapter 14 on page 169 describes Outlook Integration with ShoreTel Communicator.

To access the Outlook panel, open the Options and Preferences window and select **Outlook** in the menu on the left side of the window.
Outlook panel parameters include:

- **Contact Import**: These parameters control the importing of Outlook contacts.
  - **Import contacts from Outlook**: Selecting this option programs ShoreTel Communicator to import Outlook contacts when ShoreTel Communicator is opened. Press the **Import Options** button to configure the following:
    - **Disk Cache Options** permit the storage of Outlook Contacts in your computer storage, making them available immediately upon opening ShoreTel Communicator.
    - **Import Configuration** options specify the Outlook Contact folder from where ShoreTel Communicator import contacts.
  - **Open Outlook contacts when calls arrive**: When this option is selected, the Outlook Contacts panel becomes active when you receive a call from an Outlook contact.
• **Voice Mail**: This section displays the Outlook Voice Mail Integration status and specifies the disposition of received voice messages. The first two parameters are available only if Voice Mail Integration with Outlook is installed.
  
  — *Attach Voice Mail to Message when Moved*: When this parameter is selected, moving an email from the Outlook Inbox to another folder results in the copying of the attached Voice Message .wav file to the Outlook message file.
  
  — *Delete Voice Mail from Message when Moved*: When this parameter is selected, moving an email from the Outlook Inbox to another folder results in the removal of the attached Voice Message from the ShoreWare server.
  
  — *Integration Installation status*: The message at the bottom of the Voice Mail section indicates Outlook Voice Mail Integration Status.
    
    ▶ If Voice Mail Integration is not installed and Outlook is available, the panel displays an **Install...** button next to the status.
    
    ▶ If Voice Mail Integration is installed, the panel displays an **Uninstall** button next to the status.

• **Calendar**: Calendar integration installs a ShoreTel Communicator panel in the Outlook Calendar Window. The first parameter is available only if Voice Mail Integration with Outlook is installed.
  
  — *Use Outlook appointments to change Call Handling Mode*: When this option is selected, ShoreTel Communicator uses the Outlook Calendar to schedule changes to the Active Call Handling Mode.
  
  — *Calendar Form Installation status*: The message at the top of this section indicates Outlook Calendar Integration Status.
    
    ▶ If Calendar Integration is not installed and Outlook is available, the panel displays an **Install...** button next to the status.
    
    ▶ If Calendar Integration is installed, the panel displays an **Uninstall** button next to the status.

### A.2.10 Workgroups

The Workgroups panel, shown in Figure A-11, specifies the groups to which you belong, determines the workgroups that Queue Monitor and Agent Monitor displays, and configures Supervisor thresholds. The panel is available in Workgroup Agent, Workgroup Supervisor, and Operator ShoreTel Communicator. Chapter 12 on page 147 describes Workgroups.

To access the Workgroups panel, open the Options and Preferences window, then select **Workgroups** in the menu on the left side of the window.

Workgroup panel parameters include:

• **Show alert when call is in queue**: When this option is selected, the PC receives a popup when a call is in the queue of a workgroup to which the user is a member.
  
  — *Alert display time*: This parameter specifies the period the popup window is visible.

• **Table Parameters**: Each line in the table represent one workgroup. The table lists all workgroup to which you belong. Columns that the Workgroup table displays include:
  
  — *Unlabeled Checkbox*: Select this box to display the Workgroup in Queue Monitor and Agent Monitor.
  
  — *Workgroup*: This field lists the workgroup’s name and extension.
ShoreTel Communicator for Windows

Appendix A:

188

Calls in Q: This column lists the number of calls required to trigger a *threshold exceeded* warning in the Queue Monitor. Only Workgroup Supervisors and Operator ShoreTel Communicator users can modify this setting.

Queued Time: This field lists the call time required to trigger a *threshold exceeded* warning in the Queue Monitor. Only Workgroup Supervisors and Operator ShoreTel Communicator users can modify this setting.

A.2.11 Telephony

The Telephony panel, shown in Figure A-12, specifies the manner in which ShoreTel Communicator interfaces with your Telephone.

To access the Telephony panel, open the Options and Preferences window, then select *Telephony* in the menu on the left side of the window.

Telephony panel parameters include:

- **Telephony**: These parameters specify the ShoreWare user name of the ShoreTel Communicator user and the Main Server location of the user's account.
  - **Server name**: This parameter specifies the name or address of the Main Server.
    
    If this server is assigned a Primary and Secondary IP address, this parameter must be set to the server's Domain Name – not the dotted decimal notation. Contact your system administrator for information concerning the system configuration.
  
  - **User name**: This parameter specifies the ShoreWare user name.
    
    This field is *read only* for users authenticated through Active Directory credentials.

---

[Figure A-11 Options and Preferences: Workgroups panel]

Calls in Q: This column lists the number of calls required to trigger a *threshold exceeded* warning in the Queue Monitor. Only Workgroup Supervisors and Operator ShoreTel Communicator users can modify this setting.

Queued Time: This field lists the call time required to trigger a *threshold exceeded* warning in the Queue Monitor. Only Workgroup Supervisors and Operator ShoreTel Communicator users can modify this setting.

A.2.11 Telephony

The Telephony panel, shown in Figure A-12, specifies the manner in which ShoreTel Communicator interfaces with your Telephone.

To access the Telephony panel, open the Options and Preferences window, then select *Telephony* in the menu on the left side of the window.

Telephony panel parameters include:

- **Telephony**: These parameters specify the ShoreWare user name of the ShoreTel Communicator user and the Main Server location of the user's account.
  
  - **Server name**: This parameter specifies the name or address of the Main Server.
    
    If this server is assigned a Primary and Secondary IP address, this parameter must be set to the server's Domain Name – not the dotted decimal notation. Contact your system administrator for information concerning the system configuration.
  
  - **User name**: This parameter specifies the ShoreWare user name.
    
    This field is *read only* for users authenticated through Active Directory credentials.
Appendix A: ShoreTel Communicator for Windows

Figure A-12 Options and Preferences: Telephony panel

- **Change Password**: Press this button to change the password that authorizes the user to access ShoreTel Communicator.

- **Maximum number of active calls to show**: This setting specifies the maximum number of active calls your ShoreTel Communicator instance can handle, as described in Section 4.3.2 on page 30. This setting is bounded by the maximum Call Stack size configured for your extension by the system administrator.

- **Show empty call cells in Normal View**: Select this option to display empty call cells in the Active Call Area of the ShoreTel Communicator window.

- **Show Incoming Call Alert**: Selecting this option programs ShoreTel Communicator to display an Alert in the bottom right corner of your monitor when you receive a voice call. Refer to Section 3.1.1.3 on page 20 for information about Alerts.

- **Suppress call waiting tone for subsequent calls**: Selecting this option disables the Call Waiting Tone, as described in Section 4.3.4 on page 30.

- **Suppress dial-tone when off-hook (headset mode for analog phones)**: Handsfree mode enables you to use ShoreTel Communicator with a headset or speaker phone instead of a receiver, as described in Section 4.3.1 on page 29. Select this option to enable Handsfree Mode.
• **Prefix to dial external number:** This parameter specifies the trunk upon which calls made through ShoreTel Communicator are routed. The available options depend on the trunks configured in the ShoreWare system. Refer to Section 2.4.3 on page 17.

• **Default audio path for automatic off-hook:** This parameter specifies the audio path that ShoreTel Communicator enables when you make or receive a call, as described in Section 4.3.3 on page 30.

### A.2.12 Personalized Call Handling

The Personalized Call Handling panel, shown in Figure A-13, configures the user’s call routing plan. Section 4.5.5 on page 39 describes Personalized Call Handling.

To access the Personalized Call Handling panel, open the Options and Preferences window, then select Personalized Call Handling in the menu on the left side of the window.

![Figure A-13 Options and Preferences: Personalized Call Handling panel](image)

Personalized Call Handling panel parameters include:

• **Rule Table:** The rule table, located in the top half of the panel, lists the rules defined by the user and lists them in the priority. Rules are listed in the order that the system uses them to evaluate inbound calls. Table columns and components include:
— **Rule Buttons:** Rule buttons are located at the top of the panel and control the creation, modification, and removal of Call Handling Rules from the Rule Table.

- Pressing the New Rule button opens the Condition Setup panel. A new rule is added to the Rule Table upon successful completion of the setup panels.
- Pressing the Modify Rule button opens the Condition Setup panel and fills the parameters with the settings of the rule highlighted in the Rule Table.
- Pressing the Delete Rule button removes the highlighted rule from the Rule Table.

— **Rule List:** The Rule list displays the list of call handling rules defined by the user. Rules are listed in order of their usage priority; higher priority rules are listed first. List columns include:

  - **Rule:** This column displays the name of the rule.
  - **Action:** This column displays the call handling action triggered by the rule when the corresponding condition is satisfied.
  - **Enabled:** This column indicates the status of the rule.
    - To enable a rule, mark the Enabled box.
    - To disable a rule, clear the Enabled box.

— **Priority button:** The buttons located right of the rule list changes the priority of the highlighted rule by moving it up or down in the rule list.

- **Rule Description:** The Rule Description field, located in the bottom half of the panel, displays the conditions and call handling actions of the highlighted rule in the Rule List. Clicking on hypertext accesses a dialog box that modifies the condition or action specified by the hypertext.

### A.2.13 Instant Messaging

ShoreTel Communicator users configure their Instant Messaging settings from the Instant Messaging panels. The Options and Preferences window contains three Instant Messaging panels, as described in the following sections.

#### A.2.13.1 Instant Messaging panel

The Instant Messaging panel specifies the IM account username and password required to access the user's IM account on the Presence Server. The panel also controls messaging display options.

Refer to Chapter 5 on page 77 for more information on Instant Messaging.

To open the Options and Preferences Instant Messaging panel, shown in Figure A-14 open the Options and Preferences window and select *Instant Messaging* in the menu on the left side of the window.

Instant Messaging panel parameters include:

- **User name** and **Password:** This parameter specifies the IM address for which ShoreTel Communicator displays instant messages. The user's IM address is configured in the IM ID data entry field in the Director's Edit User panel for the user.
- **Show Alert for:** These parameters configure the behavior of popup messages that alert the user of an incoming message.
— **Show incoming message alert**: Setting this option enables ShoreTel Communicator to display popups that alert the user of an inbound IM.

— **Show text of message**: When this option is enabled, IM Alerts display the text of the inbound message.

— **Number of seconds to display alert**: This field specifies the period that IM alerts remain on your monitor.

- **Show time stamps**: When this option is selected, Instant Messaging windows display the time and date that messages were sent and received for all messages in the Instant Messaging panel.

- **Initiate instant messaging when double clicking on a contact in the Contact pane**: When this box is marked, double clicking a Contacts Viewer contact initiates an instant message to that contact.

- **Show all chats in single window**: Select this option to display all Instant Message sessions in a one message window. The session that the text panel displays is specified by chat tabs located on the right side of the window. Refer to Section 5.2 on page 77 for more information.

- **Warn me before closing chat window**: Select this option to display a prompt every time you attempt to close the Instant Message window.

---

**Figure A-14 Options and Preferences: Instant Messaging panel**
• **Save chat transcript to:** Select this option to save all IM conversations to the specified address.

• **My domain user name and Instant Messaging name are not the same:** Select this option if your Active Directory user name is different from your ShoreTel user name. Enter the user name recognized by the presence server in the Name field.

IM configuration options available in other Options and Preferences panels include:

• **Sounds panel:** This panel specifies the sound that the computer plays when it receives an instant message.

### A.2.13.2 Presence panel

The **Instant Messaging: Presence** panel configures the IM and Telephony display options.

To open the Options and Preferences Presence panel, shown in Figure A-15, open the Options and Preferences window and select **Presence** in the menu on the left side of the window.

![Options and Preferences: Instant Messaging – Presence panel](image)

**Figure A-15 Options and Preferences: Instant Messaging – Presence panel**

Presence panel parameters include:

• **Presence Options:** The selected radio button specifies the presence indicators that the Contact Viewer displays:
— **one combined telephony and instant messaging presence**: Contacts viewer displays a single presence icon that indicates the user's combined presence state. Section 6.2.3 on page 84 describes the combined presence indicator.

— **separate telephony and instant messaging presences**: Contacts Viewer displays two presence icons to indicate the user's telephony and IM presence.

- **Set Presence to “Idle” after specified minutes of activity**: When this parameter is selected, the user's IM presence state is changed to Idle after the inactivity period, specified by the data entry field, at the user's computer. When this parameter is not selected, the user's IM presence state does not automatically change on the basis of a computer inactivity period.

### A.2.13.3 Privacy panel

The **Instant Messaging: Privacy** panel controls the display of presence information to other system users. Users can also restrict Instant Messaging access to their account from this panel. Section 6.4 on page 85 describes IM Presence Privacy.

To open the Options and Preferences Privacy panel, shown in Figure A-16 open the Options and Preferences window and select **Privacy** in the menu on the left side of the window.

![Options and Preferences](image)

*Figure A-16 Options and Preferences: Instant Messaging – Privacy panel*
The Privacy Invitation settings section, located at the top of the panel, determines the user's Presence access request method when the system setting for the user is set to User Defined.

When the Class of Service is not set to User Defined, this section is grey and the option is read only. The system administrator can provide information about system privacy settings.

The invitation handling section provides the following options:

- **auto accept invitation**: All requests are accepted. When the user receives a request, a notification popup indicates a requestor was granted access to the user's presence settings.
- **prompt to accept invitation**: The user receives a popup when another user requests presence access. The request is processed by clicking a popup option.

The Presence Permissions table, located on the right side of the panel, configures the presence access setting for listed users. Users in the table are assigned one of the following permissions:

- **Allowed**: Presence information is available to users that are set to this value.
- **Blocked**: Presence information is not available to users that are set to this value. Instant Messages and presence access requests from the user are blocked.
- **Pending**: This state indicates that the user has not responded to the party's request for IM presence status.

To add a user to the list, press the Add button located below the table.

To edit a user's permission setting, select the user in the list and press the Edit button.

To remove a user from the list, select the user in the list and press the Delete button.

To sort by name or permission, click on the column heading of the desired key.

To search for a name, click the Name column heading, then start typing the desired name.

### A.2.14 Conferencing

The Conferencing panel specifies the user name and password of the Converged Conference account that ShoreTel Communicator accesses when you initiate a Converged Conference. Section 4.7.2 on page 61 describes converged conferencing.

To open the Conferencing panel, shown in Figure A-17 open the Options and Preferences window, then select Conferencing in the menu on the left side of the window.

Conferencing panel parameters include:

- **User name and Password**: These fields specify login parameters your Converged Conference Bridge.
- **Test Login**: Press this button to initiate a login attempt to the Converged Conference Bridge with the listed User name and Password.
A.2.14.1 Initiating a Web Conference with Converged Conferencing

A new button is available on the call cell to start a web conference with Converged Conferencing. The button is displayed to the right-hand side in the button list, right before Call Notes.
A.2.15 SoftPhone

The SoftPhone panel configures SoftPhone device settings. Section 7.3 on page 90 describes the SoftPhone panel.

To access the SoftPhone panel, shown in Figure A-19, open the Options and Preferences window and select SoftPhone in the menu on the left side of the window.

![Options and Preferences: SoftPhone panel](image)

Figure A-19 Options and Preferences: SoftPhone panel

SoftPhone panel parameters include:

- **Sound Devices**: These data entry fields specify the sound device that SoftPhone uses. Sound devices available to your computer are listed in Control Panel: Sounds in Vista or Control Panel: Sound and Audio Properties in other operating systems.
  - **Play**: This option specifies the device SoftPhone uses for playing audio transmissions to the user. Drop down menu contents is derived from the available devices in the Sound and Audio Properties panel that is accessed through the MS Windows Control Panel.
  - **Record**: This option specifies the device SoftPhone uses for receiving audio transmissions from the user. Drop down menu contents are derived from the available devices in the Sound and Audio Properties panel that is accessed through the MS Windows Control Panel.
— **Use Only Configured Devices:** Selecting this option restricts the list of available devices in the Recording and Playback menus to those previously configured through MS Windows.

- **Audio Device:** This option specifies the device through which the user accesses SoftPhone.
- **Network adapter:** This option specifies the Network Interface Card through which the SoftPhone performs audio calls.
- **Endpoint Name:** This data field identifies the string through which ShoreWare controls the SoftPhone as an MGCP device.

### A.2.16 Video

The Video panel configures Video Call settings. Section 4.7.3.5 on page 63 describes the **Options and Preferences: Video** panel.

To access the Video panel, shown in Figure A-20, open the Options and Preferences window and select **Video** in the menu on the left side of the window.

![Options and Preferences: Video panel](image)
The following parameters are configured from the Video Options and Preferences panel:

- **Automatically request video when calling**: Users select this option to request a video call when initiating voice calls with users authorized for video calls.

- **Accept video requests from others**: This option programs a user's automatic response to video call requests.
  - **Always**: Select this option to enable video when the initiator requests video.
  - **Never**: Select this option to reject all initiator requests to use video. You can activate video later in the call even when this option is selected.
  - **Ask me**: Select this option to receive a video inclusion prompt when an initiator requests video.

- **Video camera**: This parameter specifies the video device that ShoreTel Communicator uses to perform the video call.

- **Configure Camera**: Pressing this button accesses a panel that configures brightness, contrast, and saturation settings for the video device.

  While many cameras compensate for poor lighting conditions, this compensation usually impacts the frame rate of the device. Using optimal lighting conditions is essential to ensure the proper frame necessary for good image quality.

### A.2.17 Sounds

The Sounds panel, shown in Figure A-21, specifies the sound files that the computer plays to indicate a communication event. ShoreTel Communicator supports wav files for play audio alerts.

To access the **Sounds panel**, open the Options and Preferences window and select **Sounds** in the menu on the left side of the window.

- **Select**: The Sounds table lists the events to which ShoreTel Communicator assigns a wav file. Other panel settings are valid for the highlighted event.

- **Sound File**: The Sound File specifies the wav file that ShoreTel Communicator plays to signal the event specified by the Sounds table. Click the arrow on the right side of the data entry field to view a list of available files.
  - Press the **Play Sound** button to play the .wav file.
  - Press the **Browse** button to search your computer for additional wav files.
A.2.18 Languages

The Language panel, shown in Figure A-22, specifies the language the system uses for ShoreTel Communicator panels, Voice Mail prompts, and IP Phone instructions.

To access the Language panel, open the Options and Preferences window and select Language in the menu on the left side of the window.

- **Language used in ShoreTel Communicator**: This parameter specifies the language through which ShoreTel Communicator panels display information.
  - **System Default** refers to the language designated by the administrator as the default language. Language changes are enabled after ShoreTel Communicator is exited and restarted.

- **Language used by voice mail and IP phones**: This parameter specifies the language the system uses from your IP Phone display messages and voice mail audio prompts.
Figure A-22 Options and Preferences: Language panel
Symbols

.csv file, export Directory to ........................................ 89
.NET Framework ......................................................... 5

A
active call area ......................................................... 16
active Call Handling Mode ......................................... 36
Add Contact panel ................................................. 96
Agent Monitor ..................................................... 150–152
alert
  inbound call ..................................................... 33
alerts ............................................................... 12
AMIS voice mail .................................................. 130
answering voice calls ............................................ 33
application button ............................................... 13
assignment bar .................................................. 14
audio path, default ............................................... 30
auto-attendant transfer ......................................... 50
automated attendant .............................................. 35
automated call handling ......................................... 36
automatic off-hook ............................................... 30

B
barge in .............................................................. 65
BCA see bridged call appearance
Bridged Call Appearance Monitor ..................... 155–157
bridged call appearance, description .................. 155
broadcast distribution list ...................................... 124

calendar integration ............................................ 169
call cells .......................................................... 16
Call Handling Mode
  configuration panels ......................................... 177
Call Handling Mode preferences ......................... 176
Call Handling Modes ............................................. 36
  active mode ..................................................... 36
  manual mode transitions ................................... 38
call handling, automated ...................................... 36
Call Manager
  exiting ............................................................. 7
Call Manager types
  Personal .......................................................... 1
  Workgroup Agent ............................................... 3
Call Manager, accessing ........................................ 6–7
call on hold ......................................................... 53
call park ........................................................... 54
call recording ....................................................... 56
call routing slips ................................................ 70
call sender of voice message ................................. 119
call stack size .................................................... 30
call transfer, see transfer, calls ......................... 30
call waiting tone, suppressing ......................... 147
calls, simultaneous limit ....................................... 30
closing Call Manager ........................................... 3
combined presence .............................................. 80
combining satellite windows ................................ 17
conference bridge ............................................... 61
conference calls ................................................ 58–61
Conference panel .................................................. 59
conferencing preferences ..................................... 195
conferencing, converged ...................................... 61
consultative transfer ............................................ 50
Contact Center .................................................... 159
Contact viewer ................................................... 93–99
contacts
  adding directory entry ...................................... 90
  Contacts viewer .................................................. 157
  contacts, importing from Outlook ..................... 167
  content area ................................................... 17
  converged conferencing .................................. 61
  conversation, Instant Messaging ....................... 73
  creating an instant message .............................. 76
  custom schedule ............................................... 37

call recording ....................................................... 56
call routing slips ................................................ 70
call sender of voice message ................................. 119
call stack size .................................................... 30
call transfer, see transfer, calls ......................... 30
call waiting tone, suppressing ......................... 147
calls, simultaneous limit ....................................... 30
closing Call Manager ........................................... 3
combined presence .............................................. 80
combining satellite windows ................................ 17
conference bridge ............................................... 61
conference calls ................................................ 58–61
Conference panel .................................................. 59
conferencing preferences ..................................... 195
conferencing, converged ...................................... 61
consultative transfer ............................................ 50
Contact Center .................................................... 159
Contact viewer ................................................... 93–99
contacts
  adding directory entry ...................................... 90
  Contacts viewer .................................................. 157
  contacts, importing from Outlook ..................... 167
  content area ................................................... 17
  converged conferencing .................................. 61
  conversation, Instant Messaging ....................... 73
  creating an instant message .............................. 76
  custom schedule ............................................... 37
device assignment ................................................ 27
dial tone suppression ............................................ 29
Directory item details panel ................................. 90
Directory viewer ................................................. 87–92
Distribution Lists Details panel ......................... 125
distribution lists, voice mail ................................. 124–129
DTMF tones, sending ............................................. 57

E
ending a voice call ................................................ 58
escalation ......................................................... 122–124
Escalation preferences ........................................ 183
escalation profile ................................................. 122
escalation profile configuration ................................. 184
exiting Call Manager ............................................ 7
extension assignment ........................................... 27
external number prefix ......................................... 10
### ShoreWare Call Manager Manual

**F**
Find Me ........................................... 47
Find Me preferences ............................ 180
forward voice message ......................... 118

**G**
general preferences ............................ 173
go arrow, QuickDialer .......................... 14
guided transfers ................................. 52

**H**
handsfree mode .................................. 29
hardware requirements ........................ 4
History viewer ................................... 67–70
hold .................................................. 53
holiday schedule ................................ 37
home device ...................................... 27
hot key
setting active call handling mode .......... 38
SoftPhone ....................................... 85

**I**
importing Outlook contacts ................... 167
inbound call alert ............................... 33
initiating an IM conversation ............... 74
initiating voice call ............................. 31
installation ..................................... 5
Instant Message window ..................... 73
instant messaging ............................... 73–76
presence ......................................... 78
instant messaging preferences ............. 191
integrating Outlook calendar ............... 169
intercom calls .................................. 63
intercom transfer .............................. 50

**K**
keypad ............................................. 57

**L**
language .......................................... 9
language preferences ......................... 200
listen to voice message ....................... 117
logging into and out of workgroup ......... 146

**M**
mailbox transfer ............................... 50
mailboxes, voice mail .......................... 111
main menu ...................................... 13
Main Window ................................... 11
Make New Call panel ......................... 32
making voice call .............................. 31
manipulating Call Manager windows ...... 17–21
messages, voice see voice messages .... 112

- microphone, SoftPhone ................. 86
- mode configuration panels ............... 177
- multiple voice calls ....................... 50
- muting SoftPhone .......................... 86

**N**
night bell ........................................ 34
notification escalation, voice mail ....... 122–124
notification, voice mail ...................... 121–122

**O**
off-hook preference ......................... 30
office anywhere .............................. 28–29
Office Anywhere preferences ............... 179
on-hour schedule .............................. 36
opening Call Manager ......................... 7
operating systems requirements .......... 3
operator ......................................... 146
Options and Preference window .......... 173–200
Outlook ......................................... 169
importing contacts ........................... 167
Outlook calendar integration ............... 169
Outlook preferences ......................... 185
Outlook voice mail ......................... 168
overhead page ................................. 64

**P**
panels
- Add Contact .................................. 96
- Conference .................................. 59
- configuring Call Handling Modes .... 177
- Directory item details ..................... 90
- Distribution List Details ................. 125
- make new call ................................ 32
- Park .......................................... 55
- Transfer ..................................... 51
- park ......................................... 54
- Park panel .................................. 55
- Personal Call Manager ..................... 1
preferences
- Call Handling Mode ......................... 176
- conferencing ................................ 195
- Escalation .................................. 183
- Find Me ..................................... 180
- general ...................................... 173
- instant messaging .......................... 191
- language .................................... 9, 200
- Office Anywhere ......................... 179
- Outlook ...................................... 185
- QuickDialer .................................. 174
- SoftPhone .................................. 197
- sounds ....................................... 9, 199
- telephony ................................... 188
- trunk access code .......................... 10
- video ....................................... 198
- voice mail ................................... 181
- workgroups ................................. 187
prefix for external calls ............................... 10
presence ........................................ 77–84
instant messaging ................................. 78
telephony ........................................ 77
presence types .................................... 77
profile, escalation .............................. 122
profile, escalation configuration .............. 184
Queue Monitor .................................... 147–149
QuickDialer ....................................... 14
QuickDialer preferences .......................... 174
receiving instant messages .................. 75
record voice message .......................... 120
recording a call .................................. 56
redial button, QuickDialer .................... 14
reply to voice message ........................ 118
requirements, system .......................... 3
routing slips ..................................... 70
satellite window ................................. 12
combining ........................................ 17
move into main window ........................ 21
separating ........................................ 17
schedules ......................................... 36–38
send voice message ............................ 120
sending an instant message ................. 76
sending calls to automated attendant .... 35
sending calls to voice mail ................... 35
separating satellite windows ............... 17
silent monitor ................................... 65
simultaneous call limit ....................... 30
SoftPhone
  description ...................................... 85–86
  device assignment ............................. 28
  muting ......................................... 86
SoftPhone preferences .......................... 197
sounds ............................................ 9
sounds preferences ............................. 199
speed dial ....................................... 107
Speed Dial viewer ............................. 107–109
starting Call Manager ........................... 6
status bar ........................................ 17
step, escalation .................................. 122
subject header, voice message ............ 120
suppressing call waiting tone ............. 30
suppressing dial tone .......................... 29
system distribution list ...................... 124
system requirements ........................... 3
telephony preferences .......................... 188
telephony presence ............................. 77
tokens, QuickDialer ............................ 15
tones, sending .................................. 57
toolsbars ......................................... 14
transfer call
  to a Directory contact ....................... 35
transfer calls
  guided ......................................... 52
transfer panel ................................... 51
transfer, calls
  description ..................................... 50–53
trunk access code ................................ 10
unpark ............................................ 54
user distribution list ......................... 124
VGA Video requirements ....................... 4
video calls
  voice calls
    adding video .................................. 62
video hardware requirements .............. 4
video preferences ............................. 198
view voice message information ............ 121
viewer, Contacts .............................. 157
viewer, Directory ............................. 87–92
viewer, Voice Mail ............................ 113–117
viewers
  History ....................................... 67–70
  viewers, Contact ............................ 93–99
  viewers, Speed Dial ......................... 107–109
  viewers, Voice Mail ......................... 157
voice call
  adjusting volume ................................ 50
  alert .......................................... 33
  answering ..................................... 33
  ending ......................................... 58
  handling multiple calls ................... 50
  hold ............................................ 53
  initiating ..................................... 31
  intercom ....................................... 63
  overhead page ................................ 64
  parking a call ................................ 54
  recording ..................................... 56
  unparking a call ................................ 54
voice mail
  AMIS .......................................... 130
  mailboxes ..................................... 111
  preferences .................................. 181
  sending calls to ............................. 35
  transfer to .................................... 50
  using Outlook ................................ 168
voice mail notification ....................... 121–122
voice mail notification, voice mail escalation 122–124
Voice Mail viewer ............................ 113–117, 157
voice message
  view information ................................ 121
  voice messages
call sender ...................................................... 119
description ...................................................... 112
edit subject header ............................................. 120
forwarding ........................................................ 118
listening ........................................................... 117
recording and sending ........................................ 120
replying ............................................................ 118
volume, adjusting ............................................... 50

W
whisper page ....................................................... 65
window components ........................................... 13–17
window manipulation, Call Manager ................. 17–21
window types ....................................................... 11–13
windows
  Instant Message ................................................. 73
workgroup
  call wrap-up ..................................................... 147
  loggin in and out ............................................... 146
workgroup agent ............................................... 145
Workgroup Agent Call Manager ..................... 3
workgroup preferences ...................................... 187
workgroup supervisor ...................................... 145